Problemas en la actualización de virtualmart  

Página 1 / 2
 
Manuel Jesús
 Manuel Jesús
Reputable Member

Buenas tardes.

He actualizado virtualmart a la versión 3.2 creo recordar era la última, cuando a terminado de actualizar se me ha quedado el panel de administración en blanco y la web también.

Necesito una solución. Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 22/03/2017 7:55 pm
Manuel Jesús
 Manuel Jesús
Reputable Member

lo he solucionado con una copia de seguridad, pero la actualización de virtual mart da fallos ;(

ResponderCitar
Respondido : 22/03/2017 9:11 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba reinstalando la extensión, la puedes descargar desde:
http://virtuemart.net/

Descomprime el archivo y luego instala tanto el componente virtuemart como el componente AIO.

De ser posible te sugiero realizar estas pruebas de actualización en un clon de tu sitio.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/03/2017 9:38 pm
Manuel Jesús
 Manuel Jesús
Reputable Member

Hola Jhon.

He hecho lo que me dijiste pero ahora tengo otro fallo, es cuando me meto en un producto para editar el precio o subir otra foto del mismo me sale la siguiente pantalla ;(

He hecho un backup para volver a la versión anterior de virtualmart pero tampoco me funciona, también he probado otro navegador y en diferentes dispositivos y pasa lo mismo

ResponderCitar
Respondido : 24/03/2017 4:10 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Limpia la cache de tu navegador o verifica en otro navegador si te sucede lo mismo.

Si sigues con problemas prueba reinstalar también com_virtuemart.

Recuerda que si tienes aún problemas tiene disponible copias del sistema de backups
https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-seguridad-superbackup/

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/03/2017 6:18 pm
Manuel Jesús
 Manuel Jesús
Reputable Member

He solucionado el error de antes cuando entraba en productos, pero ahora cuando me hacen los pedidos no me aparece en el correo electrónico ni en pedidos de virtual mart LOS CAMPOS PERSONALIZADOS DEL PRODUCTO, es decir en este caso las tallas, sale como que han comprado el producto pero no sale el campo personalizado para saber que talla es.

ResponderCitar
Respondido : 24/03/2017 7:31 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Puedes enviar una captura de pantalla para ve a que te reiferes exactamente?
Verifica si creando un nuevo producto con atributos te sucede lo mismo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/03/2017 9:09 pm
Manuel Jesús
 Manuel Jesús
Reputable Member

Hola.

1.Si he creado un producto nuevo y he puesto el campo personalizado en este caso llamado TALLA he hecho el pedido de prueba y pasa lo mismo.

2. He creado un campo personalizado con diferente nombre y mismo atributos y sigue pasando lo mismo. (cambiando atributos también pasa)

3. Adjunto una foto del correo del pedido desde que he actualizado, se vera la compra de unos zapatos y no se vera la talla por debajo justo del nombre ese es el fallo (La talla es el campo personalizado).

4. Adjunto en la segunda antes de actualiza como veréis aparece la talla (Campo personalizado) justo por debajo del nombre.

ResponderCitar
Respondido : 24/03/2017 9:24 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Entiendo que el problema sólo lo tienes en las notificaciones por correo.

Puede ser que el template que estes usando tenga sobreescriendo archivos de correo de virtuemart, prueba cambiando temporalmente de template y realiza un pedido y verifica si te sucede lo mismo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/03/2017 3:37 pm
Manuel Jesús
 Manuel Jesús
Reputable Member

Hola.
Sigue sucediendo lo mismo, he probado clonar el campo personalizado y lo mismo. Crear campos nuevos y nuevos productos y sigue igual. Es como si los campos personalizados no existieran

ResponderCitar
Respondido : 25/03/2017 3:57 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Has probado cambiando de template?, a uno que te venga por defecto?

Al actualizar virtuemart te apareció algún error?, prueba reinstalando virtuemart y también el componente AIO, lo puedes descargar , descomprimir y luego instalar desde
http://virtuemart.net/

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/03/2017 5:08 pm
Manuel Jesús
 Manuel Jesús
Reputable Member

Hola

He probado todo lo que me has dicho Jhon y sigue igual. He hecho copias de seguridad desde 1 mes atrás pero nada. Y el problema que recibo pedidos y no se que talla coge el cliente. Puede ser alguna opción del nuevo virtual mart?.

El tema del campo personalizado no que solo no parezca en el correo electrónico es que tampoco en el pedido ni en el carrito a la hora de efectuar la compra. Con otras versiones más antiguas que he ido instalando si funciona los campos personalizados pero me da el fallo en la ficha de producto como explique en los mensajes anteriores.

Es como si el campo personalizado no estuviera activado o algo por el estilo he creado uno nuevo y demás pero con todos los campos personalizados pasa lo mismo, no parece ninguno, otro problema que me incumbe en este error es que el cliente no sabe que talla ha elegido ya que no aparece en el carrito.

Necesito una solución lo antes posible. Gracias de antemano

ResponderCitar
Respondido : 26/03/2017 5:38 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Manuel, Buenos Días.

Puede ser alguna opción del nuevo virtual mart?.
En principio no, por defecto tendría que mostrar las variaciones

ok, vamos a ver si podemos solucionarlo.
Por favor ¿ puedes adjuntarnos una factura para que veamos su estructura ?

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 28/03/2017 10:19 am
Manuel Jesús
 Manuel Jesús
Reputable Member

Hola Pepe, Buenos días y gracias por contestar a mi problema.

Supongo que harás visto el hilo entero del tema, cuando actualice a virtualmart 3.2 me surgió este fallo antes no me pasaba, pensé que era un fallo en la instalación pero lo he vuelto a instalar como 10 veces 🙂 y sigue igual. He hecho copias de seguridad días atrás y se arreglaba el fallo de los campos personalizados pero tenía el fallo que cuando entraba en un producto no salía el panel de editarlo saltaba una ventana bastante rara, que se soluciono cuando actualice otra vez, pero los campos personalizados volvían ha fallar. He probado hacer copias de seguridad antigua y instalar versión por versión de virtualmart 3.1.18,3.3.18 y así sucesivamente hasta llegar a la 3.9.19. Con estas versiones los campos personalizados funcionaban, pero la ficha de producto no. adjunto foto.

He creado productos nuevos + campos personalizados nuevos y no hay manera. El fallo creo que es de la actualización porque sólo pasa con virtualmart 3.2. Cuando estas haciendo la compra el campo personalizado en este caso la talla tampoco le aparece al cliente ni en pedidos de virtual mart. Te adjunto las capturas que me has pedido de las facturas verás como en una sale la talla y en otra no.
1.En la que aparece la talla (Campo personalizado) es con virtual mart 3.0.18 (Pero esta versión me empezó a provocar fallo desde que hice la copia de seguridad para quitar la instalación de virtual mart 3.2).

2. En esta que no parece la talla es con virtual mart 3.2. Qué como he explicado anteriormente no es sólo en la factura sino también en pedidos virtualmart y en él carrito antes de efectuar la compra.

Gracias de antemano

ResponderCitar
Respondido : 28/03/2017 12:08 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba asignar una variación de precio a algunos atributos y luego realizar una orden de prueba que incremente el precio, verifica si te aparece el precio cambiado cuando seleccionas algún atributo, eso para probar si se esta almacenando de alguna manera el atributo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/03/2017 7:02 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro