Seo y Virtuemart  

Página 1 / 3
 
Isabel
 Isabel
Usuario experto

Hola,

primero de todo felicitaros por el foro y daros las gracias por vuestra ayuda!

Quería comentar que cuando activo los parámetros de optimización de SEO para la tienda online que he creado con virtuemart (arrovaflors.cat - aún no activa) veo que no aplica bien estos parámetros cuando clico en la tienda y selecciono alguna categoría o producto.. Hay alguna solución?

Muchas gracias!

Isabel

Isabel

Citar
Respondido : 28/11/2010 9:52 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Isabel

Puedes revisar el siguiente post del foro en donde se trata este tema.

https://www.webempresa.com/foro/6-Joomla-15/1783-optimizaci%C3%B3n-para-buscadores.html#1788

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/11/2010 2:52 pm

Cursos Gratuitos WordPress

Isabel
 Isabel
Usuario experto

Hola John,

pues he hecho lo que pone en ese hilo de debate ( subir el archivo router.zip a la raíz de components/com_virtuemart y me sigue sin salir una url amigable

🙁

hay que descomprimirlo?

Gracias

Isabel.

Isabel

ResponderCitar
Respondido : 28/11/2010 6:36 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Isabel

Si, es necesario descomprimir, de manera que tengas un archivo router.php

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/11/2010 6:40 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Isabel
 Isabel
Usuario experto

hola de nuevo

gracias..pues ahora parece que si que va, aunque la ruta que me da es francamente larga ... por ejemplo

http://www.arrovaflors.cat/ca/component/virtuemart/details/13/28/flor/bola-flor-seca-fantasia.html

por otro lado he perdido los módulos que están asociados a esa página, es algo normal??? esto también me pasaba sin haber subido el archivo router.php, pensaba que se solucionaría con esto...

gracias

Isabel

ResponderCitar
Respondido : 28/11/2010 6:56 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola Isabel,

Si te refieres a los módulos que se tienen que mostrar cuando se carga la tienda lo que tendrías que hacer es crear un elemento de menú que enlace contra Virtuemart, en caso de que no lo tengas.

Si no quieres tener ese enlace en el menú principal una opción es que crees en algún menú que no estés usando, como el menú de usuario.

Luego, tendrías que entrar en los módulos que quieres cargar en la tienda, y en la asignación del módulo, seleccionar el nuevo elemento de menú de Virtuemart. En caso de que ya lo tuvieras, tienes que asegurarte que esos módulos tengan asignado el elemento de menú de la tienda.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/11/2010 10:07 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Isabel
 Isabel
Usuario experto

Gracias por tu respuesta Pablo,
pero a no ser que te entienda mal, creo que eso que me dices ya lo he hecho desde el principio..el problema no es que no me salgan los módulos con la tienda, el problema es que cuando activo los parámetros SEO no se ven los módulos, que vuelven a aparecer si desactivo el SEO...

No le ha pasado a nadie anteriormente esto? debo hacer algo mal...

🙁

me parece que dejaré sin activar el SEO con todo lo que conlleva... cachis!

gracias

Isabel

ResponderCitar
Respondido : 29/11/2010 2:55 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola Isabel,

Necesitaría ver la web con el SEO activado para ver las urls que se construyen. Por favor, activa de nuevo el SEO y quita el estado de mantenimiento de la web para que la podamos ver.

Las urls amigables se deberían comportar correctamente en Virtuemart con el archivo router.php. Un ejemplo de tienda con urls amigables sería la siguiente:

http://www.bonsaliments.cat/botiga/details/228/24/lactics-i-formatges/lactics-naturals/llet-fresca-ampolla-plastic-1l.html

Fíjate que construye la url a partir de los nombres de las categorías y el nombre del producto.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/11/2010 12:49 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Isabel
 Isabel
Usuario experto

Hola Pablo,
acabo de activar el SEO y la web para que veas lo que psa, por favor avísame cuando ya lo hayas visto para no tener el sítio activado porque la web no está en funcionamiento todavía!

Gracias

Isabel

Isabel

ResponderCitar
Respondido : 30/11/2010 12:57 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola Isabel,

Lo que he visto mientras tenías la web activada es que realmente no parece que tengas publicada la tienda en ningún elemento de menú, es decir, no hay ningún elemento de menú que sea de tipo Virtuemart.

Esto sería necesario para poder vincular de forma correcta los módulos a la tienda, ya que los podrías asociar con este elemento de menú.
De otra forma, no habrá un ItemId que se pueda asociar con los módulos.

Si no quieres que la tienda se muestre en ningún elemento de menú visible prueba a crear el elemento de menú en un menú que no estés publicando en la web, como el menú de usuarios.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/12/2010 9:48 am

Cursos Gratuitos WordPress

Isabel
 Isabel
Usuario experto

Hola Pablo!!!

ahora he entendido que me decías...y si...ese era el problema....lo tendré en cuenta en próximas ocasiones..

Ahora ya se visualiza todo correctamente!

Muchísimas gracias por la ayuda y por la paciencia!

Isabel

Isabel

ResponderCitar
Respondido : 01/12/2010 10:11 am
Isabel
 Isabel
Usuario experto

Hola de nuevo,

acabo de darme cuenta que al activar el SEO gracias a las indicaciones que me habéis dado ya se visualiza correctamente la tienda en arrovaflors.cat...pero ahora he detectado otro error, que es que no funciona el botón de terminar pedido cuando me encuentro en el carrito de la compra...me redirige a la página principal de la tienda..dónde salen las categorías.

Alguna idea...

Por cierto, ahora tengo desactivada la tienda...está en modo catálogo... si necesitáis que la active, decírmelo y lo haré

Mil gracias

Atentamente

isabel

Isabel

ResponderCitar
Respondido : 09/12/2010 12:35 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola Isabel

El problema con la terminación del pedido, ¿te ocurre solo cuando activas el SEO o siempre? Esto es algo raro porque en otros Joomla con el SEO activado y el archivo router.php colocado no existe ese problema.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/12/2010 12:48 pm
Isabel
 Isabel
Usuario experto

Hola Pablo,
pues sólo me ocurre con el SEO activado...cuando lo desactivo me funciona perfectamente...

Isabel

Isabel

ResponderCitar
Respondido : 10/12/2010 1:21 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Lucas
 Lucas
Miembro Admin

Hola Isabel,

Tendríamos que ver la tienda y simular un pedido para ver el link del finalizar pedido.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/12/2010 12:34 pm
Página 1 / 3

Por favor Iniciar Sesión o Registro