Avisos
Vaciar todo

Virtuemart 3.0 no funciona en Joomla 2.5  

 
LHW
 LHW
Estimable Member

Buenas tardes,
Siguiendo las instrucciones de este hilo: https://www.webempresa.com/foro/27-Joomla!-25/144229-Renovacion-de-web.html
He realizado un clon de la web, y he instalado en Joomla 2.5.28, Virtuemart 3.0
Me da el siguiente error:

Ahora, no funciona la web (la de pruebas, por suerte) Al entrar en cualquier producto la página se queda en blanco.
Producto en web en produccion con Virtuemart "antiguo": Contenido solo visible a usuarios registrados

Citar
Respondido : 23/08/2015 8:01 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola

Puntos a tener en cuenta:

1. Para utilizar VirtueMart 3.0.9 estable tienes que utilizar la versión estable de Joomla 3.4.3.
2. Para Joomla 2.5.28 se sigue recomendando VirtueMart 2.6.19 estable.
3. Para instalaciones que trabajen con multiidiomas, deben mantenerse en Joomla 2.5.28 con VirtueMart 2.6.19 hasta que no sea liberado Joomla 3.5. LTS estable.

Son recomendaciones que deberías tener presentes para sacarle partido a Joomla y VirtueMart en armonía.

Saludos

ResponderCitar
Respondido : 23/08/2015 8:38 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

LHW
 LHW
Estimable Member

Hola Luis,
Gracias por la aclaración.
Unicamente he seguido los pasos que me han aconsejado tus compañeros en el siguiente hilo: https://www.webempresa.com/foro/27-Joomla!-25/144229-Renovacion-de-web.html
Primero asegurate de tener la última versión de tu Joomla en la rama 2.5, es decir la 2.5.28
Luego sería recomendable primero que actualices tu virtuemart, de la versión que tienes a las 3 ya que esta versión también funciona en Joomla 2.5
Solo un fragmento de la conversación.
Como puedes ver, se me aconseja actualizar a Virtuemart 3.0.8.
Ya habia intentado anteriormente realizar esta actualización y me pasó exactamente lo mismo que me ha pasado ahora, por ello la he hecho en un clon de la página.
Supongo que unicamente debo ya eliminar el clon de la página en el servidor y en el administrador de archivos, y esperar a Joomla 3.5. LTS estable para cambiar de Joomla y de Virtuemart. (Estaré pendiente. Y mil gracias por el consejo)
Ahora bien, ¿Puedo "adecentar/renovar mi web cambiando a una template que funcione con mi Joomla y mi Virtuemart, pero con las características que necesito?
Las que actualmente tengo instaladas no me sirven (necesito cambiar tantas cosas de la plantilla que con lo que tengo es imposible)

Es decir,¿ puedo cargar la web en una nueva plantilla para resolver los problemas que tengo actualmente (, menus, y página de detalles de los productos, plantilla responsitive. etc etc) con Joomla 2.5.28 y Virtuemart
2.6.19 ? y si la respuesta es afirmativa, ¿recomendais alguna página en particular donde pueda descargar plantillas que sea fiable?
Gracias por tu atencion.
Saludos.

ResponderCitar
Respondido : 23/08/2015 8:53 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola

La pregunta que yo considero importante es:

¿Trabajas con multiidiomas en VirtueMart actualmente?

Esta pregunta es la que marca la diferencia entre actualizar o no a VirtueMart 3.0.9.4 con Joomla 3.4.3 ¡ni más, ni menos!

Si luego actualizas, no se de donde ha salido que tiene que pasar por VirtueMart 3.0.8 (primera noticia) ya que no existe tal afirmación por parte del core de desarrollo de VirtueMart.

Saludos

ResponderCitar
Respondido : 23/08/2015 9:16 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

LHW
 LHW
Estimable Member

Buenas tardes,
¿Trabajas con multiidiomas en VirtueMart actualmente?
Esta pregunta es la que marca la diferencia entre actualizar o no a VirtueMart 3.0.9.4 con Joomla 3.4.3 ¡ni más, ni menos!

Si, es una tienda multilingüe.

No se me aconseja pasar a la 3.0.8, se me aconseja pasar a la versión 3.0 de Virtuemart. (en ningun momento de la conversación se ha especificado cual, ni por vuestra parte ni por la mia)

El paquete que existia en el gestor de extensiones de mi administrador como "actualizaciones pendientes" es el 3.0.8., es a la que he actualizado en dos ocasiones, y es la que en dos ocasiones me ha dado error.
¿Significa que con la .9 debería funcionar? Por lo que comentas ni 3.0.8 ni 3.0.9 son para mi de momento.

Por otro lado, estoy buscando la versión de Virtuemart acabada en 2.6.19 y aqui http://dev.virtuemart.net/projects/virtuemart/files la ultima que veo es la .18. La buscaré

Intentaré averiguar si es posible cambiar o no de plantilla con mi Joomla y Virtuemart actuales.

ResponderCitar
Respondido : 23/08/2015 9:48 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola

No se me aconseja pasar a la 3.0.8, se me aconseja pasar a la versión 3.0 de Virtuemart. (en ningun momento de la conversación se ha especificado cual, ni por vuestra parte ni por la mia)

¿Quien te aconseja eso?

El propio desarrollador de VirtueMart, Max Milbers, recomienda que para instalaciones con "multiidiomas" de Joomla, se trabaje con Joomla 2.5.28 y VirtueMart 2.6.18 (la .19 fue retirada por errores).

Esto es lo que recomiendan quienes desarrollan VirtueMart, por lo que cualquier otra fuente que recomiende que actualices a Joomla 3.4.3 con VirtueMart 3.0.9.4 "en una instalación con multiidiomas" es bueno que te argumente bien el porque cambiar, ya que experimentarás problemas con la gestión de multiidiomas en VirtueMart 3.0.9.4

Saludos

ResponderCitar
Respondido : 24/08/2015 2:09 am

Cursos Gratuitos WordPress

LHW
 LHW
Estimable Member

Buenos dias Luis,
A la 3.0 se me aconsejo en este foro para realizar los cambios que quería hacer, la duda era como realizar los cambios que quiero hacer en la web. www.webempresa.com/foro/27-Joomla!-25/144229-Renovacion-de-web.html
Estos cambios los quiero hacer porque hace meses se me aconsejó hacerlos y en aquel momento no podia, y porque en la pantalla del backend me sale un aviso para que los haga. Si no son necesarios, o no son aconsejables no los voy a hacer.
Lo que si quiero hacer es cambiar la plantilla. para hacer las mejoras que me son necesarias. Porque la actual se me ha quedado obsoleta.
Y, en cuando a la version 19 . Para Joomla 2.5.28 se sigue recomendando VirtueMart 2.6.19 estable., fue lo que me comentaste, pero la dejo en el 18.

Un saludo

ResponderCitar
Respondido : 24/08/2015 11:15 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Si quieres cambiar la plantilla que estás utilizando actualmente lo puedes hacer, siempre y cuando la nueva plantilla que vayas a utilizar sea compatible con Joomla 2.5, que es lo que tienes actualmente.

Por ejemplo, todas las plantillas para tienda que tenemos para Joomla te podrían servir:

https://www.webempresa.com/crear-web-con-joomla.html

Por supuesto, puedes utilizar cualquier otra plantilla compatible con Joomla 2.5, aunque es muy aconsejable que la plantilla elegida esté adaptada a Virtuemart, para que el diseño de la tienda sea bueno.

ResponderCitar
Respondido : 24/08/2015 3:38 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación