Foro de soporte WordPress en español


Soporte WordPress en español Soporte gratuito para webs alojadas en Webempresa.com
Habilitado para todos los clientes con planes de Hosting Alto Rendimiento a partir de 3GB y planes XL.

No ofrecemos soporte a webs alojadas en servidores externos o localhost, ni soporte css o programación.

Te recomendamos que leas esta información sobre nuestro sistema de soporte en el foro, te ayudará a sacar el máximo partido de nuestro conocimiento: Cómo podemos ayudarte.


Encuentra la solución a tu problema, buscando en nuestro foro:
Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme
Resuelve tus problemas y dudas con la instalación y actualización de PrestaShop.
Especialistas PrestaShop en español

TEMA: Perdida de imagenes al regenerar miniaturas

Perdida de imagenes al regenerar miniaturas 3 años 1 mes antes #255728

Hola, he perdido unas imagenes de categorias que subi hace una par de dias al regenerar miniaturas y limpiar la cache varias veces, os cuento:

- Estuve incluyendo las imagenes de algunas de las categorias (para que aparecieran ilustrando las subcategorias, los cuadros con su nombre debajo en el teme default bootstrap). Esto fué antes de actualizar prestashp a la ultima version antes de ayer.

-Despues he estado acabando de incluir las imagenes, ya despues de actualizarlo de las que me faltaban. Total que son muchas categorias unas 300 y es un trabajo hasta que lo automatice, por ahora voy una a una.

- Luego estuve probando las opciones tamaños de imagen pero para productos y regeneré las imagenes, pero el servidor se corto el tiempo y salio el mensaje ese de nginx. Por otro lado estuve peleandome con el tema del recaptcha y para probarlo por si acaso varias veces vacie la cache.

- Las imagenes que puse despues de la actualizacion no salen, y sigue asi. Total que intenté varias veces mas la regeneracion de imagenes marcando todas y que se borren antes. Luego probé solo con las de las categorias y al final no salen. Las de los productos si salen (fallan algunas pero si salen)

¿sabeis que puede ser? he visto donde se guardan y aparecen los archivos y las imagenes estan bien pero no aparecen los datos de esos archivos en el cuadro de imagen de esas categorias y si se mantienen en las previas a la actualizacion.

Una cosa que observé es que cuando me puse a seguir incluyendo imagenes despues de actualizar, es que incluyó ademas de la imagen de miniatura de categoria (que es la unica que puse), la de portada de categorias tambien. Luego segui incluyendo solo la de miniatura en las restantes, al igual que hice antes de actualizar. Despues de regenerar miniaturas solo se mantuvieron las primeras.

bueno, quizás una explicación algo extraña, pero a ver si se os ocurre donde esta el problema, ya que a veces regenero miniaturas y no quisiera volver a tener que meter imagenes de nuevo por haberlas perdido.

Saludos y gracias.

URL del sitio: Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.
Mejora la velocidad de tu WordPress

Perdida de imagenes al regenerar miniaturas 3 años 1 mes antes #255733

Hola,

Las pruebas no se realizan sobre una web en producción sino sobre un clon:
- Clonar una instalación de PrestaShop a otra carpeta del Hosting - www.webempresa.com/blog/item/1572-clonar-una-instalacion-de-prestashop-a-otra-carpeta-del-hosting.html

Luego en el clon, es recomendable realizar la prueba de regenerar con pocas imágenes en caso de tener éxito realizar la prueba con bloques, si te muestra algún problema de recursos te recomiendo que envíes un ticket a soporte desde tu área de clientes para que revises los limites de tu cuenta.
Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.
trasladar web gratis

Perdida de imagenes al regenerar miniaturas 3 años 1 mes antes #255738

Gracias Johnny, de acuertdo, lo haré por bloques la proxima vez.

No obstante no es necesario para regenerar solo las del bloque de categorias (que son las que necesito) un ticket para aumentar el tiempo del servidor ya que son pocas en relacion con los productos que son varios miles. Lo que quisiera es saber si se os ocurre saber que ha podido pasar en cuanto a lo que hace prestashop en estos procesos si fuese posible.

Muchas gracias y saludos
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.
solucionar problemas wordpress

Perdida de imagenes al regenerar miniaturas 3 años 1 mes antes #255748

Hola Enrique, Buenos Días.

Estoy intentando ver lo que indicas y no consigo encontrarlo.

¿ Puedes indicarnos una URL donde aparezca lo que nos comentas ?

Un saludo
  • Pepe
  • Avatar de Pepe
  • DESCONECTADO
  • Administrador
  • Mensajes: 19481
  • Gracias recibidas 1555
  • Karma: 555
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

Perdida de imagenes al regenerar miniaturas 3 años 1 mes antes #255796

Hola Pepe, parece que he dado con lo que era. Ahora se mantienen al regenerar las categorias.

Hay dos tipos de imagenes de categorias entre otras: (ver imagen)
- la imagen de portada de categoria
- la miniatura de la imagen de categoria

En la version 1.6.0 yo metia solo las imagenes en las miniaturas (tengo activado que se muestren las imagenes de subcategorias) y al actualizar a la version 1.6.1, además me creó automaticamente la imagen de portada de la categoria. ¿por que? se ve que la nueva version ha cambiado esto y para que las imagenes se regeneren deben hacerlo a partir de la imagen, no de la miniatura. Igual lo hacia antes tambien y no me habia dado cuenta.

Como tras actualizar, yo seguí metiendo solo las imagenes de miniaturas, no se rellenaron automaticamente y se perdieron al regenerar.

Total, que hay que incluir las imagenes de categorias en las de portada, y no en las miniaturas y si las quieres iguales, deben tener el mismo tamaño.

www.compuelectro.es (te indico la web por si se te ocurre otra cosa al respecto)

Saludos y gracias
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.
Los siguientes usuarios han agradecido: Pepe

Perdida de imagenes al regenerar miniaturas 3 años 4 semanas antes #255829

Hola Enrique.

Me alegro que se solucionara ;)
Como siempre agradecerte que compartas tu solución :cheer:

El comportamiento de prestashop es el que tu expones, las miniaturas se generan de la imagen de portada automáticamente a no ser que quieras una imagen de miniatura distinta a la de la portada.

Un saludo y gracias por compartir
  • Pepe
  • Avatar de Pepe
  • DESCONECTADO
  • Administrador
  • Mensajes: 19481
  • Gracias recibidas 1555
  • Karma: 555
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.
Los siguientes usuarios han agradecido: Enrique

¿Te ha resultado interesante esta entrada del foro?

Suscríbete para recibir consejos y trucos útiles para tu Web.

Perdida de imagenes al regenerar miniaturas 3 años 4 semanas antes #255842

Un saludo y muchas gracias por confirmarme el comportamiento de prestashop, eso es lo que queria saber.
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.

Temas Relacionados

14 Respuestas emo
Tema iniciado 3 años 8 meses antes por JOEL
1638 Visitas
3 Respuestas emo
Tema iniciado 5 años 11 meses antes por Juan Manuel Gonzalez Santana
2202 Visitas
3 Respuestas emo
Tema iniciado 3 años 1 mes antes por Pilar
3078 Visitas
1 Respuestas emo
Tema iniciado 1 año 3 meses antes por Juan Fco
632 Visitas
5 Respuestas emo
Tema iniciado 5 años 1 mes antes por Enrique
1240 Visitas
25 Respuestas emo
Tema iniciado 2 años 4 meses antes por Mª ISABEL
  • Página:
  • 1
  • 2
1308 Visitas
5 Respuestas emo
Tema iniciado 2 años 5 meses antes por Oriol
1011 Visitas
1 Respuestas emo
Tema iniciado 2 años 4 meses antes por Dagmar
904 Visitas
3 Respuestas emo
Tema iniciado 1 año 5 meses antes por ROSA MARIA
405 Visitas
3 Respuestas emo
Tema iniciado 2 años 4 meses antes por Dagmar
971 Visitas

Moderadores: Pablo Velasco
Tiempo de carga de la página: 0.492 segundos