Foro de soporte WordPress en español


Soporte WordPress en español Soporte gratuito para webs alojadas en Webempresa.com
Habilitado para todos los clientes con planes de Hosting Alto Rendimiento a partir de 3GB y planes XL.

No ofrecemos soporte a webs alojadas en servidores externos o localhost, ni soporte css o programación.

Te recomendamos que leas esta información sobre nuestro sistema de soporte en el foro, te ayudará a sacar el máximo partido de nuestro conocimiento: Cómo podemos ayudarte.


Encuentra la solución a tu problema, buscando en nuestro foro:
Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme
  • Página:
  • 1
  • 2

TEMA: Módulo ReCaptcha no funciona: estoy usando el correcto?

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #222947

Hola, el modulo "Módulo ReCaptcha" no funciona. No aparece nada al por ejemplo registrar una nueva cuenta de cliente, sale un error de imagen no disponible y nada mas. He tenido que desinstalar el modulo para que puedan registrarse los clientes. He visto los foros relacionados vuestros pero no me solucionan nada.

He visto que el autor no es prestashop y ya no se si esto es asi por defecto o he instalado el mismo por error u otra cosa. (uso el tema por defecto default bootstrap) version prestashop 1.6.0.14. Ver imagen.

He probado desinstalando y reiniciando el modulo.

Mi pregunta es si hay otro que me recomendeis gratis que no de problemas, y por supuesto como podria arreglarlo primero.

URL del sitio: Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.
Mejora la velocidad de tu WordPress

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #222949

Hola Enrique,

Con el módulo de recaptcha que tienes por defecto con prestashop debería funcionarte.

Este modulo puede activarlo en la pestaña modulos --> módulo recaptcha, donde tendrá que poner las claves publica y privada.


Además de instalar, activar y configurar el módulo de Recaptcha, son necesarias otras acciones para conseguir que el recaptcha funciona.

Tendrías que indicarnos, de forma detallada, los pasos que has seguido para configurar el recaptcha en tu PrestaShop. Indícanos mediante imágenes como lo has confiigurado

Revisa el siguiente vídeo:



Del mismo modo, vete al directorio modules/recaptcha/lib de tu PrestaShop y reemplaza el archivo recaptchalib.php por el que te adjunto comprimido en un zip. Antes haz una copia del archivo recaptchalib.php que tenías por si se producen errores.

Con este cambio el recaptcha se tendría que cargar en el sitio correcto.

Saludos
Adjuntos:
  • Julen
  • Avatar de Julen
  • DESCONECTADO
  • Administrador
  • Mensajes: 2891
  • Gracias recibidas 288
  • Karma: 70
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.
trasladar web gratis

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223309

Es muy complicado esto, perot te digo lo que he hecho y lo que pasa. Pero antes te quisiera indicar, que creo recordar que antes (digamos al recien instalar la plantilla) aparecia la imagen con un numero de una puerta y no recuerdo tener que haber configurado nada. No se por que se ha estropeado, creo que desde que instale el smartblog, aunque son suposiciones mias.

dicho esto, con el modulo recaptcha de jose manuel bermubo instalado, al pinchar "contacto" en lo alto de mi tienda (tema default bootstrap), me daba un error y una pagina en blanco con un enlace hacia google recapcha. Por otro lado registrar como nuevo cliente si dejaba hacerlo pero con el modulo desisntalado. Ahora despues de meter las claves de google y lo del php al pinchar el boton crear una cuenta (mando foto), se queda la misma pagina pero en blanco.

Ahora he hecho lo del recaptchalip.php y he pinchado en el enlace de google y me ha dado dos claves. Las he puesto y funciona "contacto" (la pagina con aspecto de sobre de colores rojo y azul, solo para mandar correos), pero cuando pincho en "enviar" en esta pagina da un fallo el recaptcha que no puede mostrar imagenes, lo mismo que me decia antes el otro resgistro.

Lo del enlace google antes no me salia hace tiempo. Aparte lo de google me saca unos codigos para meter aqui y alla y ya me pierdo aun mas (mando foto). Además no se como ha entrado google en el recaptacha de mi web.

La verdad es muy engorroso, no se si me he explicado. Espero me ayudeis a solucionarlo. ¿no habra un modulo por ahi que sea instalar y listo?

De todas formas muchisimas gracias y espero tus indicaciones ya que ahora si que tengo un follon con los registros de nuevos clientes y los contactos.

Saludos y gracias
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.
solucionar problemas wordpress

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223335

Hola,

No conozco ningún módulo gratuito que sirva para añadir un captcha de forma automática El siguiente módulo lo añade al formulario de registro de usuarios, pero parece que no lo hace para el formulario de contacto:

addons.prestashop.com/es/aplicaciones-front-office-prestashop-modulos/8041-new-customer-email-verification-and-google-recaptcha.html

Lo más probable es que el problema haya venido por actualizar PrestaShop a una nueva versión. Para conseguir un correcto funcionamiento del recaptcha es necesario modificar 2 archivos del tema que se está usando.

En tu caso, puesto que tienes la web en mantenimiento, no se qué tema de PrestaShop estás utilizando. Tendrías que quitar este estado o indicarnos el tema que estás utilizando.
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Moderador
  • Mensajes: 20369
  • Gracias recibidas 2734
  • Karma: 758
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.
Los siguientes usuarios han agradecido: Enrique

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223362

Gracias pablo parece que ya has dado con la tecla. El tema y version lo indico al comienzo de este tema, es el default bootstrap y la version es 1.6.0.14.

Tengo en mantenimiento para que no se registre nadie con estos errores, pero si lo necesitas lo activo de nuevo. Podras arreglarlo por favor?

saludos y gracias
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223375

Hola

Entiendo que ya tienes colocadas las claves en el módulo de recaptcha de prestashop

Para trabajar con el módulo de recaptcha que tiene tu prestashop y que aparezca en el formulario de contacto tendrías que hacer modificaciones a los archivos, te adjunto los archivos modificados, deberás hacer una copia de los archivos que tengas

/override/controllers/front/ContactController.php (si esta ruta no existe tendrías que crearla, por ser un overides en la siguiente actualización no se sobreescribirá)

/themes/default-bootstrap/js/authentication.js (este archivo es parte del theme por defecto y se sobreescribe en cada actualización)

/themes/default-bootstrap/contact-form.tpl (este archivo es parte del theme por defecto y se sobreescribe en cada actualización)

Adjunto los archivos que debes usar

Saludos.
Adjuntos:
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.

¿Te ha resultado interesante esta entrada del foro?

Suscríbete para recibir consejos y trucos útiles para tu Web.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223552

Chicos, sois unos fenomenos. el formulario de registro funciona fenomeno y ademas sale el recaptcha y funciona bien, si me equivoco sale otra vez, y si le pongo voz, sale un tio en ingles. y pasa a la pantalla del usuario bien mostrando todos los botones para direcciones, deseos, etc.

Pero el formulario de contacto, al pinchar me da un error de que no he puesto el recaptcha, claro, es que aqui no sale el recaptcha. Os mando fotos, a ver de que puede ser. Por cierto el cambio que inicialmente me dijo julen esta hecho y las dos claves que me dió google estan puestas. Os mando foto tambien.

ya queda menos.

gracias y saludos.
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223558

Hola

Envía algunas capturas de pantalla de los reemplazos que has hecho de acuerdo a lo que te indique en mi respuesta anterior, es decir reemplazar o crear los 3 archivos indicados

Si has realizado alguna otra modificación de archivos respecto a esto deberías descartarla

Saludos
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223562

No se que te refieres de las capturas de los pasos que he hecho, puedo poner la mano en el fuego que esta bien hecho, he descomprimido en mi ordenador el que me has enviado, he hecho copia machacando el original en cada destino previa copia de seguridad. ahora hay dos archivos uno de ellos es .bak y el otro el que me has enviado en cada una de las rutas.

Por cierto, la carpeta y ruta de override, existía ya, y acabo de desacer el cambio que me dijo julen en su momento ya que hice una copia.

No he hecho nada mas, he vuelto a contacto y no sale el recaptcha y sigue dando el mismo error que te mande en la imagen anterior al respecto.

que capturas necesitas, del administrador de archivos?

saludos y gracias
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223585

Hola,

Actualmente tienes la web en mantenimiento, por lo que no podemos ver el problema de forma directa para analizar el código que se esta generando.

Tendrías que desactivar ese estado de mantenimiento para que lo podamos revisar.

Del mismo modo, envianos las capturas del administrador de archivos, donde se vean los archivos remplazados y las rutas en las que los has colocado

Saludos
  • Julen
  • Avatar de Julen
  • DESCONECTADO
  • Administrador
  • Mensajes: 2891
  • Gracias recibidas 288
  • Karma: 70
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223596

Aqui tienes las fotos del explorador de archivos.

Activo tambien la tienda. Aunque desactivo los modulos para el pago redsys y transferencia de mientras.

Saludos y gracias
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223607

Hola,

Vemos que esta todo correcto, el problema puede estar con las claves publicas y privadas. Prueba a regenerar dichas claves, y asegurate que las estas introduciendo de forma correcta.

Estas usando el modulo por defecto que trae prestashhop? Dicho modulo se encuentra en módulos --> módulo recaptcha. En caso afirmativo, prueba a desinstalar el modulo y a volverlo a instalar. Una vez instalado, tendrás que poner las claves publicas y privadas generadas.

Saludos
  • Julen
  • Avatar de Julen
  • DESCONECTADO
  • Administrador
  • Mensajes: 2891
  • Gracias recibidas 288
  • Karma: 70
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223615

Eso precisamente es lo primero que os pregunté en este tema y me dijisteis que deberia funcionar. Por lo que supuese que lo habiais mirado. Por favor mirarlo a conciencia por favor al principio. Os dije que el autor no es prestashop y os mande una imagen. En esa imagen precisamente dice que solo vale para registros y precisamente eso es lo que esta pasando.

Ahora he mirado la ruta que me dices y no se donde se ve el nombre del tema o el autor, he abierto sin saber el index.php y me sale entre otros el autor prestashop y no el jose perez de la imagen primera que os mandé, lo que me hace suponer que no es el mismo modulo.

ahora bien si busco en prestashop los modulos recap solo aparece el de jose perez(el que estoy usando). No me aparece como modulo para instalar tampoco (deberia aparecer al estar en esta ubicacion que tu me dices, no? o habria que copiarlo a la carpeta modules que hay dentro del tema?

Lo he desactivado, despues lo he desinstalado y he movido la carpeta fuera de /modules, (está en la raiz de public html) he actualizado en el backoffice y ya no aparece para inastalar ni nada, lo que me hace suponer que si probando hace tiempo con modulos gratis de aqui y alla, igual al instalar éste, ha machacado el original, o vaya usted a saber.

total que creo que lo suyo seria que por favor me dieseis uno nuevo de prestashop para tema default bootstrap y prestashop 1.6.0.14. Eso si ya no lo habeis resuelto vosotros antes claro.

Saludos y gracias como siempre
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223626

Hola,

Al desinstalar el módulo de recaptcha ahora te falla la página de contacto. Tendrías que volver a instalar el módulo, activarlo y configurarlo con la clave pública y privada. Te adjunto aquí el instalador.

Una vez que lo hayas hecho comprueba que te funcione con el formulario de registro y avísanos para que podamos revisar el formulario de contacto.
Adjuntos:
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Moderador
  • Mensajes: 20369
  • Gracias recibidas 2734
  • Karma: 758
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223643

Por favor podeis leer lo que os estoy diciendo? o al menos confirmarme una explicacion a si este que me mandas es el original de prestashop?. Es el mismo que usaba yo, de un tal jose manuel, al instalarlo no lo certifica prestashop, sigue fallando en el modulo de contacto, por que dice que es para registro de cuentas. Os vuelvo a adjuntar la primera imagen que os mandé.

saludos
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223659

Hola

Lo que sucede es que posiblemente el módulo del autor Jose Manuel ya no viene por defecto en prestashop y por lo tanto tendrías que instalarlo de manera manual, usa el módulo que te indicó Pablo ya que los modificaciones a los archivos estan en base a este módulo

Tendrías que instalar manualmente.

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223679

Os pido disculpas por mi insistencia. Si que viene por defecto, por eso me lo estais mandando. He instalado vuestro pack (en otra carpeta de prueba), que ya viene con la version incluso mas nueva (aparece el pinguino de prestashop) y sigue usando el mismo autor ese. A no ser que vosotros hayais modificado eso al instalar el pack prestashop por defecto.

Lo que pasa es que me chocaba al no ser de prestashop. Pero bueno, el desconocimiento juega malas pasadas.

Esta puesto el de pablo, que si es el mismo que yo tenia y para el que me mandaste los tres archivos, debe estar bien. Lo que pasa es que sigue sin funcionar el contacto, el registro si.

bueno la tienda la tengo activada y a la espera que me digais, a ver si lo podemos arreglar.

saludos y gracias
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223690

Hola

Actualmente ya veo que funciona correctametne el captcha en :
Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.

He realizado una prueba de envío

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.
Los siguientes usuarios han agradecido: Enrique

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223711

En efecto funcionan ya los dos. Si señor.

Muchisimas gracias por vuestro apoyo y vuestras soluciones a todos los que ayudais y colaborais en que éste modulo y otros muchos detalles de soporte de vuestros clientes funcionen.

Saludos y gracias como siempre.
  • Enrique
  • Avatar de Enrique
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 363
  • Gracias recibidas 3
  • Karma: 1
El tema ha sido cerrado.

Módulo ReCaptcha no funciona: estoy usando el correcto? 3 años 11 meses antes #223712

Hola,

Gracias por tu confianza :)

Nos alegra que te guste nuestro servicio. :)

Nos sería de mucha utilidad que nos dejases tu testimonio, solicitamos testimonios para colocar en nuestra página y ayudar a otros posibles clientes a decidirse por nuestros servicios:

Puedes crear el testimonio aquí: www.webempresa.com/testimonios.html?view=form&layout=edit

Si nos quieres enviar tu experiencia con nuestro servicio, la publicaremos en nuestra página con un link hacia tu Web. Nuestro dominio webempresa.com tiene una autoridad alta, así que el link siempre te ayudará en el posicionamiento en buscadores de tu Web.

Un experto en SEO te diría que es un regalo que te dejemos poner un testimonio si linkamos a tú página, nosotros decimos "quid pro quo", una cosa por otra, así nos ayudamos mutuamente. :)
Si ya lo solicitamos anteriormente y nos lo facilitaste, puedes dejar otro testimonio si tienes otra página que quieras posicionar mejor al tener un link en la nuestra con tu testimonio.

Gracias por publicar tu testimonio y por tus palabras de agradecimiento.
  • Julen
  • Avatar de Julen
  • DESCONECTADO
  • Administrador
  • Mensajes: 2891
  • Gracias recibidas 288
  • Karma: 70
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.
Los siguientes usuarios han agradecido: Enrique
  • Página:
  • 1
  • 2

Temas Relacionados

5 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 3 años 10 meses antes por jaime luis
1020 Visitas
15 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 1 año 4 meses antes por isabel
1964 Visitas
7 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 1 año 3 meses antes por Antonio Fernández
755 Visitas
13 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 4 años 6 meses antes por Miguel
2168 Visitas
3 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 4 años 5 meses antes por Estructuras y Contratas del Levante SL
1572 Visitas
3 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 1 año 5 días antes por Lorena
265 Visitas
6 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 1 año 4 días antes por Lorena
350 Visitas
1 Respuestas emo
Tema iniciado 1 año 6 meses antes por Enrique
1416 Visitas
8 Respuestas emo
Tema iniciado 1 año 4 meses antes por Jaume
561 Visitas
4 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 4 años 5 meses antes por Benigno A. Carvajal Fernandez
2026 Visitas

Moderadores: Pablo Velasco
Tiempo de carga de la página: 39.066 segundos