Fallo en la configuracion del transportista en prestashop  

 
Enrique
 Enrique
Reputable Member

Hola.

Al configurar el transportista tanto si quieres modificar uno ya creado como si deseas añadir uno nuevo, siempre sale la pantalla en blanco y no aparece nada.

al pinchar en transporte/transportistas

Podeis echarme una mano?

Gracias y saludos.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 26/09/2016 1:09 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Enrique.

El error 500 o pagina en blanco generalmente cuando sucede suele ser porque hay algún fallo en la programación, esto puede suceder si hemos hecho algún cambio en la plantilla del sitio web o si se instalo alguna extensión con algún bug.

Cada vez que se genera uno de estos errores, se genera un fichero error_log y se introduce una línea indicando el motivo del error, el fichero y línea donde se ha producido. Esto nos ayudara para ver donde se producen los errores que aparecen en la web.

Puedes localizarlo accediendo desde cPanel -> administrador de Archivo y despliega la carpeta public_html y edita el fichero error_log.

Adjúntanos los errores que te indica o nos adjuntas el fichero para que podamos revisarlo.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 26/09/2016 3:28 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Reputable Member

Hola.
No me aparece lo del error 500. La pantalla en blanco que sale realmente es el "panel" de trabajo del back office de prestashop lo que sale en blanco. Mira la foto. No aparecen las opciones de configuracion. Es muy extraño.

Por otro lado te mando el archivo de error. Tampoco es eso creo, ya que hace unos dias vi el error ese y es del recaptcha. Desintale y borré todo lo que pude del mismo fijandome en los archivos que tiene una instalacion limpia de prestashop sin ese modulo, y se quitó. No creo que tenga nada que ver.

No he querido borrar el transportista que tengo por miedo a que siga el error y me quede inoperativo el proceso de comprar por no aparecer ningun transportista.

He probado limpiando la caché.

saludos y gracias.

ResponderCitar
Respondido : 26/09/2016 6:23 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Puedes verificar si se ha generado el fichero que comenta Pepe pero en el directorio de administración?

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/09/2016 6:49 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enrique
 Enrique
Reputable Member

Te refieres al html-public/adminwe ?

si, hay un error_log, pero tiene lo mismo del dia 23 para el recaptcha que comenté antes y nada sobre los transportistas. Os mando el archivo.

Una curiosidad ¿no podeis vosotros mirar estas cosas?, o sea, no teneis acceso a mis carpetas cuando solucionais incidencias?

saludos y gracias.

ResponderCitar
Respondido : 27/09/2016 9:04 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Enrique.

¿no podeis vosotros mirar estas cosas?, o sea, no teneis acceso a mis carpetas cuando solucionais incidencias?

No, desde foro no tenemos acceso a ninguna cuenta, cPanel, acceso a web's, etc..., por temas de LOPD

Según veo en los archivos que adjuntas los errores mas actuales son del día 23 por lo que a fecha de hoy tendrían que estar ya solucionados.

¿ Desde cuando te sucede esto ?, ¿ Por casualidad eliminaste algo de cache manualmente desde el administrador de archivos ?

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 27/09/2016 9:50 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enrique
 Enrique
Reputable Member

Hola. Os cuento.

Por culpa del error del recaptcha que me obligo a desinstalarlo y eliminarlo, seguia dando el problema registrado en el error-log antes comentado, borre el contact-controler.php de overrridecontrolerfront y ya no lo registró mas. además el modulo que seguia saliendo en el front office dando problemas desaparecio del todo y todo perfecto. Eso es lo unico o ultimo que recuerdo hacer borrado.

En un clon que tengo en local y que da el mismo problema con el transportista, he copiado en la misma ruta el contact-controler.php, vaciado la cache, cerrado sesion, cerrado el servidor y reiniciado, vaciado la cache del navegador y los favoritos. Nada, sigo con el mismo problema.

Por si acaso he vuelto a hacer lo mismo con el contact-controler que daba el problema del recaptcha (quitando el original) y tampoco funciona.

Espero que podais ahora darme alguna solución. Ya os he dicho todo.

saludos y gracias

ResponderCitar
Respondido : 28/09/2016 1:22 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Entiendo que ya no se generan errores de recaptcha pero aún sigues manteniendo problemas al editar un trasnportistas en tu sitio web del servidor. (Mejor no enredarnos con tu máquina local ya que es otra historia y no conocemos la configuración , etc).

Prueba eliminar el archivo error_log tanto de la raiz de tu sitio como de la carpeta adminwe, verifica entrando a un transportista y verifica si se crea el archivo con errores recientes.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/09/2016 7:47 pm

Cursos Gratuitos WordPress

Enrique
 Enrique
Reputable Member

Hola.
No genera ninguno, en ninguna de las dos carpetas. He probado a añadir y a modificar el que tengo. Siguen saliendo las pantallas sin nada.

Por cierto en mi clon probé a borrar el transportista que tenia por si se arreglaba , nada y además me quedé sin ninguno.

saludos

ResponderCitar
Respondido : 29/09/2016 3:07 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si dispones de alguna actualización en tu PrestaShop, de ser así puedes probar actualizando previa copia de seguridad: https://www.webempresa.com/blog/actualizar-prestashop-1-6-x-a-la-version-estable-disponible.html

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/09/2016 5:00 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Reputable Member

Ya actualicé a la ultima version 1.6.1.7. De hecho asi me aparece en el modulo de actualizacion.

No veis nada para poder arreglar esto?

gracias y saludos

ResponderCitar
Respondido : 29/09/2016 10:34 am
Enrique
 Enrique
Reputable Member

No sigais buscando. Ya lo he arreglado.

Estoy comprobando varias cosas a ver si van y os digo.

saludos y gracias

ResponderCitar
Respondido : 29/09/2016 2:24 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enrique
 Enrique
Reputable Member

Va todo bien.
Hola.

Basta con copiar la carpeta adminwethemesdefaulttemplatecontrollerscarrier_wizard de nuevo, desde una instalacion limpia de prestashop. No copiar los order_carriers porque fallan los pedidos al hacerlos.

saludos y gracias

ResponderCitar
Respondido : 29/09/2016 4:48 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Entiendo que los archivos del theme que tenías te causaban el problema.

Gracias por el aporte

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 29/09/2016 6:54 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enrique
 Enrique
Reputable Member

En efecto. Siempre copiando de una instalacion limpia de la misma version y previamente guardo un zip por si acaso de la carpeta.

Saludos y gracias a vosotros

ResponderCitar
Respondido : 29/09/2016 7:26 pm

Por favor Iniciar Sesión o Registro