Avisos
Vaciar todo

Grupos de clientes y módulo de categorías  

Página 1 / 2
 
Musicvall
 Musicvall
Reputable Member

Buenas tardes:
He agregado en mi tienra prestashop (1.4.9) un grupo de distrivuidores, a los cuales se les aplicará un descuento. Cuando accede el distribuidor a su área de cliente, resulta que no aparece el menú de categorías (imagen adjunta grupo distribuidores). Y al usuario le cambio el grupo de clientes, en este caso al de clientes en general, resulta que sí aparece el menú de categorías. (imagen adjunta clientes en general) Increible pero cierto!
Me podéis ayudar?
PD: No puedo actualizar a una versión más reciente del software.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 27/07/2015 6:06 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes una versión antigua, a la fecha se han corregido varios bugs, podría ser un bug de tu prestashop

Si que podrías evaluar actualizar ya que actualmente esta en la 1.6, sin embargo lo que te sugiero es realizar pruebas primero, sería mejor que clones tu sitio en una carpeta y revisar si la actualización va bien.

Saludos.

ResponderCitar
Respondido : 27/07/2015 10:31 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Musicvall
 Musicvall
Reputable Member

Perfecto. Voy a clonar la web y a actualizar. Pero como actualizo prestashop? Me he descargado la última versión.
Gracias

ResponderCitar
Respondido : 08/08/2015 8:44 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola,

Es importante que revises la nota oficial al respecto de PrestaShop:

https://www.prestashop.com/blog/es/actualizacion-de-seguridad-por-prestashop/#more-13185

Queda claro que lo primero a hacer es una copia de seguridad y que no es fácil actualizar de 1.4.x 1.6.1.0 estable y que deberías primero hacerlo (si o si) en un clon o copia de tu web antes de ponerte a actualizar la instalación que tienes en producción.

Saludos

ResponderCitar
Respondido : 08/08/2015 11:58 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Musicvall
 Musicvall
Reputable Member

Hola:
He leído el artículo completo y es un lío, la verdad.
Yo tengo la versión 1.4.9 y si no he entendido mal, debo actualizar a la versión 1.6.1 directamente (porque los parches sólo son para las últimas versiones de 1.4.X y de 1.5.X), verdad?

Ya he descargado la última versión de prestashop. He hecho un backup completo de mi sitio. Cómo actualizo?
Gracias

ResponderCitar
Respondido : 10/08/2015 1:49 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Comprueba si en el apartado Módulos de tu PrestaShop tienes un módulo de nombre Actualización 1-click o 1-click Upgrade. De ser así, podrías utilizarlo para actualizar PrestaShop.

En el siguiente artículos de nuestro blog se explica cómo hacerlo:

Recuerda que es mejor opción hacer la prueba de actualización en un clon de la web que hacerlo directamente en la web real, aunque hayas hecho un backup de la misma. Ten en cuenta que pueden fallar cosas tras la actualización si tienes módulos en tu web que no son compatibles con PrestaShop 1.6. La plantilla también deberá ser compatible, por lo que tendrás que cambiar casi con seguridad.

ResponderCitar
Respondido : 10/08/2015 3:04 pm

Cursos Gratuitos WordPress

Musicvall
 Musicvall
Reputable Member

En la versión de mi tienda, la 1.4.9, el módulo 1-click Upgrade me permite actualizar a la última versión de prestashop. Pero en la opción de "check" (donde todos los ítems deben estar en validados (en verde)), resulta que me indica que el módulo de 1-click Upgrade tiene una versión antigua y que debo actualizarlo para poder actualizar prestashop. Cómo actualizo dicho módulo?
Gracias

ResponderCitar
Respondido : 10/08/2015 3:46 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Para actualizar el módulo vete en la administración de PrestaShop a Módulos y localiza el módulo 1-click Upgrade. Aquí te tendría que salir un enlace o botón para actualizar el módulo.

Una vez hecho esto podrías volver a la pantalla que comentas para ver si ya se muestra que le módulo está actualizado.

ResponderCitar
Respondido : 10/08/2015 4:30 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Musicvall
 Musicvall
Reputable Member

No existe dicho botón de actualizar. Lo que he hecho ha sido descargar de prestashop.com el módulo y lo he subido por ftp.
Ahora realizo todos los pasos según el artículo del blog que me habéis comentado y pero no consigo actualizar la versión de prestashop. Incluso he subido a admin/autoupgrade/donwload/ y a admin/autoupgrade/latest/prestashop/ la nueva versión y nada de nada.
DEcir que la pestaña de "comparación de archivos", parece que está haciendo un chequeo de comparación de archivos y no aparece, de momento, el listado de archivos nuevos etc.... Es requisito que este listado esté para poder actualizar?
Gracias

ResponderCitar
Respondido : 10/08/2015 5:54 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Lo que te comentó Pablo es actualizar primero el módulo, usualmente debería aparecerte un listado de los módulos a actualizar dentro de la opción de módulos

Una opcion alterna es instalarte un Prestashop 1.6 desde cero y realizar la exportación de tu información desde tu prestashop 1.4,

Si tienes dudas sobre este tema de actualización será mejor abrir un nuevo hilo de discusión con un título adecuado.

Saludos.

ResponderCitar
Respondido : 10/08/2015 6:27 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Musicvall
 Musicvall
Reputable Member

El módulo (1-click upgrade) ya está actualizado a la última versión vía FTP.
La opción alternativa que comenta no se puede contemplar porque hay partes del core de prestashop que están modificadas y que funcionan, y aunque están aisladas para poder actualizar el software sin que se borren, si hago una nueva instalación tendría que rehacer todo lo hecho y es inviable.
Sr. Marreros: el título del hilo es el adecuado. Yo pregunté por mi problema de grupos y usuarios. Si lee desde el principio fue usted quien me dijo que actualizara prestashop y por hacerle caso, ahora tengo dos problemas: que no puedo actualizar (y no sé porqué) y el grupo de usuarios. Por tanto, está dentro todo del mismo hilo, porque por solucionar un problema se ha creado otro y no consigo solucionarlo. Espero que con la actualización se arregle el problema de usuarios. Ya llevo años en el foro de Webempresa.com y sé que el título ha de corresponder al contenido. Gracias

Volvamos al tema en cuestión: no consigo poder actualizar prestashop como muestra la imagen adjunta. Qué pasa? Qué problema hay? No lo entiendo. Aparentemente está todo correcto....
Gracias

ResponderCitar
Respondido : 11/08/2015 6:01 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Lo que te comenté antes

Tienes una versión antigua, a la fecha se han corregido varios bugs, podría ser un bug de tu prestashop

Si que podrías evaluar actualizar ya que actualmente esta en la 1.6, sin embargo lo que te sugiero es realizar pruebas primero, sería mejor que clones tu sitio en una carpeta y revisar si la actualización va bien.

Asumo que estas realizando pruebas en un clon, ya que actualizar de 1.4 a 1.6 requerira tiempo en dejar tu siti operativo, por ejemplo el theme que usas cambiará y que posiblemente tengas que configurar nuevamente algunos módulos.

El problema de actualización en algún momento lo ibas a notar, es decir siempre ha estado allí por lo visto, no es que con mi respuesta te he generado un problema.

Lo que comentas :

La opción alternativa que comenta no se puede contemplar porque hay partes del core de prestashop que están modificadas y que funcionan, y aunque están aisladas para poder actualizar el software sin que se borren, si hago una nueva instalación tendría que rehacer todo lo hecho y es inviable.

Creo que igual si actualizas con clik upgrade no funcionarán las modificaciones que has hecho, que tipo de modificaciones son?, ten en cuenta que vas a saltar dos versiones de ramas principales, si has modificado clases en los overrides asi no se sobreescriban es posible que no funcionen por la estructura , nombre de variables, etc

Desde tu captura no se aprecia bien los parámetros, aunque veo todo marcado correctamente, que tipo de error te aparece cuando tratas de actualizar?

Saludos

ResponderCitar
Respondido : 11/08/2015 7:15 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Musicvall
 Musicvall
Reputable Member

Sí, estoy realizando la actualización en un clon. Si hubiera podido solucionar lo del grupo de clientes sin tener que actualizar prestashop, a día de hoy no lo hubiera hecho, porque creo que es algo muy laborioso la actualización y que requiere mucho tiempo y no tener prisas, y a día de hoy tengo un poco de prisa.

Cuando hice las modificaciones del core, el programador que contraté me confirmó que las modificaciones estaban aisladas y que no habría problema en las actualizaciones.

En la imagen no me marca error y no sé que pasa. El módulo de 1-click es la versión 1.6.4 y no sé si será demasiado alta para mi versión de prestashop 1.4.9....
No sé que pasa....

ResponderCitar
Respondido : 11/08/2015 8:08 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

En tu captura de pantalla hay un mensaje de warning o advertencia que indica que la versión recomendada para la nueva versión debe ser al menos 5.4, envía un ticket de soporte para que te cambie la versión de PHP en tu cuenta y verificar si este puede ser el problema

Saludos.

ResponderCitar
Respondido : 11/08/2015 10:14 pm

Cursos Gratuitos WordPress

Musicvall
 Musicvall
Reputable Member

Gracias.
He contactado con soporte y me han actualizado la versión de Php 5.3 a la 5.4
Ya no me aparece el "warning".
Pero sigo sin poder actualziar. Me explico. Vuelvo al módulo 1-click, no me aparece ninguna problema (solo que no aparece el listados de archivos que van a cambiar, sigue pensando....) , incluso relleno los datos de link y subo a los directorios la última versión de prestashop (todo esto por si acaso)..... Imagen 1.

Hago click en "upgrade prestashop now", me dice que la nueva versión se ha instalado, pero en la zona de prestashop que indica la versión que tienes de la tienda (abajo del todo) sigue apareciendo la anterior versión, por lo que entiendo que no se ha actualizado. Imagen 2.

Yo ya no sé qué pasa ni qué hacer.....

ResponderCitar
Respondido : 12/08/2015 11:46 am
Página 1 / 2