Mensaje de errores en el back office Prestashop  

 
Federico
 Federico

Buenas!

Hoy he entrado al backoffice de mi prestashop y al guardar cambios en el me han aparecido unos mensajes de errores que nunca antes habia visto.

He de decir que el desarrollador de mi theme (de pago) esta realizando cambios en mi la configuaración de apariencia de mi web y la ha puesto en modo depuración(quizas sea esto lo que produce los errores)

Os adjunto una captura de pantalla para que podais indicarme que es lo que provoca estos errores y como puedo solucionarlos.

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 10/07/2018 1:07 pm
Julen
 Julen
Miembro Admin

Hola

Los mensajes que te aparecen no son errores, solo notificaciones, por lo que a priori no deberían generar problemas en la web.

Pueden estar relacionados con un consumo excesivo de memoria de php. Envía un ticket a soporte indicando los mensaje de error que tienes para ver si te pueden aumentar el límite de memoria de la cuenta.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/07/2018 1:28 pm

Cursos Gratuitos WordPress

Federico
 Federico

Buenas

Ya me aumentaron la memoria php de mi cuanta a 2GB y los errores salieron igualmente.

Algun consejo?

Saludos

ResponderCitar
Respondido : 11/07/2018 6:56 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Veo que aparecen errores relacionados con eval(), esta función no se recomienda usar ya que podrías ejecutar código como cadena, lo cual es inseguro, es posible que por defecto este bloqueada esta función en la cuenta de hosting que tienes, consulta nuevamente por tickets sobre esta función y si te la pueden habilitar.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/07/2018 7:17 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Federico
 Federico

Buernas tardes

He hecho exactamente lo que me habeis dicho,y la respuesta de vuestros compañeros ha sido la siguiente:

"Hola Federico,

He comprobado que la función eval funciona correctamente en nuestros servidores.

Te he hecho un código de ejemplo para que puedas comprobarlo. Lo tienes en /home2/ferreide/public_html/ferreidea.com/prueba.php

El resultado puedes verlo en la url siguiente, llamando a este archivo https://ferreidea.com/prueba.php

Un saludo,
Ramón"

¿Siguen saliendo los errores,entonces si esta funcion eval funciona correctamente,aque se deben?¿Como los soluciono?

Te adjunto captura de los errores que siguen saliendo

Gracias por todo!

ResponderCitar
Respondido : 11/07/2018 8:49 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Debe ser un problema con algo de Smarty que es el compilador de los themes.
Algo que podrías probar es desde Parámetros Avanzados > Rendimiento, desactiva la cache, fuerza la cache de smarty y desactiva todos los parámetros CCC

Si sigues con problemas prueba temporalmente cambiar de theme, aunque esto sería mejor que lo hagas en un clon de tu sitio para probar.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/07/2018 10:50 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro