Error ruta imágenes y blog  

 
Joan
 Joan
Nuevo usuario

Hola! He migrado mi web a Webempresa, y para que vaya perfecta faltan dos cositas. la web es esta, para que veáis los problemas: www.musicalexbarcelona.com

El caso es que hay imágenes que no me las carga, y me han dicho desde un ticket de soporte que es porque la url a la que apuntan es esta: www.musicalexbarcelona.com/Wordpress, que es la ruta donde estaba a web en 1&1. Si os fijáis al entrar las imágenes del slider por ejemplo no aparecen.

Con el bloc pasa algo que creo que debe ser por lo mismo. En la página donde se ven los posts se ve la previsualización correctamente, pero al pulsar sobre el bloc la página se queda en blanco. Lo podéis probar pulsando sobre cualquier post.

Cómo puedo solucionarlo?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 27/07/2014 1:04 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Joan,

La web, ¿cuando la tenías en 1&1, estaba en la carpeta /public_html o en /public_html/Wordpress ?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/07/2014 4:16 am

Cursos Gratuitos WordPress

Joan
 Joan
Nuevo usuario

En public_html/wordpress

ResponderCitar
Respondido : 27/07/2014 11:58 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

En el código se puede visualizar que las imágenes siguen cargando en la ruta: Contenido solo visible a usuarios registrados es por este el motivo que no se muestran las imágenes, se tendría que revisar la configuración de dicho slider y corregir la ruta con eso debería de ser suficiente.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/07/2014 6:37 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Joan
 Joan
Nuevo usuario

Ok. Necesitaria un poco de ayuda, ya que al intentar resubir la imagen me da un error. No me la sube. Te puedo pasar quizás mi login para que lo veas?

ResponderCitar
Respondido : 31/07/2014 9:28 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Joan,

El código del archivo /home/conrueda/public_html/.htaccess debe ser:

RewriteEngine On
RewriteBase /musicalexbarcelona.com/
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /musicalexbarcelona.com/index.php [L]


# END WordPress

Ya que la web se encuentra en una carpeta y no en /public_html.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/07/2014 9:54 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Joan
 Joan
Nuevo usuario

Oh!!! Muchas gracias! Ahora ya puedo subirlas. Una última cosa, si voy a la página del bloc puedo previsualizar los posts, pero si pulso sobre el link para abrirlas no van, sólo se abre una pestaña en blanco. ¿A qué se debe?

ResponderCitar
Respondido : 31/07/2014 10:05 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola Joan

Nos comentan los administradores que en tu sitio se estan generando errores en el archivo error_log de tu sitio web con el siguiente mensaje :

[31-Jul-2014 19:18:13 UTC] PHP Catchable fatal error: Object of class WP_Post could not be converted to string in /home/conrueda/public_html/musicalexbarcelona.com/wp-content/plugins/qtranslate/qtranslate_core.php on line 455

Es decir al parecer el hecho de que no muestre correctamente el contenido es debido a que el qtranslate no esta trabajando correctamente. Prueba primero desactivando la funcionalidad de traducción y verifica si con esto se muestra , tendrías que reinstalar el plugin y verificar si te sucede lo mismo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/07/2014 10:22 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola Joan

Adicionalmente, al parecer hay un bug en qtranslate
https://gist.github.com/zioproto/10970990#file-qtranslate_wordpress39-patch

Revisa si tienes las versiones comentadas en el link y prueba editar el archivo del core.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/07/2014 10:29 pm

Por favor Iniciar Sesión o Registro