formulario contact form NO responsive  

 
Enrique
 Enrique
Usuario eminente

Hola buenos días, expongo mi duda:

Estoy haciendo una web a través de wordpress mediante plantillas, a la hora de añadir el clásico formulario contact form, quise distribuirlo en 2 columnas, con un código que encontré en un foro, en la versión pc (o pantalla grande) todo perfecto, los problemas vienen al visionar la web en smartphone o pantallas pequeñas, las celdas se superponen unas con otras, alguna solución para que esto no ocurra? gracias

pd: dejo el código HTML y añado capturas de pantalla:

[radio radio-648 use_label_element default:1 "Particular" "Empresa"]

[submit "Enviar"]

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 10/09/2019 11:30 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Enrique.

Modifica el código del formulario por el siguiente:

Nombre [text* first-name]
Apellidos [text* last-name]
Email [email* your-email]
Teléfono [text* your-phone]
Tu mensaje [textarea your-message]
[submit "Enviar"]

.- Edita el archivo style.css que encontrarás en la ruta wp-content -> themes -> agama-blue " style.css " y añade lo siguiente:

/* Formulario CF7 responsive */
#responsive-form{
	max-width:600px;
	margin:0 auto;
        width:100%;
}
.form-row{
	width: 100%;
}
.column-half, .column-full{
	float: left;
	position: relative;
	padding: 0.65rem;
	width:100%;
	-webkit-box-sizing: border-box;
        -moz-box-sizing: border-box;
        box-sizing: border-box
}
.clearfix:after {
	content: "";
	display: table;
	clear: both;
}

/**---------------- Media query ----------------**/
@media only screen and (min-width: 48em) { 
	.column-half{
		width: 50%;
	}
}

Revisa el resultado y comentas.

Un saludo

ResponderCitar
Respondido : 10/09/2019 12:30 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Usuario eminente

Perfecto! muchas gracias Paco!

Un par de dudas más, tengo un error en el apartado del correo electrónico en el DE (emisor del correo)

"!(error de configuración) El correo electrónico de emisor no pertenece al dominio del sitio."
He visto en algunos videos que es un error de la última actu y que basta con poner un correo inventado con nuestro dominio pero no se me quita...

Y por último, como puedo retirar la sección lateral derecha?(en la foto que mandé puedes apreciarlo) la de últimas entradas, archivos agosto 2019...etc

mil gracias

ResponderCitar
Respondido : 10/09/2019 1:37 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Enrique.

El correo electrónico de emisor no pertenece al dominio del sitio.
Intenta utilizar una cuenta de correo del mismo dominio por ejemplo " info@midominio.xxx "

Cuentas como gmail, outlook, etc... suelen dar problemas a la hora de recibir los avisos.

como puedo retirar la sección lateral derecha?
Solo en la página de contacto ?

No se si tu plantilla tiene opciones para asignar la barra lateral en las páginas que deseas mostrarla.
Comprueba si en la configuración de la plantilla puedes eliminarla el sidebar de la página de contacto

Si no tuvieras opción para ocultar el sidebar en diferentes páginas puedes utilizar un plugin:
-> https://es.wordpress.org/plugins/widget-options/

Una vez instalado accede a Widget y en el bloque sidebar, despliegas lso Widgets y selecciona la página de contacto para que no se muestre.

attachment:1]screenshot-joomlero-cp95.webjoomla.es-2019.09.10-13_48_30.jpg[/attachment]

Si solo quieres que no se muestre en la versión Móvil, selecciona la opción de " Movil "

Si quieres eliminarlo de todas as paginas, solo tienes que eliminar los widgets.

Un saludo

ResponderCitar
Respondido : 10/09/2019 2:52 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación