La bliblioteca de Medios no me reconoce algunas imágenes  

Página 1 / 2
 
Maria Dolores
 Maria Dolores
Usuario activo

Hola, muy buenas.
Primero que nada decir que es éste mi primer post en el foto y le mando un saludo y mi presentación a todos los miembros y administradores de este foro de Webempresa.

Acabo de poner un post que por alguna razón se no ha publicado. Así que pido disculpas si vuelvo a poner este repetido porque no me consta en ninguna parte que se haya publicado.

Disculpas y gracias por vuestra paciencia.

__________________________

 

LA PREGUNTA EN CUESTIÓN

Tengo mi instalación de WP funcionando perfectamente, pero he estado editando posts que no tenían la imagen destacada habilitada, y resulta que la base de datos no las tiene sincronizadas.

Las imágenes es´tan, pero al intentar buscarlas por la biblioteca de medio no aparecen. Busco por el título del archivos, el atributo alt de las imágenes.. nada de nada.

Si abro el cliente de FTP sí que puedo verlas, y por la cantidad que he podido ver son muchas las que tienen este problema.
NUNCA he subido imágenes por FTP, así que supongo que habrá sido en algún proceso que no recuerdo con la base de datos.

Una de las imágenes que no me reconoce es ésta:

 

Contenido solo visible a usuarios registrados

Citar
Respondido : 18/02/2021 5:07 pm
Maria Dolores
 Maria Dolores
Usuario activo

Hola de nuevo.

He estado investigando sobre cómo sincronizar la base de datos con a biblioteca de medios en este artículo:

https://www.tutoriales-wp.com/subir-archivos-multimedia-por-ftp-a-wordpress/

Aconsejan instalar en plugin "Add to Server" de los repositorios WP.

Lo he hecho y he buscado el archivo en cuestión de toda la selva de subcarpetas del la contenedora general .../wp-content/upload/...

Me lo ha tomado el plugin y tras unos segundos me lo ha recuperado perfectamente.

Problema resuelto en parte.

Ahora mi pregunta es si puedo hacer una recuperación general de todo el sistema de .../upload/... en modo bulk.
Supongo que tardará una buen ratos, pero la duda que me ronda es si podría romper algo.

Ahora mismo mi sitio está funcionando sin problemas, y no quiero pensar la que se organizaría si pierdo las imágenes de los posts.

He revisado la documentación del plugin y el creador avisa que no ofrece soporte del mismo.

He sito otro plugin llamado "Media from FTP", que no he probado porque espero que alguien de ustedes me aconseje en la materia.

Muchas gracias por vuestra ayuda. Saludos!

ResponderCitar
Respondido : 18/02/2021 5:22 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Entiendo que has realizado una prueba con una subcarpeta, pero, si usas directamente la carpeta uploads te sincroniza algo con el plugin que has usado?

Saludos.

ResponderCitar
Respondido : 18/02/2021 5:57 pm
Maria Dolores
 Maria Dolores
Usuario activo

@jmarreros

Hola, muchas gracias por la respuesta.

Efectivamente he hecho una prueba exitosa con un archivos concreto y específico en una subcarpeta de la principal "uploads".
Y creo adivinar que si le digo que me muestree toda la carpeta raíz de medios "uploads", me haga un chequeo que me sincronice todo.

Pero... tengo mieditis. No sé hasta qué punto podría tener problemas a posteriori.

El nombre del plugin es "Add from server", que en el post original lo escribí mal.

El plugin tiene buenas valoraciones y está actualizado a hace dos mese, pero el hecho de que el autor me diga que no da soporte, me ha tirado para atrás.

 

Lo voy a probar en mi pc local con localhost en Xampp a ver qué tal funciona.

Admito sugerencias, por supuesto. Yo también estoy aprendiendo.

 

Muchas gracias por vuestra ayuda.

Esta publicación ha sido modificada el hace 2 meses por Maria Dolores
ResponderCitar
Respondido : 18/02/2021 6:07 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Maria,

Estupendo incuso si pudieses hacer una copia del sitio > https://guias.webempresa.com/preguntas-frecuentes/clonar-mi-web/, seria mucho mejor asi trabajas directamente en un entorno parecido al de la wb en vivo.

Esperamos próximas noticias sobre las pruebas, un saludo 🖐️ 

ResponderCitar
Respondido : 18/02/2021 6:40 pm
Maria Dolores
 Maria Dolores
Usuario activo

Muchas gracias @argenis . Le echaré una mirada a la idea de clonar mi sitio.

He probado "Add from server" e localhost y... NO HA FUNCIONADO.

 

Entonces he instalado la segunda opción, el "Media from FTP" y este SÍ QUE HA FUNCIONADO.

A simple vista se ve que es una solución mucho más profesional, con varias opciones.

Esta opción sí que la recomiendo, a falta de probarlo en la web.

Admito sugerencias. Yo también estoy aprendiendo.

Saludos!!

ResponderCitar
Respondido : 18/02/2021 7:15 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba entonces con el plugin que si te funcionó, si tienes suficiente espacio en tu cuenta puedes probar, tal como te comentó Argenis, en un clon de tu sitio antes.

Saludos.

ResponderCitar
Respondido : 18/02/2021 8:17 pm
Maria Dolores
 Maria Dolores
Usuario activo

Hola de nuevo.

Estoy sincronizando todas las imágenes con el plugin inicial, es decir, con el "Add from server".

He empezado a editar todos los posts que no tienen imagen destacada.

Voy al bloque de imagen (ya uso Gutenberg y estoy muy satisfecha con su rendimiento y funcionalidad) y abro el código html de la imagen para ver el nombre del archivo con la ruta desde la raiz /uploads/...

Entonces me voy la nueva pestaña creada por el plugin en media (llamada igualmente "Add from server", y me ubico en la carpeta del mes.

Al principio sólo elegía el archivo en cuestión, pero al ver que me lo recuperaba (voy al posta y compruebo que la imagen destacada ya me aparece en e editor de medios), ya he empezado a mercar todos los archivos de cada carpeta mensual.

Os dejo toda esta información por si le ocurre este problema a alguien más.

Dejos el hilo abierto por si alguien quiere aportar alguna idea adicional, y en unos días lo cierro si sé hacerlo. Y si no les ruego a los administradores que lo hagan ellos por si no atino.

muchas gracias por la ayuda prestada.

 

SOLUCIONADO

ResponderCitar
Respondido : 18/02/2021 11:32 pm

Cursos Gratuitos WordPress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@twerkas
Hola María,

Entiendo que has encontrado una solución que hasta el momento te ha dado resultado.

Dejamos el hilo abierto por si quieres comentar algo mas al respecto o por si alguna otra idea se desea compartir.

No te preocupes, nosotros nos encargamos de cerrar el hilo si acaso no lo hicieras tú.

Quedamos atentos a tus comentarios y dudas adicionales.

Saludos 🙂

ResponderCitar
Respondido : 19/02/2021 12:06 am
Maria Dolores
 Maria Dolores
Usuario activo

Muchas gracias por tu respuesta @bulmaro-webempresa

Bueno... he hecho algunos avances y he llegado a algunas conclusiones basadas en la corta experiencia en el uso de ambos plubins.

El "Add from server" es un plugin sencillo, que no necesita configuración alguna y que me ha funcionado perfectamente en "rescatar" todas esas imágenes de la carpeta de medias "uploads" sin ningún problema.

Es muy cierto que a nivel local (localhost) no me ha funcionado, pero yo creo que es debido a que la instalación de WP con Xampp no cumple las mismas características que la que tengo en alojamiento remoto.

La segunda opción, el "Media from FTP" me ha funcionado estupendamente en local, pero en la web no lo he comprobado porque el primero ha hecho bien el trabajo.

Decir también que aunque "cacharrear" en la base de datos es una maniobra que implica cierto riesgo, en el caso de la instalación local donde no me ha funcionado el primero, he pasado el otro y no he tenido ningún problema.

uiero decir que aunque "Add from server" no me ha podido rescatar los medios, tampoco he detectado ningún desastre o anomalía en ellos.

 

Seguiré informando si encuentro algún datos más que pueda ser relevante para la comunidad.

 

Saludos1

ResponderCitar
Respondido : 19/02/2021 10:28 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Holas Maria dolores.

Muchas Gracias por informarnos, seguro que viene bien a otros usuarios con el mismo problema.

Dejo el hilo abierto por si necesitas retomarlo.

 

Un saludo y de nuevo agradecerte tu aportación al foro.

 

Esta publicación ha sido modificada el hace 2 meses por Pepe
ResponderCitar
Respondido : 19/02/2021 10:53 am
Maria Dolores
 Maria Dolores
Usuario activo

Muchas gracias por tu respuesta @pepesoler

 

Solucionado el problema de rescatar a las imágenes perdidas, tengo que volver a ponerle los atributos, ya que sólo tengo en nombre del archivo y nada más.

Necesitaría que me recomendaran un plugin que ampliara las funcionalidades de la biblioteca de medias para etiquetar nuevamente el "title" y el "alt" de las imágenes.

Soy consciente que sería un tema para poner en el apartado de plugins, pero está tan relacionada con el problema de las imágenes que considero que es mucho más útil en este hilo que abrir uno nuevo.

Si lo consideran oportuno sólo tienen que indicarlo.

Muchas gracias por la ayuda. Saludos!

ResponderCitar
Respondido : 19/02/2021 10:30 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@twerkas

Hola Mariela,

Bien, esta tarea puedes hacerla sin necesidad de plugins -> Contenido solo visible a usuarios registrados

Pero poodrías probar los siguientes:

https://wordpress.org/plugins/update-alt-attribute/

https://wordpress.org/plugins/bulk-image-alt-text-with-yoast/

Si no contesté o intepreté mal tu pregunta, por favor, indícamelo y ayúdame a entenderlo, por favor.

Saludos 🙂

ResponderCitar
Respondido : 19/02/2021 11:38 pm
Maria Dolores
 Maria Dolores
Usuario activo

Muchas gracias por tu respuesta @bulmaro-webempresa

Necesitaré algún tiempo para procesar todos esos datos. Por favor, no cierren este hilo aunque tarde en responder, sigo teniendo problemas con las imágenes.

El siguiente problema es que el plugin me ha rescatado todas las imágenes y mes las ha sincronizado con la base de datos, pero ahora tengo cada archivo de imagen por triplicado.

Se trata de los tres tamaños de imágenes que WP crea cada vez que subo uno a través del gestor de las mismas.

Una solución sería borrar todas las repetidas y dejar sólo la grande. Volverla a descargar y volverla a subir para que vuelva a crear los tres tamaños originales, sin olvidarnos de borrar definitivamente el archivo original.

Un trabajo manual descomunal que no sé si se podría automatizar.

 

¿Alguna sugerencia?

 

P.D.;

He estado prensando sobre el origen de todos estos problemas. El problema no es de WP, ni del tema, ni tampoco de ningún plugin.

Fue un ataque de un hacker que tuve hace bastantes años. El problema ha pasado desapercibido hasta que he vuelto a reeditar mis viejos posts y hace lo propio con sus imágenes.
Espero que no le pase a nadie, porque es una pesadilla.

Saludos!!

ResponderCitar
Respondido : 21/02/2021 4:07 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

@twerkas

Hola,

Una opción sería la de eliminar las miniaturas o imagenes duplicadas dejando únicamente la original, posteriormente podrías usar el plugin de regenerate-thumbnails para que se regeneren las miniaturas de manera automática, ahorrándote así el subir nuevamente imagen por imagen.

Saludos 🙂

ResponderCitar
Respondido : 21/02/2021 7:01 pm
Página 1 / 2