Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

[Resuelto] Menu roto no busca  

 
David
 David
Usuario eminente

El problema viene que cuando yo hago click encima de una categoría del menú, no se me abre ninguna página de productos y me queda con la imagen de fondo y no me muestra el contenido. Uso la plantilla generate press free

Contenido solo visible a usuarios registrados

Respondido : 05/12/2022 3:51 pm
David
 David
Usuario eminente

adjunto fotos del error. La foto 1 es cuando selecciono la categoria del menu y la foto 2 de lo que se muestra, es decir la imagen de fondo sin contenido de la categoria

image
image
Respondido : 05/12/2022 3:58 pm

Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal David,

Creo que hay una confusión en como se ha estructurado el menu

Por una parte tienes opciones como la siguiente https://lagaretagourmet.com/categoria-producto/despensa/el-bierzo/ Donde claramente invocas una categoria de un producto en Woocommerce 

Pero por otra parte tienes esta URL https://lagaretagourmet.com/despensabierzo/ Donde muestras un listado de productos

Considero que hay una discrepancia en como has configurado las categorias y los enlaces de dichas opciones del menu

Echale un vistazo

Saludos!

 

Respondido : 05/12/2022 4:09 pm
David
 David
Usuario eminente

@bruno-vichetti Si eso esta hecho adrede así pero el problema lo tengo que no carga el contenido, es decir, si entro por el menu no me carga el contenido porque si entro por la pagina inicial en las fotos de bodega despensa y packs eso son paginas en las que muestro yo los productos que deseo, pero sin embargo entrando a través de menu por ejeplo en bodega bierzo vino blanco deberia mostrar todos los vinos blanco que tengan esa categoria y no los muestra me queda sin contenido la web. 

Respondido : 05/12/2022 4:23 pm

Cursos Gratuitos WordPress

Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola David,

Puedo comprender lo que quieres lograr pero el inconveniente tal como mencione anteriormente es como gestionas las URL de las categorías

Por una parte tienes una pagina estática con un listado de productos específicos y por otra la pagina que debería de cargar los productos de una categoría determinada no esta funcionando.

Por favor envíanos una captura de como has configurado tus enlaces permanentes, especialmente correspondiente al apartado de categorías de Woocommerce

Saludos!

Respondido : 05/12/2022 4:28 pm
David
 David
Usuario eminente

acabo de crear un menu de prueba con solo una categoría padre de productos y dentro sus respectivas y cuando entro en una el erro persiste, que no se si llamarlo error ya que no muestra contenido en la web, no se si podrá ser tema de caché o que

Respondido : 05/12/2022 4:29 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal David,

Por favor toma especial atención en lo que te he comentado, validemos la configuración de Ajustes-> Enlaces permanentes

image

El apartado de Woocommerce

image

Saludos!

Respondido : 05/12/2022 4:32 pm
David
 David
Usuario eminente

te adjunto fotos de la configuración de los enlaces

image
image
Respondido : 05/12/2022 4:33 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Usuario eminente

al igual que si usas el menu lateral con todas las categorías, no me muestra contenido cuando entro en una cualquiera.

Respondido : 05/12/2022 4:37 pm
David
 David
Usuario eminente

@bruno-vichetti asi lo tengo configurado

Respondido : 05/12/2022 4:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal David,

Indagando un poco mas en tu sitio veo que estas utilizando elementor y un plugin complementario llamado Royal Addons, mediante el cual has editado la vista archivo relacionada con la tienda y es por ello que cuando intentas ingresar en cualquier categoria se muestra es una pagina a medio editar

image

Elimina la plantilla o bien termina de configurarla para que se muestren los productos correspondientes

Saludos!

Respondido : 05/12/2022 4:58 pm
David
 David
Usuario eminente

@bruno-vichetti Muchas gracias ha funcionado perfectamente. Agradecido enormemente. Un saludo

Respondido : 07/12/2022 7:50 am

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola David, 

Enhorabuena todo funciona de forma correcta, es un placer para nosotros siempre poder ayudarte.

No dudes en escribirnos si tienes cualquier otra consulta

Un Saludo 😊 

Respondido : 07/12/2022 11:56 am