Avisos
Vaciar todo

[Resuelto] No puedo subir imágenes a Media  

 
Joan
 Joan
Usuario activo

Hace unos días cloné esta web WP desde Arsys, con la herramienta de Webempresa.
Ahora no puedo subir imágenes a Media. Siempre aparece una de estas dos respuestas: 

Respuesta inesperada del servidor. El archivo puede haber sido subido correctamente. Comprueba la biblioteca de medios o recarga la página.Comprueba la biblioteca de medios o recarga la página.

El posproceso de la imagen ha fallado probablemente porque el servidor está ocupado o no tiene suficientes recursos. Puede ayudar el subir una imagen más pequeña. El tamaño máximo sugerido es de 2500 píxeles

La imagen que subo mide 1024 x 600 px. Y he probado con otras igualmente pequeñas.

He probado todo tipo de soluciones, que no han resulto nada: Limpiar cache, desactivar plugins, instalar Disable "BIG image" Threshold, modificar version PHP...

Contenido solo visible a usuarios registrados

Respondido : 01/07/2021 7:51 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Joan, 

Puedes enviarnos una captura de pantalla sobre el error que se muestra cuando intentas subir una imagen en tu sitio web?, de igual forma si es posible envíanos una imagen que intentas subir para poder probarlo

Por otro lado prueba verífica lo siguiente, ingresa a ajustes -> medios y revisa la carpeta a la que apunta la subida de archivos, tiene que apuntar a la carpeta Uploads.

Screenshot   2021 07 01T145927.223

Comprueba esto y nos comentas como ha ido todo

Un Saludo 

Respondido : 01/07/2021 7:59 pm

Cursos Gratuitos WordPress

Joan
 Joan
Usuario activo

@karen

Hola.

Media apunta a /home2/yogaecua/public_html/yogaecuanime.com/wp-content/uploads

Ahora me ha dado esta respuesta: El posproceso de la imagen ha fallado probablemente porque el servidor está ocupado o no tiene suficientes recursos. Puede ayudar el subir una imagen más pequeña. El tamaño máximo sugerido es de 2500 píxeles.

Pero en otras ocasiones aparece las que he indicado arriba.

Captura pantalla:

imagen

Imagen que quiero subir, auqnue he porbado con otras. Ninguna se puede.

test

Si queréis os doy el acceso a wp-admin, ningún problema.

Respondido : 01/07/2021 8:40 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Joan,

Entre los ajustes realizados mencionas cambiar version del PHP, aumentaste los parámetros disponibles?

Con respecto al cambio del directorio donde se cargan los medios puedes intentar lo siguiente, desde tu Cpanel busca el directorio configurado en el mensaje anterior /home2/yogaecua/public_html/yogaecuanime.com/wp-content/uploads valida los permisos de dicho directorio sean 755, ademas intenta cargar una imagen de forma manual y verifica que pueda visualizarse desde la biblioteca de medios en WP

Nos comentas, Saludos

Respondido : 01/07/2021 8:45 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Joan
 Joan
Usuario activo

Hola,

Retomo el tema, ya que sigue sin cargar las imágenes ("El posproceso de la imagen ha fallado probablemente porque el servidor está ocupado o no tiene suficientes recursos. Puede ayudar el subir una imagen más pequeña. El tamaño máximo sugerido es de 2500 píxeles")

En la configuración de WP aparece que los medios están por defecto /home2/yogaecua/public_html/yogaecuanime.com/wp-content/uploads, pero los últimas imágenes que cargué antes de trasladar la web desde Arsys a Webempresa cargaban en /wp-content/uploads/2021/05/YogaEcuanime-Bienestar01.jpg (por ejemplo, https:// yogaecuanime.com/wp-content/uploads/2021/05/YogaEcuanime-Bienestar01.jpg). ¿Es esto correcto? Ver pantallazo del adminsitrador de archivos:

imagen

Los permisos de este directorio (/wp-content/uploads/2021/05/) son 0644, no 755.

He subido manualmente una imagen a /wp-content/uploads y a /wp-content/uploads/2021/05/ y he cambiado los permisos a 755. La imagen ha cargado correctamente (https:// yogaecuanime.com/wp-content/uploads/2021/05/Yogaceuanime-online-zoom02.jpg), pero no se ve en Media de WP.

Respondido : 07/07/2021 10:47 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Joan

Ahora me ha dado esta respuesta: El posproceso de la imagen ha fallado......

Prueba a instalar el siguiente plugin:

-> https://es.wordpress.org/plugins/disable-big-image-threshold/

Los medios están por defecto /home2/yogaecua/public_html/yogaecuanime.com/wp-content/uploads,

Es la dirección correcta, solo tiene que apuntar a la carpeta uploads.

pero no se ve en Media de WP.

Para que se vean en la biblioteca de medios tienes que cargarla desde la propia biblioteca, si la subes manualmente no se verán en al biblioteca de medios.

 

Prueba a instalar el plugin que te comente y revisa si puede subir la imagen.

Si después de instalar el plugin sigues con el problema, ves desactivando los plugins uno a uno por si el problema estuviera causado por algún conflicto con un plugin.

 

Un saludo

Respondido : 07/07/2021 11:52 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Joan
 Joan
Usuario activo

Hola,

https://es.wordpress.org/plugins/disable-big-image-threshold/ Ya estaba instalado y activo. No cambia nada. De todos modos, las imágenes que intento subir son relativamente pequeñas.

A instancias de un ticket también hecho lo siguiente, sin cambios:

Actualizar WP, theme y plugins.

Desactivar plugins.

Aumentar valores PHP al máximo.

Añadir a functions.php add_filter( ‘big_image_size_threshold’, ‘__return_false’ );

Respondido : 07/07/2021 12:26 pm
Joan
 Joan
Usuario activo

Hola,

Para vuestra documentación: Ya he encontrado la solución, un plugin llamado Tuxedo Big File Uploads ( https://es.wordpress.org/plugins/tuxedo-big-file-uploads/)

Con esto he podido cargar las imágenes (que insisto, no son "grandes").

Respondido : 07/07/2021 12:41 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Joan.

Ok vamos a probar otra cosa.

.- Accede a tu cuenta de cPanel -> Administrador de archivos.

.. Accede a la carpeta de la instalación

.- Renombre el archivo .htaccess por ejemplo .htaccess_old

.- Accede a la admisnitracion de WordPress.

.- Accede ajustes -> Enlaces permanentes

.- Sin realizar ningún cambio pulsa en " Guardar Cambios "

 

Revisa si después de esto la carga mejora.

 

Un saludo

 

Respondido : 07/07/2021 12:48 pm
Joan
 Joan
Usuario activo

Creo que no has entendido mi mensaje anterior: Ya lo he solucionado yo.

Copio:

Para vuestra documentación: Ya he encontrado la solución, un plugin llamado Tuxedo Big File Uploads ( https://es.wordpress.org/plugins/tuxedo-big-file-uploads/)

Con esto he podido cargar las imágenes (que insisto, no son "grandes").

Respondido : 07/07/2021 12:56 pm

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Joan.

Ok, gracias por informarnos, se ve que se cruzaron las respuestas y no vi la ultima que creaste.

 

Cerramos el tema.

Un saludo

Respondido : 07/07/2021 1:03 pm