Avisos
Vaciar todo

[Resuelto] Problema con Atributos en Wordpress - Woocomerce (Elige las opciones del producto antes de añadir este producto a tu carrito)  

 
Borislav
 Borislav
Usuario activo

Buenas tardes, 

Soy administrador de Wordpress y tengo el siguiente problema, en una tienda online con Woocomerce, Restaurante Kebab, la página está en funcionamiento desde hace 1 año, pero desde hace  poco me llama algún cliente diciendo que no puede hacer pedidos, el problema es el siguiente;

 

Los productos tienen varios atributos, cuando elijes un "Menú Kebab" debes elegir de qué carne (Pollo / Ternera / Mixto) y por otra parte la Bebida.

 

Cuando seleccionas ya la carne y la bebida, no te permite añadir el producto a la cesta, ya que dice que debes seleccionar todas las opciones antes de añadir el producto a la cesta.

Este problema solo lo tengo en a versión de "Ordenador" en "Movil" no sucede.

Por favor me urge solucionarlo ya que no recibo casi pedidos.

 

El sitio de salud está correcto excepto porque no tengo actualizado el PHP, pero entiendo que esa no es la causa de este problema con los atributos de los productos.

 

 

Gracias, saludos.

Leandro.

Contenido solo visible a usuarios registrados

Respondido : 08/02/2021 6:11 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Borislav,

Es extraño que solo suceda con este producto en especifico, has validado no sea un problema de inventario? adicional a esto has creado un producto nuevo con las mismas características? para verificar un cambio en las configuraciones del mismo.

Verifica y nos comentas, un saludo 🖐️ 

Respondido : 08/02/2021 6:19 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Borislav
 Borislav
Usuario activo
Respondido por: @borislav84bggmail-com

Buenas tardes, 

Soy administrador de Wordpress y tengo el siguiente problema, en una tienda online con Woocomerce, Restaurante Kebab, la página está en funcionamiento desde hace 1 año, pero desde hace  poco me llama algún cliente diciendo que no puede hacer pedidos, el problema es el siguiente;

 

Los productos tienen varios atributos, cuando elijes un "Menú Kebab" debes elegir de qué carne (Pollo / Ternera / Mixto) y por otra parte la Bebida.

 

Cuando seleccionas ya la carne y la bebida, no te permite añadir el producto a la cesta, ya que dice que debes seleccionar todas las opciones antes de añadir el producto a la cesta.

Este problema solo lo tengo en a versión de "Ordenador" en "Movil" no sucede.

Por favor me urge solucionarlo ya que no recibo casi pedidos.

 

El sitio de salud está correcto excepto porque no tengo actualizado el PHP, pero entiendo que esa no es la causa de este problema con los atributos de los productos.

 

 

Gracias, saludos.

Leandro.

Contenido solo visible a usuarios registrados

Decir que la plantilla que estoy utilizando es Flatsome.

Respondido : 08/02/2021 6:19 pm
Borislav
 Borislav
Usuario activo

@argenis Gracias primero que nada por responder.

 

Lo que te decía, desde la versión movil no te da ningun problema, es solo desde la vista de ordenador, y en cuando al SKU no tengo configurado inventario en ningún producto.

Respondido : 08/02/2021 6:22 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Boris,

Veo que ya funciona correctamente, has hecho algún cambio?

image
image

Un saludo 

Esta publicación ha sido modificada el hace 8 meses por Argenis
Respondido : 08/02/2021 6:34 pm
Borislav
 Borislav
Usuario activo

@argenis Esto es lo que me mosquea, que a lo mejor ahora funciona y sin embargo entra otro cliente y no, por favor, podrías probarlo en otro equipo y en el submenú de ofertas?

Es que en el PC del restaurante no me funciona, en mi portátil de trabajo si, he borrado cookies, temporales, he reiniciado...es una cosa muy extraña, podría tener algo que ver la versión que tengo de PHP que está desactualizada?

Gracias

Esta publicación ha sido modificada el hace 8 meses por Borislav
Respondido : 08/02/2021 6:35 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Borislav
 Borislav
Usuario activo

@argenis Tienes algún manual o algunas best ppractices de como configurar los atributos?

 

También me gustaría actualizar el PHP a la versión nueva actualmente tengo la 7.3.26 y ya me he vuelto loco a probar y no se porqué puede ser el problema..

Respondido : 08/02/2021 6:52 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Borislav,

Veo que utilizas la versión 7.3, esta esta mas que bien para trabajar ya que algunos complementos aún no funcionan correctamente con la versión 7.4 de php, por otra parte he probado en 3 computadoras diferentes utilizando igualmente 3 navegadores (safari, chrome y firefox).

He logrado replicar el error pero he encontrado un "patrón" no funciona tal como comentas pero al agregarlo en un producto donde si funciona vuelve a funcionar en el kebah que no funcionaba previamente.

Veo errores a nivel de un javascrip por consola, tienen algún código personalizado? verifica desactivando todos los complementos temporalmente y verifica si este comportamiento persiste, adicional si tienes algún código personalizado agregado al function prueba eliminarlo temporalmente o desactivarlos por medio de comentarios para verificar que nada este interfiriendo en el funcionamiento del mismo.

Un saludo 🖐️ 

Respondido : 08/02/2021 6:56 pm

Cursos Gratuitos WordPress

Borislav
 Borislav
Usuario activo

@argenis He comprobado;

 

- Configuraciones CSS no tengo no veo cambios

- He desactivado unos 8 plugins y no veo cambios

- He revisado el functions.php del tema en uso y esto es lo que tengo.

 

***

<?php
/**
* Flatsome functions and definitions
*
* @package flatsome
*/

require get_template_directory() . '/inc/init.php';

/**
* Note: It's not recommended to add any custom code here. Please use a child theme so that your customizations aren't lost during updates.
* Learn more here: http://codex.wordpress.org/Child_Themes
*/

 

***

 

Haber si sigues viendo esos errores de PHP, es funciona intermitentemente.. no entiendo a qué puede deberse..

 

Mil gracias

Respondido : 08/02/2021 7:12 pm
Borislav
 Borislav
Usuario activo

En principio continúa ocurriendo el problema. He desactivado los últimos plugins que active hace semanas y continua igual ... sigue dando el mismo fallo

Respondido : 08/02/2021 7:15 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Borislav,

Como te comenté previamente 

verifica desactivando todos los complementos temporalmente

verifica desactivar todos, únicamente deja woocomnmerce y haces la prueba para verificar si sigue mostrándose un error de javascript adicional veo que tienes 17 plugins activos, y no tienes actualizaciones pendientes, esto ocurre desde hace mucho tiempo? es posible que sea provocado por algún complemento como te comento previamente es por esto que realizas la prueba desactivado todo.

Un saludo 🖐️ 

Respondido : 08/02/2021 7:39 pm
Borislav
 Borislav
Usuario activo

@argenis Ya lo tengo tio !! OLE OLE 👍 

 

Mil gracias Argenis, ya sé porqué era, hace ya mucho tiempo estuve haciendo pruebas con un plugin para poner complementos a los productos el famoso "YITH WooCommerce Product Add-Ons" llevo 5 minutos probando productos y me añade todo correctamente, y además da la casualidad que este plugin funciona con Java.

 

Mil gracias por tu tiempo, tu experiencia y amabilidad !

 

Que tengas buena tarde y un saludo !

Respondido : 08/02/2021 7:49 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Borislav,

Estupendo, yo también he verificado en los 3 dispositivos vaciando la cache y verifique en un 4to, efectivamente ya funciona de forma correcta, 😀.

Recuerda que si tienes alguna otra consulta puedes crear un nuevo tema y con todo gusto lo atenderemos.

Un saludo 🤓 🖐️ 

Respondido : 08/02/2021 7:54 pm