Problemas con la libreria multimedia  

 
Lluc
 Lluc
Usuario experto

Tengo un problema con las imágenes de la mediateca de wordpress. Por un lado no puedo borrar ningún media. Tengo que borrarlos mediante Filezilla. Aún así, me queda un icono “fantasma” del media eliminado en la librería multimedia. Lo peor del caso és que en alguna imagen concreta me duplica por centenares el icono de referencia, haciendo muy incomoda la gestión de los contenidos.

Sabéis que puede causar este problema?

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 13/09/2014 10:28 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

ES posible que tengas mal configurada la ruta de medios, revisa esto en la configuraicón de medios, sin embargo si tienes una versión actual de wp no será posible ver esta información,

Podrías hacerlo cambiando el wp-config.php
http://www.wpbeginner.com/wp-tutorials/how-to-change-the-default-media-upload-location-in-wordpress-3-5/

O usar un plugin
https://wordpress.org/plugins/wp-original-media-path/

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/09/2014 6:32 pm

Cursos Gratuitos WordPress

Lluc
 Lluc
Usuario experto

Gracias Jhon,

No he entendido muy bien que hace este cambio en wp-config.php. Lo he probado pero no soluciona el problema y las imágenes de las paginas de categorías no se visualizan en el sitio. Supongo que no lo he aplicado correctamente.

De todas formas creo que he encontrado el origen del problema en el plugin WPML Media. Lo he desactivado y el problema se ha resuelto, después de eliminar los miles de iconos fantasma de las imágenes que me había generado en la galería multimedia.

Un saludo!

ResponderCitar
Respondido : 15/09/2014 12:13 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Lluc,

Recomendaciones:

Elimina los siguientes defines del archivo /home/discove1/public_html/descobreixmenorca.com/wp-config.php

define('WP_CACHE', true); // Added by W3 Total Cache
define('W3TC_EDGE_MODE', true); // Added by W3 Total Cache

Y sustituye W3 Total Cache por WP Super Cache.

Vemos que en esta web utiliza el plugin W3 Total Cache que causa errores por el uso de servicios de cache que estresan la instalación de WordPress:

Recomendamos el uso de WP Super Cache para optimizar el rendimiento de su Web y mejorar la experiencia de sus usuarios únicamente.

http://wordpress.org/extend/plugins/wp-super-cache/

Me comenta un Técnico de Soporte que no tenias definida ruta de /uploads, indispensable para la gestión de galerías e imágenes (subidas) y que te lo han corregido:

Contenido solo visible a usuarios registrados

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/09/2014 1:34 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Lluc
 Lluc
Usuario experto

Hola Luis,

Tal como me recomiendas, he eliminado los defines de wp-config.php que me indicas y he sustituido W3 Total Cache por WP Super Cache, pero el problema persiste.

Aunque he eliminado el plugin WPML Media, no se me duplican más los iconos de las imágenes en la librería multimedia pero siguen sin verse la imágenes que subo en los idiomas que no sean el predeterminado.

Alguna sugerencia para resolverlo?

Muchas gracias

ResponderCitar
Respondido : 15/09/2014 10:45 am
Lorena
 Lorena
Miembro Moderator

Hola Lluc,

Ahora mismo no se visualiza la web Contenido solo visible a usuarios registrados y que no tengas un deny from all en el fichero .htaccess

Si tienes dudas sobre la configuración del fichero .htaccess puedes utilizar el de por defecto de Wordpress disponible en http://codex.wordpress.org/htaccess

# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

Adicionalmente pide al asistente Stephan que te realice un análisis de tu cuenta.

Accede a tu Área de Cliente https://www.webempresa.com/areacliente.php y pulsa en "Crear Ticket", verás que te permite usar el Asistente Virtual Stephan que te resolverá varios de los problemas habituales.

Pulsa en "Pedir una revisión automática a Stephan", escoge la cuenta de hosting que quiere revisar y pulsa en "Revisar Cuenta", al cabo de unos 30 segundos te mostrará el resultado del análisis.

Un saludo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/09/2014 2:46 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Lluc
 Lluc
Usuario experto

Hola Lorena,

Veo que el sitio funciona correctamente. No se que puede haber pasado. He revisado la cuenta con Stephan y parece estar todo en orden.

Gracias

ResponderCitar
Respondido : 15/09/2014 6:35 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Actualmente ya se ve el sitio, puede que haya sido algo puntual, si sigues con problemas te sugiero envíes la url de un artículo en el que no te aparecen las imágenes para revisar el código de que ruta se genera.

Envía el articulo en ambos idiomas

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/09/2014 12:23 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Lluc
 Lluc
Usuario experto

Hola Jhon,

Parece que es un problema del plugin WP Media: http://wpml.org/errata/media-library-wont-show-languages-filters/

Esperaré a la próxima actualización del plugin a ver si se resuelve.

Gracias

ResponderCitar
Respondido : 16/09/2014 12:59 pm

Por favor Iniciar Sesión o Registro