Avisos
Vaciar todo

Problemas con menú desplegable  

 
Javier
 Javier
Usuario activo

Buenos dias

A ver si me pueden ayudar...

El menu desplegable de mi web a veces funciona y otras no!! Por momentos abre sin ningun problema mientras que en otras ocasiones al hacer click en el no hace absolutamente nada.

Utilizo la plantilla Flatsome

Alguna idea??

Gracias

Contenido solo visible a usuarios registrados

Citar
Respondido : 07/03/2021 11:41 am
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Javier,

He intentado replicar el error pero no lo he conseguido, hay una condición especial para que suceda? por ejemplo en un explorador en específico? veo que trabaja con ciertos scripts, puede que se trate de un error de comprensión por parte del complemento de caché. Comentanos un poco en que momentos succede para poder replicarlo y verificar.

Un saludo 🖐️ 

ResponderCitar
Respondido : 07/03/2021 1:20 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Javier
 Javier
Usuario activo

@argenis

Muchas gracias por responder... Mira, estuve probándolo (PC y MOVIL) en Chrome y en Firefox y en este ultimo creo que el error es algo mas frecuente, y puede que en móviles mas que en PC. El error sucede cuando cambias a una categoría o a un producto por momentos el menú no se abre. Actualizas la pagina y si que funciona...

Gracias

ResponderCitar
Respondido : 07/03/2021 1:43 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Javier,

Efectivamente no hizo falta ingresar a una categoría, directamente en mi teléfono no funciona el menu por más que actualice, por lo que veo tienes el complemento de carga Async JavaScript, prueba desactivarlo momentáneamente y nos comentas para realizar nuevamente la prueba, también una vez que lo desactives puedes vaciar la caché de wordpress para que no nos muestre una versión cacheada de la página.

Verifica esto y nos comentas para poder ingresar y corroborar, un saludo 🖐️  

ResponderCitar
Respondido : 07/03/2021 2:08 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Javier
 Javier
Usuario activo

@argenis

Buenos dias, perdona que ayer no pude contestar!!

Desactive el plugin y borre la cache y es verdad que funciona bastante mejor pero después de unos clicks volvió a fallar. Lo dejo desactivado por si lo quieres probar!

Muchas gracias

 

Javier

ResponderCitar
Respondido : 08/03/2021 8:02 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Javier,

Puedo ver que al mantener el plugin desactivo el menú funciona de forma correcta tanto en mi ordenados como móvil, te adjunto una URL donde te indico lo que veo

-> Contenido solo visible a usuarios registrados

Si es posible indícanos si es esto lo que no funcionaba de forma correcta?

Un Saludo

ResponderCitar
Respondido : 08/03/2021 11:28 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Javier
 Javier
Usuario activo

@karen Gracias por responder!

 

Si, ahora lo estaba probando y funciona... Ayer cuando desactive el plugin funcionaba mejor pero a veces se quedaba trabado el menu. Ahora lo volvi a probar y si, pareciera que se arreglo!! Muchas gracias

Ahora mi pregunta es... Hay algun forma de activar el plugin de Async JavaScript y configurarlo para que siga funcionando?? Mientras me responder intentare investigar un poco!

 

Muchas gracias nuevamente!

Javier

ResponderCitar
Respondido : 08/03/2021 11:42 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Javier.

Podrías crear una excepción con ese plugin.

.- Accede a la configuración de " Async JavaScript "

.- En el bloque " Plugin Exclusions " y añade el plugin que utilizas para él menu 

.- Si forma parte de la plantilla selección la plantilla en el bloque " Theme Exclusions "

Captura de pantalla 2021 03 08 a las 13.04.30

 

Un saludo

ResponderCitar
Respondido : 08/03/2021 12:06 pm

Cursos Gratuitos WordPress

Javier
 Javier
Usuario activo

@pepesoler

Buenas! En el menu es el que viene por defecto con la plantilla asi inclui tanto Flatsome como Flatsome Child dentro de las exclusiones y comenzo a dar errores... Volvi a desactivar el plugin y funciona bien... Veo que hay un buen conflicto ahi. O bien buscare un plugin de menu o bien algun otro que haga las funciones de Active Sync...

Alguna recomendacion

 

Muchas gracias

ResponderCitar
Respondido : 08/03/2021 12:29 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Javier,

Dentro de las opciones prueba seleccionar el tema padre de flatsome ya que dentro de este se encuentra todo el código del tema, comprueba si al añadir el tema padre no te marca ningún error el plugin.

Por otro lado al ser este un tema de pago no podemos comprobar su funcionalidad completa por lo que te sugiero contactes con el desarrollador del tema de esta forma te puede indicar de forma precisa su existe compatibilidad de este complemento con el tema

Un Saludo

Esta publicación ha sido modificada el hace 8 meses por Karen Rios
ResponderCitar
Respondido : 08/03/2021 12:43 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Javier
 Javier
Usuario activo

@karen Gracias

 

He probado hacer eso, solo seleccionar el tema padre y en el ordenador va bien pero en el movil es donde mas fallos da. Intentare contactar con el desarrollador a ver si me contestan

 

Muchas gracias

 

Javier

ResponderCitar
Respondido : 08/03/2021 1:45 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Javier,

De acuerdo, en este caso puedes preguntarles a los desarrolladores del tema como añadir esta opción en tu tema o mencionar algún plugin compatible para ello

Un Saludo

ResponderCitar
Respondido : 08/03/2021 1:48 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación