Avisos
Vaciar todo

[Resuelto] subir archivos o imagenes en https wordpress multisite  

 
Alberto
 Alberto
Usuario activo

Ayuda por favor estoy intentando subir imágenes a un subdominio de wordpress multisite integre el siguiente código para la redirección a https pero cuando cargo una imagen o archivo se carga en http y al momento de acceder al sitio en el candado me sale un mensaje que dice "partes de la web no son seguras" como puedo solucionarlo? gracias 

RewriteEngine On
RewriteCond %{ENV:HTTPS} !on [NC]
RewriteCond %{QUERY_STRING} !wc-api [NC]
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L,NE]

Contenido solo visible a usuarios registrados

Respondido : 28/02/2021 11:08 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Alberto,

Verifica que tengas instalado el certificado para todos tus subdominios, ten en cuenta que estos son tratados como un dominio más.Para ello debes  a tu área de clientes e instalar los certificados para los subdominios que tengas creados, luego en el multisite modifica las URL para que carguen con https.

Igualmente puedes probar si al instalar el siguiente plugin para toda  tu red de sitios se soluciona el contenido mixto en las url de las imágenes -> https://wordpress.org/plugins/really-simple-ssl/

Comprueba esto y nos comentas

Un Saludo

Respondido : 01/03/2021 12:03 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alberto
 Alberto
Usuario activo

@karen  Gracias , el certificado esta instalado para el subdominio pero las imágenes siguen subiendo en http instale el plugin de Really Simple SSL pero igualmente siguen subiendo en http 

Respondido : 01/03/2021 1:45 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Alberto,

He verificado la URL que nos compartes y veo que se muestra de forma correcta el SSL

imagen

Puedes indicarnos cual es el dominio donde aun no se visualiza de forma correcta?

Un Saludo

Respondido : 01/03/2021 2:57 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Alberto
 Alberto
Usuario activo

@karen vale resuelto , ya esta cargando el contenido que subo en ssl gracias por la ayuda 

Respondido : 06/03/2021 2:23 am
Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola Alberto, 

Excelente, me alegra que nuestra asistencia te fuera de utilidad. 

Cualquier otra duda o consulta que tengas no tardes en consultarnos para poder asistirte. 

Gracias por consultarnos.

 

Respondido : 06/03/2021 3:04 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación