Avisos
Vaciar todo

[Resuelto] Web con miles de URLs y con muchos años sin actualizar, errores en vista móvil tras cambio de tema  

 
Miguel
 Miguel
Nuevo usuario

Hola, la web llevaba años sin tocar por dentro, plugins antiguos (más de 20 sin actualizar durante años quizá), estaba con versión PHP 5 (no recuerdo exactamente), un tema antiguo, etc.

Tras varios errores al cambiar versiones de PHP, tema etc, parece que toda está ya ajustado, pero a veces, en el móvil se abren las URLs mal, o en versiones antiguas, o parpadeando, etc...

Y no encuentro la causa.. (he borrado cachés etc)

Contenido solo visible a usuarios registrados

Respondido : 16/06/2024 10:30 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Miguel,

Estoy verificando el sitio web y veo se muestra de forma correcta, solo ve que este slide no se adapta correctamente a móvil 

image

Esto se debe a la cantidad de texto entre el slide y como están añadidos los elementos, puedes verificar si tienes control de modificar el ancho y tamaño de a fuente para la versión móvil. 

Otra alternativa es añadir el siguiente código CSS en el apartado de Apariencia → Personalizar → CSS adicional de tu sitio web

@media only screen and (max-width: 600px) {
.ultp-block-0b6474 .ultp-block-content-inner {
width: 100%;
}
.ultp-block-0b6474 .ultp-block-item .ultp-block-content .ultp-block-title, .ultp-block-0b6474 .ultp-block-item .ultp-block-content .ultp-block-title a {
font-size: 22px;
line-height: 30px !important;
}
}

Si aparte de esto otra URL o elemento no carga de forma correcta, envíanos alguna capturas y la URL, de esta forma podemos revisarlo con mayor detalle. 

Te comparto la siguiente guía donde indican como subir imágenes a consultas en foro → https://soporteforo.webempresa.eu/guia/subir-imagenes-a-consultas-en-foro/

Un Saludo 

Respondido : 16/06/2024 2:34 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Miguel
 Miguel
Nuevo usuario

@karen Muchas gracias Karen!

Y en el móvil, algunas entradas se ven así (adjunto pantallazo)

Y a veces con el aspecto del anterior tema.

Si tú lo ves bien, el problema es desde nuestros móviles, y será por caché supongo.

Por otro lado, en relación al cambio de versión PHP, tus compañeros me dijeron "Ya que en la actualización influyen varios aspectos, lo mejor es que abras una consulta en nuestro foro atendido por nuestros especialistas en WordPress, de esta manera ellos determinarán si es buena idea o no actualizar la versión."

Tras varias pruebas y errores, la dejé en la 7.4. Aún así, ¿debo revisar otros parámetros? Y, debería probar la 8?

 

Orkambi El farmaco para respirar  bien que puede provocar depresión con ideas suicidas   Miguel J ara periodismo de investigaci

 

Respondido : 16/06/2024 2:56 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Miguel,

Verificando en mi móvil veo que si sucede pero esto puede ser un tema de la caché, veo que tienes instalado LiteSpeed Cache, prueba borrar la caché del sitio web pulsando en purgar todo

image

Adicional a ello veo que tienes activo magic caché, si es así accede a tu cuenta de hosting → otras herramientas → magic caché y vacía la caché para tu sitio web

Imagen de WhatsApp 2024 06 12 a las 14.34.02 49feec34
Imagen de WhatsApp 2024 06 12 a las 14.34.23 cbc4dc1d
Imagen de WhatsApp 2024 06 12 a las 14.34.39 b175055e

Ten en cuenta que para que puedas gestionar bien la caché en tu sitio web es conveniente instales el plugin de WE-Varnish-Cache, puedes ver una guía completa sobre su instalación en esta guía que tenemos disponible → https://guias.webempresa.com/preguntas-frecuentes/magic-cache/

También toma en cuenta cuáles son los plugins de caché que se recomienda utilizar cuando tienes magic cachpe activo.

Verifícalo y nos comentas como va todo

Un Saludo 

Respondido : 16/06/2024 4:20 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Miguel
 Miguel
Nuevo usuario

@karen Seguí tus recomendaciones y parece que todo va bien.

 

Gracias!

Respondido : 16/06/2024 6:11 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Miguel, 

Verificando el sito web como comentas ya se ve todo de forma correcta

IMG 5334

Coméntanos si con esto podemos dar el tema como solucionado?

Un Saludo 

Respondido : 16/06/2024 7:01 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Miguel
 Miguel
Nuevo usuario

@karen Sí, parece que ya todo está bien.

 

Muchas gracias

Respondido : 17/06/2024 10:12 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Miguel

Genial !!! Me alegra que lo solucionaras.

Cualquier consulta que tengas no dudes en comunicarlo.

 

Un Saludo

Respondido : 17/06/2024 10:42 am