WordPress Seo y error en sitemap xml  

 
Rafael
 Rafael
Usuario activo

Hola. Soy nuevo en este foro, por lo que me presentaré. Mi nombre es Rafa Escudero y soy el webmaster (aficionado) de http://bricoblog.eu. Os invito a visitarlo.
Bueno os cuento mi problema.
Hasta ahora he estado usando los plugins “All in one seo pack” y “Google XML sitemaps”.
Recientemente he sustituido el primer plugin por “Wordpress Seo”, y he eliminado el segundo puesto que ahora lo tengo integrado en este ultimo.
Pues bien, desde que lo sustituí, la herramienta para webmasters de Google, cada vez que indexa el sitemap arroja una advertencia de bloqueo de la siguiente url "http: //bricoblog.eu/wp-includes/js/tinymce/plugins/wordpress/img/trans.gif".
Adjunto un par de pantallazos.

He probado a desactivar el plugin “Ultimate TinyMCE”. Pero sigue apareciendo el aviso a diario.
Como en Google son tan quisquillosos con este tipo de cosas, quiero resolverlo para que no vuelva a dar la incidencia.
Alguien me puede echar una mano y decirme cómo puedo hacerlo?
Gracias anticipadas.

URL del sitio: Contenido solo visible a usuarios registrados

Rafa - BricoBlog

Citar
Respondido : 16/05/2014 3:41 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por lo que se ve en la captura de pantalla parece que ese bloqueo lo está realizando el archivo robots.txt. Verifica si tiene un archivo con ese nombre en la raíz y, de ser así, edítalo y comprueba si su configuración es correcta, ya que es posible que esté bloqueando a los robots el acceso a determinadas páginas.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/05/2014 6:15 pm

Cursos Gratuitos WordPress

Rafael
 Rafael
Usuario activo

Hola Pablo.
Efectivamente, en el directorio raiz tengo el archivo robots.txt. El contenido de dicho archivo es el siguiente:
User-agent: *
Disallow: /wp-admin/
Disallow: /wp-includes/
http://bricoblog.eu/sitemap_index.xml

Hace un par de días inserté una nueva linea en el fichero robots.txt, pero desde el editor de WordPress Seo:
Allow: /wp-includes/js/tinymce/plugins/wordpress/img/trans.gif
Pero al día siguiente tenía un nuevo aviso de la incidencia en webmaster tools.
Cómo podría solucionarlo?
Gracias por tu colaboración Pablo.

Rafa - BricoBlog

ResponderCitar
Respondido : 16/05/2014 6:46 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Rafael,

¿La línea Allow: /wp-includes/js/tinymce/plugins/wordpress/img/trans.gif sigue existiendo en el plugin SEO de tu WordPress?

La imagen /wp-includes/js/tinymce/plugins/wordpress/img/trans.gif ¿existe?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/05/2014 12:03 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Rafael
 Rafael
Usuario activo

Hola Luis.
No, la línea Allow: /wp-includes/js/tinymce/plugins/wordpress/img/trans.gif la quité, una vez observé que seguía saliendo el aviso. El archivo robots.txt está actualmente de la siguiente manera:
User-agent: *
Disallow: /wp-admin/
Disallow: /wp-includes/
http://bricoblog.eu/sitemap_index.xml

Ni la imagen /trans.gif, ni la carpeta /img/, existen. No sé si el problema estará en que ambos elementos deberían existir.
Sabrías cómo puedo solucionarlo?
Saludos.

Rafa - BricoBlog

ResponderCitar
Respondido : 19/05/2014 12:26 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

La cuestión sería tratar de averiguar desde donde se hace la llamada a esa imagen que no existe. De todas formas, esto no debería ser un problema para el posicionamiento de tu web, ya que el hecho de que muestre una advertencia de una imagen que no existe no debería afectar al posicionamiento del resto de las paǵinas.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/05/2014 5:56 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Rafael
 Rafael
Usuario activo

Hola de nuevo.
Investigando, creo que ya sé de dónde viene el problema. En el propio repositorio de plugins de worpress.org ( http://wordpress.org/plugins/ultimate-tinymce/), en la ficha del plugin hay una advertencia en la que se indica que el plugin no funcionará correctamente con la versión de WP 3.9 y posteriores. Incluso, aconsejan sustituir este plugin por WP Edit.
Una vez sustituido, he eliminado el plugin Ultimate TinyMce. Sin embargo, al ir al administrador de archivos en mi cPanel, observo que el directorio “tinymce” sigue existiendo.
Además Webmaster Tools continua arrojando la advertencia.
Mi pregunta es: ¿Si elimino el directorio “tinymce” (http:// bricoblog.eu/wp-includes/js/tinymce/…) por completo, podría provocar algún tipo de error en el resto de mi sistema de WP? ¿Es preferible renombrarlo?
¿Cómo hago para eliminar cualquier rastro del plugin que he eliminado?
Gracias anticipadas.

Rafa - BricoBlog

ResponderCitar
Respondido : 21/05/2014 2:12 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En teoría, cuando se desinstala un plugin (no confundir con desactivarlo) se tendrían que borrar los archivos del mismo. Es algo que te pregunta en el momento de la desinstalación.

El directorio que comentas está dentro de la carpeta wp-includes, lo que indica que es un archivo del sistema, por lo que eliminarlo puede ser arriesgado. Podrías probar a renombrarlo y luego hacer pruebas en la administración y en el frontal de la web para ver si se produce algún tipo de error. En ningún caso lo elimines ya que, a efectos prácticos, un directorio renombrado debería ser equivalente a uno eliminado para los buscadores, ya que no sabrán de su existencia. Con un directorio renombrado siempre podrás volver al estado anterior cambiando de nuevo su nombre.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/05/2014 5:27 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rafael
 Rafael
Usuario activo

Ok, gracias por vuestra colaboración amigos.
Saludos.

Rafa - BricoBlog

ResponderCitar
Respondido : 21/05/2014 6:08 pm

Por favor Iniciar Sesión o Registro