Avisos
Vaciar todo

No despliega checkbox en ClassicMode  

Página 1 / 2
 
Alvaro
 Alvaro
Estimable Member

Hola,

Como podéis ver en la imagen que sigue, no se despliegan los Checkbox en el formulario (ClassicMode).

Podéis comprobar también que en el formulario el Label del Checkbox actúa como vínculo inactivo.

En el back-end los Checkbox se visualizan correctamente (he probado con Radio Button y sucede lo mismo).

Saludos y muchas gracias por vuestra ayuda.

URL del sitio: http://larevis1-cp47.webjoomla.es/maqueta/index.php?option=com_content&view=article&id=55&Itemid=58

Citar
Respondido : 09/05/2012 1:32 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Alvaro,

- ¿Puedes indicar en que Pack de Webempresa te pasa eso?
- ¿Que versión de BreezingForms es la que tienes, y de Joomla?.

Para el primer ckeckbox veo que usas "tu_clase":

class="tu_clase" type="checkbox" checked="checked" value="Acepta suscripción"

¿Es eso correcto?.

Saludos

ResponderCitar
Respondido : 09/05/2012 1:50 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alvaro
 Alvaro
Estimable Member

Hola gnumax,

- No se trata de un paquete Webempresa, es una instalación "limpia" (a partir de una instalación Rocketlauncher, como utilizo en prácticamente todos mis desarrollos).
- Versión Joomla: 1.5.26
- Versión BreezingForms: 1.7.3 Stable

En cuanto a la clase que veías ("tu_clase") se trataba de una prueba, lo he removido.

Gracias y un saludo.

ResponderCitar
Respondido : 09/05/2012 2:12 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Alvaro,

Puedes mostrar en el backend, en BreezingForm los parámetros del checkbox? con uno de ellos vale ya que entiendo que en ambos casos son lo mismo.

Saludos

ResponderCitar
Respondido : 09/05/2012 2:21 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alvaro
 Alvaro
Estimable Member

Hola gnumax,

Adjunto las capturas.

Gracias y un saludo.

ResponderCitar
Respondido : 09/05/2012 2:29 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Alvaro,

Es posible que el fondo este afectando, cambia el orden por medio de las flechas de tal manera que el check box quede arriba y la imagen abajo.

Saludos.

ResponderCitar
Respondido : 09/05/2012 3:40 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Alvaro
 Alvaro
Estimable Member

Hola Johnny,

Los elementos del formulario ya están dispuestos de esa forma, pero solo los Checkbox no se visualizan. Adjunto captura.

Gracias y saludos.

ResponderCitar
Respondido : 09/05/2012 4:52 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Alvaro,

A lo que me refería que cambies orden de dicho fondo a la parte inferior por medio de las flechas. Te adjunto una captura para un mejor entendimiento.

Saludos.

ResponderCitar
Respondido : 09/05/2012 5:05 am

Cursos Gratuitos WordPress

Alvaro
 Alvaro
Estimable Member

Hola Johnny,

Si invierto la posición de los elementos como me indicas, los elementos quedan por debajo de la imagen (he dejado el formulario publicado con esa posición para que puedas verlo).

Lo que me resulta curioso es que los elementos Input Box se despliegan correctamente (si retorno a mi posición original de los elementos del formulario).

Saludos.

ResponderCitar
Respondido : 09/05/2012 5:44 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Alvaro,

¿Si deshabilitas el "Fondo Formulario", por un momento se pueden visualizar los Checkbox?

Saludos.

ResponderCitar
Respondido : 09/05/2012 9:56 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alvaro
 Alvaro
Estimable Member

Hola Jhonny,

No, si deshabilito la imagen de fondo del formulario tampoco se visualizan los Checkbox.

Dejo el fondo deshabilitado para que puedas comprobarlo.

Gracias y un saludo.

ResponderCitar
Respondido : 09/05/2012 10:03 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Alvaro,

Verifico un estilo te esta afectando pero se encuentra dentro de la programación del formulario (adjunto captura), habría que indagar en dicha programación para ocultar dicho estilo y funcione correctamente.

Saludos.

ResponderCitar
Respondido : 09/05/2012 10:42 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alvaro
 Alvaro
Estimable Member

Hola Johnny,

Siguiendo tu razonamiento, he intentado modificar las hojas de estilo que identifico mediante Firegug (template-gecko.css y template.css) pero no logro hacer que el Checkbox se despliegue.

Por favor, ¿sería posible me indicaras que etiqueta/s añadir o modificar dentro del/los css para desplegar el Checkbox como se ve en tu última captura de pantalla?.

Gracias por tu ayuda.

ResponderCitar
Respondido : 10/05/2012 3:25 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Alvaro,

Tendrías que comentar o eliminar dicho estilo css. El mismo habría que localizarlo dentro de la programación del formulario ya que es un elemento interno. Te adjunto captura para una mejor visualización.

Saludos.

ResponderCitar
Respondido : 11/05/2012 3:58 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Alvaro
 Alvaro
Estimable Member

Hola,

He descargado toda la instalación a local para buscar la cadena en cuestión (o parte de ella) y no he logrado localizarla.

element.style {
    left: -10000px;
    position: absolute;
}

Me encuentro completamente perdido con este tema, comentado desde Firebug "left: -10000px;" se despliega el Checkbox, pero luego de mucho intentarlo me resulta imposible interpretar como se genera o donde se encuentra el código.

Por favor, ¿me podríais echar una mano para localizar dicho código?.

Un saludo y muchas gracias por vuestra ayuda.

ResponderCitar
Respondido : 12/05/2012 3:26 am
Página 1 / 2