Instalar Moodle en un mismo hosting  

 
Juan
 Juan
Reputable Member

Hola,
Quisiera instalar un moodle 2.4.2 en mi hosting, por necesitarlo mi cliente, que ya dispone de su web. El servicio moodle quedará accesible como subdominio de la página.
¿Puede instalarse un Moodle en webempresa? ¿Algún tipo de ayuda o asistente tipo el de los packs joomla, wordpress, etc? ¿Algo a tener en cuenta?
Gracias de antemano.
Saludos,
Juan

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 13/03/2013 10:53 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Juan,

En nuestros servidores la aplicación web de eLearning "Moodle" funciona correctamente.

Tenemos varios clientes con una web Joomla! y Moodle en la misma cuenta de Hosting sin problemas

Si durante el proceso de instalación, recibe un aviso como: "Intl extension is used to improve internationalization support, such as locale aware sorting" puede proceder la instalación ya que no le será necesario habilitar soporte internacional pues nuestro servidor ya lo contempla.

Puede revisar el siguiente tutorial que explica cómo instalar Moodle en nuestros servidores:

Aquí tiene información sobre los requerimientos de Moodle: http://docs.moodle.org/en/Environment

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/03/2013 11:37 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan
 Juan
Reputable Member

Hola,
He creado un subdomninio para instalar el moodle 2.4.3 y procedido tal y como se indica en el vídeo. Sin embargo, una vez concluyo con la descompresión de archivos y su reubicación hacia la carpeta que he creado, accedo a la url desde la que proceder con los primeros pasos de la instalación y me dice que requiero una versión posterior de PHP (5.3.2). La que el servidor tiene instalada es una 5.2.17. ¿Se puede actualizar la versión de PHP?¿Debo instalarme una versión antigua de Moodle?
Gracias
Saludos,
Juan

ResponderCitar
Respondido : 18/03/2013 6:02 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Si deseas puedes solicitar por tickets de soporte que te cambien la versión de PHP para tu cuenta de hosting .

Ten en cuenta que el cambio de versión de PHP afectará a todos tus sitios web ya que es a nivel de tu cuenta, sin embargo en la mayoría de los casos no deberías tener problemas ya que usualmente Joomla 2.5 y sus extensiones trabajan bien en Joomla 5.3.x

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/03/2013 10:32 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan
 Juan
Reputable Member

Hola Jhon,
Lo que tengo en ese hosting es un joomla 1.5.25, con algunas extensiones para 1.5.x
Saludos,
Juan

ResponderCitar
Respondido : 18/03/2013 11:05 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Juan,

Existe la posibilidad de que alguna extensión deje de funcionar si trabaja con PHP 5.2. Una opción seria que contrates un hosting con PHP 5.3 para que instales el Moodle.

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/03/2013 11:25 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan
 Juan
Reputable Member

Hola,
Tengo varias cuentas de hosting. Lo mínimo requerido por el Moodle 2.4.3 es un PHP 5.3.2. En todas mis cuentas, menos aquélla en la que deseo instalar el Moodle, la versión PHP instalada es 5.3.16, que tampoco es la mínima requerida por este Moodle, por lo que entiendo que el proceso de instalación de éste se detendrá al inicio, por no ser PHP 5.3.2 lo que se encuentre.
Alternativas que veo:
a) Actualizar mi hosting a 5.3.2 en donde tengo un J1.5 con PHP 5.2.17, con el riesgo de que me afecte al J! y extensiones. Este hosting es, sin embargo el ideal, puesto que es el que destino exclusivamente para el cliente en cuestión, donde ya tiene su web, y para el que contraté un aumento de espacio recientemente con el propósito de instalar ahí el Moodle.
b) Actualizar cualquiera de mis otros hostings e instalar ahí el Moodle. En este caso, si la actualización fuera posible y no afectara a la web del hosting que decida, mi pregunta es si puedo independizar bien el moodle, en lo que a urls y demás se refiere, de los nombres que tiene la cuenta de hosting en la que lo instale. El nombre de dominio está fuera y apuntado al hosting de la web. La url pública del servicio Moodle me gustaría construirla como subdominio del nombre de dominio del cliente.
c) Aplicar la b), pero instalando el moodledata en el hosting php 5.2.17 para no comprometer el espacio disponible para otro de mis clientes en su hosting. ¿Esto es posible?

¿Alguna recomendación que no implique contratar otro hosting? Gracias
Saludos,
Juan

ResponderCitar
Respondido : 21/03/2013 12:22 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Juan,

Lo recomendable seria que hagas la consulta con soporte enviando un ticket mediante tu área de clientes para que te brinden mayor información. Es posible que la web que tienes con joomla 1.5 te siga funcionando en la migración de versión PHP y consigas instalarlo en el mismo hosting.

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/03/2013 5:23 am

Cursos Gratuitos WordPress

Juan
 Juan
Reputable Member

Hola Johnny,
Gracias por tu respuesta. Hago la consulta vía ticket.
Saludos,
Juan

ResponderCitar
Respondido : 22/03/2013 9:23 am
Juan
 Juan
Reputable Member

hola,
he limpiado una de mis cuentas de hosting con php 5.3 y trasladado el joomla que tenía ahí a otra de mis cuentas.
He comenzado la instalación del moodle 2.4.3 en un subdomnino especifico de la cuenta. Una vez creo la base de datos específica y el usuario y llego al paso de corregir la codificación de la base de datos, quedando la instalación libre de problemas (salvo la advertencia en color amarillo que podemos ignorar), pulso continuar y la página se me queda en blanco, sin cargar nada. La url que muestra es http://casaluch-cp52.webjoomla.es/formacion/admin/index.php?agreelicense=1&confirmrelease=1&lang=es_es, pero el contenido es una página totalmente en blanco.
¿A qué puede ser debibo?
Gracias
Saludlos,
Juan

ResponderCitar
Respondido : 25/03/2013 11:45 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David Noguera
 David Noguera
Miembro Admin

Hola Juan, es posible que se deba a que no tienes la función ini_set incluida en la lista de funciones permitidas, revsia el fichero error_log del directorio de instalación de tu Moodle e indícanos que errores aparecen.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/03/2013 12:10 pm
Juan
 Juan
Reputable Member

Hola David,
Tengo esto en el error log
[25-Mar-2013 11:17:37 UTC] PHP Warning: ini_set() has been disabled for security reasons in /home/casaluch/public_html/formacion/install.php on line 201
repetido uncas cuantas veces
Saludos,
Juan

ResponderCitar
Respondido : 25/03/2013 12:14 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

Hola Juan, OK, tienes que poner un ticket de soporte para que te solucionen el problema y puedas acabar de instalar tu Moodle.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/03/2013 12:47 pm
Juan
 Juan
Reputable Member

ok, resuelto vía ticket. Gracias
Saludos,
Juan

ResponderCitar
Respondido : 04/04/2013 1:30 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro