Avisos
Vaciar todo

Nueva web en mismo dominio  

 
David UdV
 David UdV
Estimable Member

Buenas tardes,

Tengo pensado hacer una nueva web empezando de 0 y con uno de los packs que ofrecéis pre-instalados.

En estos momentos tengo la web montada sobre la ruta "public_html", por lo que para empezar una nueva web de manera limpia habia pensado en trabajar sobre la ruta "public_html/viatgi.com". Así, mientras monto la nueva web me funcionaría la actual. Cuando acabe únicamente debo redirigir el dominio "http://www.viatgi.com" a "http://www.viatgi.com/viatgi.com".

Hasta aquí creo que no voy mal encaminado. ¿Cierto?

El problema viene en que cuando quiero instalar un pack de los que ofrecéis se pregunta la ruta en la que se quiere instalar, y cuando les especifico que la quiero en "public_html/viatgi.com" me dice que pongo carácteres que no se aceptan.

Por otro lado tengo dominio adicionales en el mismo hosting y todos ellos tienen como ruta inicial la "public_html/dominio.com". Así que por eso me gustaria instalar la nueva web en la ruta que indico.

Quedo a la espera de vuestros comentarios.

Saludos, DAVID

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 26/10/2012 4:50 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola David

Deberías elegir otro nombre para tu web nueva, es decir no debes usar :
www.viatgi.com/viatgi.com

PUedes usar viatgi simplemente sin .com , de esta manera el instalador te permitirá, ten en cuenta que lo recomendable en vez que redirecciones es que al final muevas la ruta de tu sitio nuevo a la raiz de tu cuenta de hosting.

Nota: El instalador no te permite estos caracteres especiales, en los casos de los dominios adicionales se instala a través del dominio y no a través de una carpeta es por eso que no tuviste problemas en este caso.

Saludos.

ResponderCitar
Respondido : 26/10/2012 6:45 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David UdV
 David UdV
Estimable Member

Hola Jhon,

Lo haré como me dices pero... ahora me están surgiendo más dudas...

¿Cómo puedo recuperar después toda la información que tengo en el actual site? Es decir, toda la información de AcyMailing y VirtueMart sobretodo.

¿Hago servir la misma base de datos? Supongo que no... tendré que crear una nueva para importar los datos de estas aplicaciones después... ¿Cierto?

Gracias y saludos,
David UdV

ResponderCitar
Respondido : 30/10/2012 10:02 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Para recuperar la información puede seguir 2 sistemas. Por una parte, en lugar de instalar un pack podrías clonar la web que contienen los datos que quieres copiar. Para hacer esto puede copiar los archivos de la web y colocarlos en un nuevo directorio y clonar la base datos en una nueva. Luego, tendrías que editar el archivo configuration.php de la nueva web y cambiar los datos de la base de datos y el usuario y contraseña que accede a ella. Otra forma de hacer esto sería utilizando el Akeeba Backup.

El otro sistema de recuperación de información sería partir de un nuevo pack y copiar los datos entre las tablas de la base de datos que los contiene. Para que esto funciona tendrías que tener las mismas versiones entre las extensiones en la web nueva y vieja.

Es muy importante que en la web nueva trabajes con una base de datos distinta ya que, en caso de compartir de la misma base de datos, lo cambios aplicados en la nueva web repercutirían en la vieja.

ResponderCitar
Respondido : 30/10/2012 1:13 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David UdV
 David UdV
Estimable Member

Hola Pablo,

El "problema" es que la web actual corre bajo Joomla 1.5 y me gustaría que la nueva web corriera bajo Joomla 2.5.

Para ello, y por tu respuesta... ¿¿No puedo recuperar estos datos??

¿No existe ninguna posibilidad de hacerlo desde las propias extensiones? Si así fuese...nunca podría renovar una web por completo, ¿No?

Saludos,

ResponderCitar
Respondido : 30/10/2012 1:30 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David,

Para ello, y por tu respuesta... ¿¿No puedo recuperar estos datos??

¿No existe ninguna posibilidad de hacerlo desde las propias extensiones? Si así fuese...nunca podría renovar una web por completo, ¿No?

La respuesta rápida seria "No es posible" y la respuesta más extendida seria:

El planteamiento para realizar una migración de Joomla! 1.5 a 2.5 es el siguiente:

- Podrás migrar si tus actuales extensiones ya están disponibles en Joomla! 2.5, lo cual deberás verificar en el JED: http://extensions.joomla.org/search?q=joomla+2.5
- NO podrás migrar si tus extensiones no están disponibles para Joomla! 2.5, y esta premisa es fundamental para seguir hablando de migraciones.
- Podrás migrar si ADEMÁS de tus extensiones, tu plantilla en uso esta disponible para Joomla! 2.5.
- Podrás migrar a Joomla! 2.5 si tus extensiones están disponibles para Joomla! 2.5 pero NO deberías migrar si tu plantilla no está disponible para esta rama, o por el contrario tendrás, tras la migración, pasar por un proceso de ADAPTACIÓN de la misma a una liberada para 2.5 y reajuste de módulos a nuevas posiciones.

Importante volver a leer el siguiente documento:

- https://www.webempresa.com/blog/joomla-17-preguntas-frecuentes-faqs.html

Recomendación: no realizar una migración sin previamente hacer un respaldo del sitio web, preferiblemente con Akeeba Backup.
-

Tras analizar estos puntos, la migración actualmente es relativamente sencilla y con extensiones como jUpgrade se realiza de forma rápida desde Joomla! 1.5 a Joomla! 2.5 en un solo proceso.

En el siguiente artículo puedes ver como se realiza una migración de Joomla! 1.5 a 2.5 mediante jUpgrade:

- https://www.webempresa.com/blog/migrando-joomla-15-a-joomla-25-con-jupgrade.html

Nota importante: Si vas a realizar dicha tarea, lo primero es que hagas una copia de seguridad de tu actual web con Akeeba Backup y la descargues a tu pc para garantizarte un punto al que poder volver en caso de problemas.

Saludos

ResponderCitar
Respondido : 30/10/2012 2:50 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David UdV
 David UdV
Estimable Member

Hola Luis,

Muchas gracias. Me pongo en ello.

Saludos,

ResponderCitar
Respondido : 02/11/2012 5:47 pm
David UdV
 David UdV
Estimable Member

Hola de nuevo,

Retomando este tema os expongo la situación actual.

Finalmente me he decidido por montar una web totalmente nueva desde 0. Así que mientras trabajo en ella he dejado la actual corriendo bajo el mismo dominio.

La nueva web la estoy montando en la ruta http://www.viatgi.com/viatgi. La instalación no la hice desde el Panel de Webempresa, sino que subi un pack de los que llaman "Quickstart", para que desde un principio ya me venga practicamente montada con sus extensiones.

El problema con el que me encuentro es que una vez hecha la instalación entro perfectamente al apartado de la Administración, pero en cambio no me aparece la web por ningún lado.

¿Alguna sugerencia?

La plantilla es la iSTORE de JoomShaper http://demo.joomshaper.com/

Saludos y gracias de antemano.

ResponderCitar
Respondido : 16/11/2012 9:09 am

Cursos Gratuitos WordPress

David Noguera
 David Noguera
Miembro Admin

Hola David, veo que hay un error del servidor, si has descomprimido el quickstart en tu máquina local y subido por FTP es posible que tenga algunos permisos incorrectos y pro este motivo de error del servidor.

Tendrás que revisar el fichero de error_log que hay en la raíz de tu web para consultar el motivo del problema...

Saludos!

ResponderCitar
Respondido : 16/11/2012 11:12 am
David UdV
 David UdV
Estimable Member

Hola David,

He estado revisando el archivo que me dices y no hay ningún error que se refiera a ninguna carpeta dentro de "html_public/viatgi".

Por otro lado, lo curioso del tema, es que con el sitio desactivado sí funciona.

Entiendo pues que deberia ser algún problema de algun módulo, ¿no?. He estado revisando pero sigo sin encontrar nada... ¿Podría ser por algo del idioma? He visto que hay hasta 3 opciones diferentes de configuración de idioma, y en la de content he tenido que añadir yo manualmente el Spanish (ES).

Y otra cuestión. Al instalar el joomla me ha pedido que tipo de base de datos iba a hacer funcionar... MySql o MySqli. Yo en principio puse MySql... ¿es correcto?

Saludos,

ResponderCitar
Respondido : 16/11/2012 3:58 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola DAvid

La carpeta correcta es : public_html/viatgi y no html_public/viatgi

No es lógico que sólo te funcione con el sitio desactivado

Actualmente no aparece ningún archivo en :
http://www.viatgi.com/viatgi/administrator
http://www.viatgi.com/viatgi/

Supongo que estas realizando el proceso nuevamente.

Te sugiero uses Mysqli en lugar de Mysql

Saludos

ResponderCitar
Respondido : 16/11/2012 8:21 pm