Avisos
Vaciar todo

[Resuelto] Desactivo caché y sigo sin poder actualizar Prestahop  

Página 1 / 2
 
Luis
 Luis
Usuario activo

Buenos días equipo! Os pongo un poco en situación, estoy intentando actualizar la versión de prestashop 1.7.6.1 a 1.7.7.1, pero me indica que debemos desactivar la memoria cache de la página para poder actualizar. Procedemos a desactivar la memoria cache, entro en el apartado de rendimiento dentro de nuestro backoffice y resulta que la cache esta desactivada y aun así no deja actualizar, sigue marcando como que esta activada. He probado a activarla y desactivarla de nuevo pero sigue marcando lo mismo. Adjuntamos capturas de pantalla para que podáis observar lo que ocurre.

Contenido solo visible a usuarios registrados

Respondido : 21/01/2021 10:40 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Luis.

.- Accede a parámetros Avanzados -> Rendimiento.

.- Revisa que tengas la caché desactivada:

screenshot nimbus capture 2021.01.21 12 06 50

.- Revisa que tengas desactivada también la cache de Smarty:

 

screenshot nimbus capture 2021.01.21 12 08 21

 

Un saludo

Respondido : 21/01/2021 11:09 am

Cursos Gratuitos WordPress

Luis
 Luis
Usuario activo

@pepesoler

Si ambos están desactivados.

2
2
3
4
Respondido : 21/01/2021 12:01 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Luis.

Ok, prueba lo siguiente.

-> Accede de nuevo a Parámetros Avanzados -> Rendimiento.
.- Activa de nuevo la cache del bloque " CACHÉ " y guarda
.- Desactiva de nuevo la Cache y Guarda de nuevo la configuración.

.- Accede al modulo de actualización y revisa si desaparece el aviso

 

Un saludo

Respondido : 21/01/2021 12:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis
 Luis
Usuario activo

@pepesoler

ya he intentado eso que dices anteriormente sin obtener resultados. Lo he probado de nuevo, activo el botón "

El aviso sigue apareciendo y no deja actualizar.

 
Respondido : 21/01/2021 3:57 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Luis.

Ok vamos realizarlo a fuerza bruta:

.- Accede a tu cuenta de cPanel -> administrador de archivos 

.- Accede a public_html -> tucamello.es-pruebas -> app -> config y editar el archivo " parameters.php "

Al final del array añade lo siguiente:

 'ps_cache_enable' => false,
screenshot cp528.webempresa.eu 2083 2021.01.21 17 25 30 (1)

.- Acce denuevo a la administración y revisa si puedes actualizar.

 

Un saludo

Esta publicación ha sido modificada el hace 4 semanas por Pepe
Respondido : 21/01/2021 4:28 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis
 Luis
Usuario activo

@pepesoler

No funciona... sigo sin poder actualizar. Entré el archivo, el cual ya contenía el parámetro ('ps_cache_enable' => 'false'), lo copie y pegue al final del array pero sigue sin funcionar. =(

Respondido : 21/01/2021 4:50 pm
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Luis,

Es muy raro que no logres desactivar la cache, haz realizado algún cambio a nivel de módulos? es posible que algún este ocasionando este conflicto. Veo ahora un error con el modulo de graphnvd3 prueba desactivar este modulo de forma temporal y verifica si con ello logras ejecutar la actualización

[20-Jan-2021 18:29:55 Europe/Madrid] PHP Fatal error: Cannot declare class GraphNvD3, because the name is already in use in /home2/tucamell/public_html/tucamello.es-pruebas/modules/graphnvd3/graphnvd3.php on line 181

Un Saludo

 

Respondido : 21/01/2021 5:00 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis
 Luis
Usuario activo

@karen

Hola Karen, no, no he realizado ningún cambio a nivel de módulos. He desactivado el modulo que me comentas pero seguimos igual sin poder actualizar, sigue marcando la cache como su estuviese activada.

Respondido : 21/01/2021 5:42 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba igual desactivar todos los módulos que tengas y verifica, ya que es muy raro que aún tengas ese mensaje cuando ya esta desactivado.

Saludos.

Respondido : 21/01/2021 6:00 pm

Cursos Gratuitos WordPress

Luis
 Luis
Usuario activo

@jmarreros

Hola, acabo de desactivar todos los módulos de la página excepto la carpeta autoupgrade. Sigue pasando lo mismo, no me deja actualizar.

Respondido : 21/01/2021 6:30 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Ubica la BD de tu sitio web, puedes ubicar el nombre en el archivo /app/config/parameters.php

Luego desde la aplicación PHPMyAdmin , disponible en el Cpanel de tu cuenta de hosting, ubica y selecciona la BD, y luego en el tab SQL ejecuta:

select * from ps_configuration where name like '%cache%';

Cambia "ps_" por el prefijo de tu tu tabla

Revisa los registros que aparecen, puedes enviarnos una captura de pantalla.

Si hay algún registro de cache establecido a 1 debería estar en 0

Saludos.

 

Respondido : 21/01/2021 7:45 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis
 Luis
Usuario activo

@jmarreros

Buenos días, tras revisar lo que me comentas, no tengo ningún registro en "1", adjunto captura de pantalla.

Sin título

Saludos.

 

Respondido : 22/01/2021 9:23 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Luis.

Ok vamos a probar una cosa y si vemos que no funciona actualizaremos a mano.

.- Accede a módulos y comprueba si tienes actualizaciones del módulo 1 click upgrade, si tienes actualizaciones lo actualizas.

screenshot joomlero cp95.webjoomla.es 2021.01.22 11 49 00

.- Si no tienes actualizaciones, reinicia el módulo.

screenshot joomlero cp95.webjoomla.es 2021.01.22 11 50 22

 

Comprueba si con estos pasos se soluciona.

 

Un saludo

 

 

Respondido : 22/01/2021 10:51 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis
 Luis
Usuario activo

@pepesoler

Hola, no da la opción de actualizar, eso es que ya esta actualizado a la ultima versión, reinicie el modulo pero seguimos sin poder actualizar.

Respondido : 22/01/2021 11:18 am
Página 1 / 2