Avisos
Vaciar todo

Error 500 en pedidos de algunos clientes  

 
ROLANDO
 ROLANDO
Usuario experto

Buenas noches
Llevo desde hace dos días con un error el 500
-Aparece en los pedidos cuando quiero visualizarlos. Aparece así http://prntscr.com/o8gc4m
- A algunos clientes les aparece el error al querer pagar

Nota: no pasa en todos los pedidos

Escribí a tus compañeros de soporte y:

- Me hicieron cambiar configuraciones de cache,
- Me dijeron era el modulo Santander
- de version php
- Restaurar, etc

Sigue igual
El día empecé a tener problemas me instalaron el Memcached estuve tiempo sin poder entrar a la web y cuando la desactivaron me encontré con que los pedidos que entraron estaban con este problema

Restauré como te comentaba antes, y al llegar a los pedidos de 5 clientas en concreto, que son las mismas que tenían antes los pedidos corruptos, me aperece el error. No son los mismos números de pedidos.

A ver si me pueden ayudar, desespero además no tengo conocimientos, solo algo de prestashop pero de código nada

Me sugieren pasarme al prestashop 1.7 es estable? por otra parte no me gustaría perder módulos comprados que no me valen para este y luego seguir con el mismo problema
Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 30/06/2019 1:39 am
ROLANDO
 ROLANDO
Usuario experto

Hola
Te agrego más cosas, cuando voy a crear artículos también me da error.
Ahora no puedo pasar a productos, si pico error 500

ResponderCitar
Respondido : 30/06/2019 2:47 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Saludos Rolando,

Parece ser que el problema se debe a que tienes activada una función llamada "Pedido Rápido de 5 Pasos", desactívala, si el problema persiste será necesario que realices lo siguiente:

  1. Deshabilita y elimina caché.
  2. Abre desde el administrador de archivos desde cPanel y dirígete a $raiz_de_tu_sitio$/config/defines.inc.php
  3. Identifica esta línea define(‘_PS_MODE_DEV_’, false);
  4. Cámbiala por esta otra define(‘_PS_MODE_DEV_’, true);
  5. Guarda cambios

Esto nos ayudará a identificar con mayor claridad el origen del problema.

Respecto a PrestaShop 1.7 personalmente lo considero mas estable aunque tiene sus detalles claro, si te recomendaría realizar la migración. Respecto a tus módulos adquiridos puedes listarlos y buscaremos alguna solución gratuita y de pago para PS 1.7 que realice las mismas funciones.

Nota: Recuerda crear una copia de seguridad de los archivos que modifiques en tu sitio.

Saludos.

ResponderCitar
Respondido : 30/06/2019 2:17 pm
ROLANDO
 ROLANDO
Usuario experto

Yo no lo veo aqui, que debo desactivar ?

http://prntscr.com/o8l4s9

ResponderCitar
Respondido : 30/06/2019 2:19 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

ROLANDO
 ROLANDO
Usuario experto

Los módulos que tengo son
- Transportistas por zonas con distintos importes de pago gratuito. Este. https://addons.prestashop.com/es/gastos-de-transporte/8707-envio-gratis-por-zona-transportista-peso-y-precio.html?ab=1

- Carrito abandonado que manda recordatorio

- tpv santander
- paypal
- Pago contrarrembolso
- Bulk mass https://addons.prestashop.com/es/edicion-rapida/19965-a-granel-productos-de-edicion-de-masas.html?ab=1

ResponderCitar
Respondido : 30/06/2019 2:23 pm
ROLANDO
 ROLANDO
Usuario experto

Más cosas, cuando trato de subir una imagen a un producto sale un cartel adventencia en rosa
y luego ya no puedo entrar a Productos, tiene que ser algo más grave lo que ocurre

ResponderCitar
Respondido : 30/06/2019 2:56 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

ROLANDO
 ROLANDO
Usuario experto

Hice todo lo que me pediste

en los pedidos que tengo error 500 al abrir me sale esto http://prntscr.com/o8lvbm
Copio el texto

Fatal error: Uncaught Error: Call to undefined function imagecreatetruecolor() in /home2/picknite/public_html/classes/ImageManager.php:238 Stack trace: #0 /home2/picknite/public_html/classes/ImageManager.php(83): ImageManagerCore::resize('/home2/picknite...', '/home2/picknite...', 33.75, 45, 'jpg') #1 /home2/picknite/public_html/controllers/admin/AdminOrdersController.php(2710): ImageManagerCore::thumbnail('/home2/picknite...', 'product_mini_35...', 45, 'jpg') #2 /home2/picknite/public_html/controllers/admin/AdminOrdersController.php(1610): AdminOrdersControllerCore->getProducts(Object(Order)) #3 /home2/picknite/public_html/classes/controller/AdminController.php(2059): AdminOrdersControllerCore->renderView() #4 /home2/picknite/public_html/classes/controller/Controller.php(189): AdminControllerCore->initContent() #5 /home2/picknite/public_html/override/classes/controller/Controller.php(196): ControllerCore->run() #6 /home2/picknite/public_html/classes/Dispatcher.php(367): Controller->run() #7 /home2/picknite/public_html/ad in /home2/picknite/public_html/classes/ImageManager.php on line 238

ResponderCitar
Respondido : 30/06/2019 3:48 pm
ROLANDO
 ROLANDO
Usuario experto

Lo he vuelto a poner como antes porque me daba ese error

ResponderCitar
Respondido : 30/06/2019 3:54 pm

Cursos Gratuitos WordPress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Ok Rolando,

Necesito que realices lo que te solicité.

Deshabilita y elimina caché.
Abre desde el administrador de archivos desde cPanel y dirígete a $raiz_de_tu_sitio$/config/defines.inc.php
Identifica esta línea define(‘_PS_MODE_DEV_’, false);
Cámbiala por esta otra define(‘_PS_MODE_DEV_’, true);
Guarda cambios

En Tipo de Proceso de Pedido, ¿Te aparece alguna otra opción? Seleccionala.

18.750899,-100.380344

ResponderCitar
Respondido : 30/06/2019 4:20 pm
ROLANDO
 ROLANDO
Usuario experto

Si lo hice
esto no lo entiendo. En Tipo de Proceso de Pedido, ¿Te aparece alguna otra opción? Seleccionala.
No puedes intentarlo tu? tienes mi datos de cpanel

ResponderCitar
Respondido : 30/06/2019 4:35 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Qué versión exacta de PrestaShop tienes?, y qué versión de PHP, te recomiendo para la rama 1.6 tener la verisón más reciente 1.6.1.24 con al menos PHP 7.2

Para desactivar parámetros de optimización revisa en Parámetros Avanzados > Rendimiento, desactiva la cache y los parámetros CCC en caso los tengas activos.

Entiendo que no tienes cache a nivel de servidor (magic cache) igual o podrías consultar con soporte para que te aseguren que tienes deshabilitada esta funcionalidad en tu cuenta.

Si sigues con problemas es posible que algún módulo te este causando el problema, en tal caso tendrías que ir desactivando módulos hasta detectar si alguno te causa esto.

Migrar a PrestaShop 1.7 también sería una opción tendrías que revisar si los módulos de terceros que usas funcionan o tienen una versión para PS 1.7

Saludos.

ResponderCitar
Respondido : 30/06/2019 6:12 pm
ROLANDO
 ROLANDO
Usuario experto

Hola lo he probado lo que me dices
Encontré esto picknite/public_html/classes/ImageManager.php on line 238

ResponderCitar
Respondido : 30/06/2019 6:32 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

ROLANDO
 ROLANDO
Usuario experto

versión 1.6.1.15 prestashop
php 5.6

ResponderCitar
Respondido : 30/06/2019 6:32 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

De manera general te recomiendo actualizar al menos a PS 1.6.1.24 y usar también PHP 7.2
Puedes hacer pruebas antes de actualizar en un clon de tu sitio, para clonar tu sitio puedes revisar:
https://www.webempresa.com/blog/clonar-una-instalacion-de-prestashop-a-otra-carpeta-del-hosting.html

Teóricamente al estar en la misma rama el theme y los módulos de terceros que tengas deberían seguir funcionando, igual revisa si estan actualizados.

Saludos.

ResponderCitar
Respondido : 30/06/2019 6:45 pm

wpdoctor-revisa-la-salud-de-tu-wordpress