error refuse to execute script prestashop  

 
Toni
 Toni
Usuario activo

Hola,

En un Prestashop 1.6.1.24, podrías indicarme, como solucionar https://www.artegres.es cuando se carga en el navegador, obtengo los siguentes errores:

BARRA DIRECCIONES DEL NAVEGADOR
Contenido no seguro bloqueado. Esta página está intentando cargar scripts de fuentes no autorizadas

CONSOLA HERRAMIENTAS DESARROLLADORES
(index):19 Mixed Content: The page at 'https://www.artegres.es/es/' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Roboto+Slab:400,100,300,700'. This request has been blocked; the content must be served over HTTPS.
(anonymous) @ (index):19

(index):1 Refused to execute script from 'https://cdn.syndication.twimg.com/widgets/timelines/ https://twitter.com/artegres?ref_src ="twsrc%5Etfw?&lang=en&callback=__twttrf.callback&suppress_response_codes=true&rnd=0.9951551097302269"' because its MIME type ('') is not executable, and strict MIME type checking is enabled.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 30/08/2019 10:21 am
Pepe
 Pepe
Miembro Moderator

Hola Toni.

El error es de contenido mixto en la carga de las fuentes de Google, está cargando en http en vez de cargar con https:

¿ Como añadiste esas fuentes, es u script o utilizas algun modulo para cargar fuentes de google ?

De todas formas prueba lo siguiente:
.- Edita el archivo htaccess y añade lo siguiente:

Header always set Content-Security-Policy "upgrade-insecure-requests;"

Este código lo que hace es forzar la carga de contenido no seguro bajo protocolo HTTPS.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 30/08/2019 11:36 am
Toni
 Toni
Usuario activo

Perfecto se ha solucionado lo relacionado al contenido mixto indicado en la consola:
(index):19 Mixed Content: The page at 'www.artegres.es/es/' was loaded over HTTPS, but requested an insecure stylesheet 'fonts.googleapis.com/css?family=Roboto+Slab:400,100,300,700'. This request has been blocked; the content must be served over HTTPS.
(anonymous) @ (index):19

ESTE ERROR ME SIGUE APARECIENDO EN LA CONSOLA
(index):1 Refused to execute script from 'cdn.syndication.twimg.com/widgets/timelines/ https://twitter.com/artegres?ref_src ="twsrc%5Etfw?&lang=en&callback=__twttrf.callback&suppress_response_codes=true&rnd=0.9951551097302269"' because its MIME type ('') is not executable, and strict MIME type checking is enabled.

Gracias por todo,

ResponderCitar
Respondido : 30/08/2019 6:50 pm
Pepe
 Pepe
Miembro Moderator

Hola Toni.

¿ Utilizas algún modulo de redes sociales ?
El problema es de algún plugin de redes sociales que se conecta con un script a twitter

Analizando el error puedo ver que la URL a la que hace referencia no existe y por eso muestra ese error:
Contenido solo visible a usuarios registrados

Si tienes algún modulo de redes sociales prueba a desactivarlo y revisa si se soluciona.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 30/08/2019 8:13 pm

Por favor Iniciar Sesión o Registro