Página del carrito ni funciona prestahsop 1.7.3  

 
Mario
 Mario
Estimable Member

Hola,

Estamos trabajando en una versión de prueba en prestashop 1.7.3.2 y la página del carrito no funciona. No sabemos qué puede estar pasando.
Si agregas un producto al carrito, aparentemente entra bien pero luego aparece que su precio y transporte es 0 euros. Y si clickas en el enlace de arriba derecha que dice "carrito", éste tampoco hace nada...
Alguien sabe qué puede estar pasando?
Gracias
Un saludo

URL del sitio: Contenido solo visible a usuarios registrados

Carretera y Manta

Citar
Respondido : 24/05/2018 2:59 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mario.

¿ Los productos tienen stock ? ¿ añadiste algun modulo de terceros o es una instalación limpia de PS ?

Veo que estas utilizando la versión 5.5 de PHP en tu cuenta de hosting, las nueva versiones de PS necesitan la versión 7x

Prueba a modificar la versión de PHP para esa cuenta, esto lo puedes hacer fácilmente desde tu cuenta de cpanel -> Software -> Configurar PHP

Solo tienes que seleccionar la versión que quieres que se instal del desplegable, te dejo información en este enlace:

-> https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 24/05/2018 5:17 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Mario
 Mario
Estimable Member

Hola Pepe,

Estamos haciendo una prueba en el dominio https://beta.mantasdegrazalema.com/es/ y aquí sí está la versión php 7.1
Creo que la la que has visto está en el dominio www.mantasdegrazlame.acom y sí es 5.5.
No sabemos qué peude ser.
Gracias
un saludo

Carretera y Manta

ResponderCitar
Respondido : 24/05/2018 5:42 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba cambiando la versión de PHP a PHP 7.2

Luego, verifica si has instalado recientemente algún módulo que no vino por defecto con PrestaShop, podrías desactivarlo y verificar.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/05/2018 6:46 pm

Cursos Gratuitos WordPress

Mario
 Mario
Estimable Member

Hola de nuevo!

El error está localizado pero no sabemos cómo arreglarlo.
Es en el archivo core.js de prestashop

Cadena vacía pasada a getElementById().

ReferenceError: core is not defined

Esos errores los he podido ver en la consola de depuración de firefox. Y sucede cuando agrego un producto al carrito, no lo agrega aunque en la base de datos si, pero en la web no aparece.

Alguna idea?

Gracias

Carretera y Manta

ResponderCitar
Respondido : 28/05/2018 4:06 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mario.

El problema viene por una cadena vacía, es decir una variable que se le pasa a un elemento que no encuentra, esto suele venir por alguna incompatibilidad con algun modulo o de la propia plantilla, aunque ese error no lo tenemos documentado en versiones 7.3

Creo que utilizas la versión 1.7.3.2 de PS, prueba actualizar la versión a la última estable 1.7.3.3 y comprueba que la plantilla la tengas también actualizada.

Si añadiste algún módulo después de la instalación lo desactivas.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 28/05/2018 4:29 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Mario
 Mario
Estimable Member

Hola Pepe,

Acabo de actualizar la tienda a la versión 1.7.3.3 y el problema persiste.
Tampoco creo que se deba a los módulos, porque es un problema que surgió justo al hacer la actualización a la 1.7. antes de haber subido ninguno.
Utilizamos el theme Classic que es la plantilla que viene por defecto.
Gracias
Un saludo

Carretera y Manta

ResponderCitar
Respondido : 28/05/2018 5:15 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Mario.

¿ activaste o instalaste algun modulo de lso que no vengan pro defecto activados en PS ?
en esta URL tienes una instalación de PS por defecto y funciona bien, por eso te comento lo de los módulos, no es un bug que pueda tener PS

-> http://joomlero-cp95.webjoomla.es/prestashop17/es/

Añado: revisando tu cuenta veo que el limite de disco lo tienes superado, prueba a eliminar cosas que no necesites del hosting, correos, etc.., es posible que al superar el límite del disco no deje añadir cosas.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 28/05/2018 6:05 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro