Avisos
Vaciar todo

Problema al actualizar a 1.6.1.18  

 
Angel
 Angel
Estimable Member

Hola,
he actualizado un clon que tengo de mi página de la versión 1.16.1.17 a 1.16.1.18 y me ha dado este error:
Quedan 227 archivos por actualizar.
Todos los archivos actualizados. Actualización de bases de datos en curso...
[Ajax / Server Error for action upgradeDb] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: " "

y lo última que ha hecho es:
Copiado /webservice/dispatcher.php.
Copiado /webservice/index.php.

Después de esto me da miedo actualizar la real. ¿Podeis ayudarme?
Gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 25/03/2018 2:23 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Angel.

Manda un ticket a soporte para que te aumenten los valores de tiempo de ejecución de PHP.
Revisa si después de eso puedes actualizar la pagina sin problemas.

Un saludo

ResponderCitar
Respondido : 25/03/2018 2:59 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Angel
 Angel
Estimable Member

Hola, acabo de comprobar que Prestashop se ha actualizado a 1.6.1.18 a pesar del error y aparentemente todo funciona. ¿Que me aconsejas hacer a parte de de que me aumenten los valores de PHP? ¿Deberia volver a la versión anterior?

ResponderCitar
Respondido : 25/03/2018 3:03 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Angel.

¿Debería volver a la versión anterior?
No, si todo te funciona bien deja la actualización como esta, según el aviso es un error de ajax con la función de Upgrade, de normal suele venir por algun corte, por eso el aumento del tiempo de ejecución, pero veo que al final termina con la actualización.

Una posible causa puede ser las copia de seguridad, revisa en el bloque Opciones de copia de seguridad del modulo 1click upgrade que tengas desactivas las copias.

Un saludo

ResponderCitar
Respondido : 25/03/2018 3:14 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Angel.

Pide el aumento de tiempo para PHP, desactiva las copias en el modulo de actualización ( esto es mas que recomendado ) y prueba a realizar de nuevo la actualización.

De todas formas, sabes que tienes copias de los últimos 30 días que puedes restaurar fácilmente.
-> https://guias.webempresa.com/preguntas-frecuentes/gestionar-copias-seguridad-superbackup/

Puedes revisar lo siguiente -> https://www.prestashop.com/forums/topic/433269-solucionadoerrorthrowninternal-server-error-jqxhr/

otra opción seria descargar la ultima versión de la rama de prestashop que tienes instalada -> https://www.prestashop.com/es/versiones-anteriores

.- accedes a la carpeta admin -> autoupgrade -> latest, subes el paquete de prestashop que te descargaste y lo descomprimes en esa carpeta.

.- Accede al modulo En el módulo 1-Click-Upgrade y pulsa en el botón " Más opciones (modo experto) "
.- selecciona “Canal: directorio local”.

Una vez eso realiza la actualización.

Un saludo

ResponderCitar
Respondido : 25/03/2018 3:49 pm