Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

error PSR-0 `Requests en mi web desde que actualize wordpress  

Página 1 / 2
 
frederic
 frederic
Usuario activo

hola
se me cuela un error desde que he actualizado wordpress
en alguas paginas, no todas, aparece el mensaje siguiente (a veces en cabecera, a veces dentro de la pagina)

The PSR-0 `Requests_...` class names in the Requests library are deprecated. Switch to the PSR-4 `WpOrg\Requests\...` class names at your earliest convenience. in /home2/casasier/public_html/wp-includes/class-requests.php on line 24

he intentado bucar en internet como solucionarlo pero no doy con la solución y no sé como arreglarlo

gracias, saludos y feliz añonuevo

Contenido solo visible a usuarios registrados

Citar
Respondido : 01/01/2024 11:02 am
Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Fredereic, 

En este caso primero asegúrate que tenga asignada como mínimo para esta página la versión PHP 7.4 y comprueba si no se muestra este error, si no es así indícanos en cuáles páginas exactamente se muestra para revisarlo con mayor detalle. 

Te comparto la siguiente guía donde indica como modificar la versión PHP de tu sitio web → https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Un Saludo 

ResponderCitar
Respondido : 01/01/2024 2:52 pm

Cursos Gratuitos WordPress

frederic
 frederic
Usuario activo

@karen

hola

he comprobado y tengo php 7,4...

las paginas afectadas son batantes, no las voy a poner a todas aqui pero por ejemplo tienes estas:

https://www.casasierrasalamanca.com/noticias-casas-rurales

https://www.casasierrasalamanca.com/rutas-senderismo   (y entradas de ese blog)

https://www.casasierrasalamanca.com/turismo-astronomico

https://www.casasierrasalamanca.com/reservas-online (alli el texto de error aparece donde deberia haber un calendario)

 

 

voy a probar a cambiar a version php 8 a ver si hay cambios

Esta publicación ha sido modificada el hace 5 meses por frederic
ResponderCitar
Respondido : 01/01/2024 6:44 pm
frederic
 frederic
Usuario activo

hola de nuevo

parece que al poner la verion 8.0, se haya solucionado el problema, no aparece el error de monento

ResponderCitar
Respondido : 01/01/2024 6:53 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

frederic
 frederic
Usuario activo

pensaba haberlo solucionado porque desaparecen esos mensajes pero sale otros ahora includo en index

 

Deprecated</b>:  Required parameter $atts follows optional parameter $defaults in <b>/home2/casasier/public_html/wp-content/plugins/enhanced-media-library/core/medialist.php</b> on line <b>23</b>
ResponderCitar
Respondido : 01/01/2024 6:57 pm
frederic
 frederic
Usuario activo

no obstante, he limpiado el caché y parece que ya no se ve..voy a comprobar en movil y esperar unas horas a ver que pasa

ResponderCitar
Respondido : 01/01/2024 7:04 pm

frederic
 frederic
Usuario activo

en el movil se ve de todo ,aun mas caotico, pagina con el antiguo error, otras con el nuevo, otras con las 2

y en mi ordenador parece que se ve bien

no entiendo nada

ResponderCitar
Respondido : 01/01/2024 7:17 pm
frederic
 frederic
Usuario activo

he vuelto a poner la versión php 7.4

pero sale listas aun mas grandes de errores en algunas paginas.. como esta

https://www.casasierrasalamanca.com/casas-turismo-rural

Esta publicación ha sido modificada el hace 5 meses por frederic
ResponderCitar
Respondido : 01/01/2024 7:24 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Frederic, 

Actualmente tienes activo la opción de Debug de tu sitio web?, veo que la mayoría de los avisos son warning y es posible que se muestren ya sea por tu plantilla que tiene algún conflicto con la versión de WordPress u otro plugin, prueba ahora desactivar el plugin de WPML Sticky Links y borra la caché de WP Rocket, de igual forma asegúrate de actualizar cualquier plugin o aviso que te muestre tu sitio web. 

Verifica si el sitio web función de forma correcta, si es así desactiva la opción de Debug en tu WP config y comprueba como se muestra todo, una alternativa si vez que alguno no funciona de forma correcta es retroceder la versión de WordPress y esperar hasta asegurarse todos tus plugins sean totalmente compatibles con esta nueva versión. → https://www.webempresa.com/blog/como-volver-a-version-anterior-de-wordpress.html

Verifica esto y nos comentas como va todo

Un Saludo 

ResponderCitar
Respondido : 01/01/2024 8:12 pm
frederic
 frederic
Usuario activo

de momento, desde que ayer volví a poner la versión php 7.4 y limpies los caches, parece que sale todo bien tanto en ordenador como en movíl, no he vuelto a tocar nada porque lo de debug no sé que es y no sé como se activa o desactiva...

mis plugins y tema divi estan actualizados todos...

ResponderCitar
Respondido : 02/01/2024 5:49 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Frederic, 

Por ahora veo que todo funciona de forma correcta, como te comento esto parecía ser un problema de caché, sin embargo, mantente al tanto y nos comentas si sucede nuevamente este error. 

Un Saludo 

ResponderCitar
Respondido : 02/01/2024 6:02 pm
frederic
 frederic
Usuario activo

@karen

hola

he vuelto a comprobar la web hoy, y en mi movil sale todavia el mensaje de error en la parte de arriba en esta pagina (y su versión en otros idiomas)

https://www.casasierrasalamanca.com/villanueva-del-conde

 

y en el ordenador aqui tambien

https://www.casasierrasalamanca.com/de/landhaus-spanien

Esta publicación ha sido modificada el hace 5 meses 2 veces por frederic
ResponderCitar
Respondido : 03/01/2024 10:27 am

Cursos Gratuitos WordPress

frederic
 frederic
Usuario activo

https://www.casasierrasalamanca.com/reservas-online   https://www.casasierrasalamanca.com/casas-turismo-rural   (ayer no y hoy sí::)

https://www.casasierrasalamanca.com/pt-pt/casas-ferias-espanha (y en los otros idiomas)

 

es como que desaparecen y vuelven a aparecer

Esta publicación ha sido modificada el hace 5 meses por frederic
ResponderCitar
Respondido : 03/01/2024 10:34 am
frederic
 frederic
Usuario activo

Sé que tengo muchas veces problemas al actualizar, por DIVI y el plugin HB booking. cada vez que lo hago tengo un problema con la web

de hecho, empecé a tener el problema en noviembre y se lo dijé al informatico que me instaló hb boking y que tiene acceso a mi wordpres, fue él que actualizó wordpress a la ultima versión y desde entonces me sale ese error

normalmente suelo restaurar una copia de seguridad anterior, y esperar un tiempo prudencial antes de actualizar ese plugin y la plantilla Divi.. pero esta vez no pude porque perderia mi trabajo de actualización de calendario y tarifas del plugin hb booling para 2024

Esta publicación ha sido modificada el hace 5 meses por frederic
ResponderCitar
Respondido : 03/01/2024 10:46 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Frederic

El error error PSR-0 viene porque el nombre de la clase PSR-0 está obsoleta y ya no se utiliza.

Por lo que veo es en todos calendarios para seleccionar las fechas y el problema viene del plugin Hotel Booking, al ser de pago tendrias de consultarlo con su soporte:

-> https://motopress.com/forums/forum/wordpress/plugins/hotel-booking/

 

Por favor haz una prueba, Vacía la caché de WPRocket y revisa si se elimina ese aviso.

 

Un Saludo

ResponderCitar
Respondido : 03/01/2024 11:29 am
Página 1 / 2