Avisos
Vaciar todo

[Resuelto] Salud del sitio: 1 error crítico y 2 mejoras recomendadas  

Página 1 / 3
 
Diana
 Diana
Usuario eminente

Hola,
En el Wordpress aparece un mensaje (adjunto captura de pantalla) que habla de 1 error crítico y 2 mejoras recomendadas relacionadas con seguridad y rendimiento. Esto hace que la web no se vea bien y el footer ha desaparecido.

Mis conocimientos son casi nulos y no tengo ni idea cómo solucionar esto. 

Pongo lo que dice cada item: 

1 error crítico

Tienes temas esperando a ser actualizados. 

Los temas añaden el aspecto y comportamiento de tu sitio. Es importante tenerlos actualizados, para mantener la coherencia con tu marca y mantener tu sitio seguro.

Tu sitio tiene 1 tema esperando a ser actualizado. 

Gestiona tus temas

Hago clic en gestiona tus temas y no tengo ni idea de lo que debo hacer. 

 

2 mejoras recomendadas

Faltan 1 o más módulos recomendados: 

Los módulos PHP realizan la mayoría de las tareas en el servidor que hacen que tu sitio funcione. Cualquier cambio en ellos debería hacerlo el administrador de tu servidor.

El equipo de alojamiento de WordPress mantiene una lista de estos módulos, tanto los recomendados como los obligatorios, en el manual del equipo (abre en una nueva pestaña).

  • Advertencia El módulo opcional, imagick, no está instalado, o ha sido desactivado.

Mis conocimientos son casi nulos y no tengo ni idea de qué debo hacer y me da miedo tocar algo y que se estropee la web. 

Espero me puedan ayudar. 


Un saludo,

 

Contenido solo visible a usuarios registrados

Respondido : 06/10/2021 3:32 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Diana.

Tranquila que estamos para ayudaros en lo que podamos y no tengas miedo 😉  

1 error crítico Tienes temas esperando a ser actualizados. 

Lo que te indica es que tienes una plantilla sin actualizar:

.-  Accede a Escritorio -> Actualizaciones:

screenshot mary52.webempresa.eu 2021.10.06 16 48 29

.- Actualiza todo lo que tengas pendiente, plugins y plantilla

Solo tienes que seleccionar todo y pulsar en el boton de Actualizar:

screenshot mary52.webempresa.eu 2021.10.06 16 50 17

2 mejoras recomendadas Faltan 1 o más módulos recomendados: 

El modulo que te indica " El módulo opcional, imagick, no está instalado, o ha sido desactivado. " este modulo es de PHP y se instala en el servidor, nosotros no lo instalamos por motivos de seguridad ya que necesita de unos permisos de servidor que hace que cualquier usuario externo pueda tomar el control de tu instalación.

No te preocupes que no es un modulo necesario para el funcionamiento de tu web es mas en la mayoría de servidores y mas si son compartidos no se instala ese modulo.

 

Revisa lo que te comento y vemos si aparece el Footer.

 

Un saludo

Respondido : 06/10/2021 4:04 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Diana
 Diana
Usuario eminente

@pepesoler Hola Pepe, 

He dado actualizar todo en los plugins y me salió este mensaje. 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Respondido : 06/10/2021 4:28 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Diana,

Veo que tienes tu web activa por lo que el error fue solo al intentar actualizar, puedes enviarnos una captura directamente de Escritorio > Actualizaciones, para poder validar si se han actualizado de forma correcta?

Un saludo 🖐️ 

Respondido : 06/10/2021 4:41 pm

Cursos Gratuitos WordPress

Diana
 Diana
Usuario eminente

@argenis Hola Argenis, 

Conseguí actualizar los plugins. Sin embargo sigue apareciendo una actualización pendiente y es del tema. 

Tengo entendido que mi tema es Divi, con lo cual no sé porque me dice de actualizar un tema que se llama: Twenty Twenty-One que nunca me ha dicho el diseñador que haya usado. Entonces no sé si dar a actualizar y que se desconfigure la web.

 

He ido a la web y el footer no aparece.

Y las páginas se han desconfigurado, como esta: https://www.dianaspeaks.net/sobre-mi/

https://www.dianaspeaks.net/programas/

 

Captura de pantalla 2021 10 06 a las 17.43.03

Te adjunto captura de pantalla de como la veo en mi navegador.

Captura de pantalla 2021 10 06 a las 17.40.19

 

Te adjunto la captura de pantalla de Escritorio > actualizaciones

Captura de pantalla 2021 10 06 a las 17.46.23

 

Esta publicación ha sido modificada el hace 3 semanas por Diana
Respondido : 06/10/2021 4:44 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Diana,

Si no lo utilizas puedes eliminarlo, este es un tema que viene por defecto en algunas instalaciones:

ingresas en apariencias > temas, una vez dentro haces clic en el tema y te mostrara lo siguiente:

image

Haces clic en este botón y eliminarás el tema que no esta en uso.

Veo que tienes litespeed cache, verifica vaciar la cache completa del sitio en la parte superior:

image

Luego también vacía la cache directamente del divi:

Divi > Opciones del tema > constructor > Avanzado > claro 

image

Verifica esto y nos comentas.

Un saludo 🖐️ 

Respondido : 06/10/2021 4:53 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Diana
 Diana
Usuario eminente

Hola Argenis, 

He eliminado el tema, purgado todo y vaciado la caché del divi. 

He ido a la web y el footer no aparece.

Y las páginas que se han desconfigurado continúan desconfiguradas; como esta:  https://www.dianaspeaks.net/sobre-mi/

https://www.dianaspeaks.net/programas/

 

Captura de pantalla 2021 10 06 a las 17.43.03

 

Captura de pantalla 2021 10 06 a las 17.40.19

 

Te adjunto la captura de pantalla de Escritorio > actualizaciones en donde se ve pendiente 1 actualización pero no hay nada más

Captura de pantalla 2021 10 06 a las 18.08.52

 

 

Respondido : 06/10/2021 5:12 pm
Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Diana,

Entiendo, en este caso puedes escribir a tickets para que verifiquen si hay algo a nivel de tu servidor que te impide realizar este ajuste? desde foro vemos que tienes una mala configuración entre la url del sitio y la url del home por esto pueden fallar algunos complementos.

para solventarlo debes modificar tu archivo wp-config que está ubicado en:

Cpanel > Administrador de archivos > Public_html > dominio > wp-config.php

y verificar estos dos espacios:

image

Deben ser iguales los dos.

Un saludo 🖐️ 

Respondido : 06/10/2021 5:29 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola diana,

Nos contactaron directamente de tickets, con el archivo que tiene el error, vemos que tienes al final de tu archivo wp-config, una configuración a multisite:

define( 'WP_ALLOW_MULTISITE', true );

define ('FS_METHOD', 'direct');
define('RELOCATE',true);

Verifica el eliminar estas 3 líneas que encuentras al final del todo, luego de que las borres verifica si la web se ve de forma correcta, si por alguna razón obtienes un error al tratar de visualizar la web como por ejemplo un 404 o error de pantalla en blanco, vuelves a escribir el código de 3 líneas.

En este caso que suceda esto solo elimina el primero es decir:

define( 'WP_ALLOW_MULTISITE', true );

Con esto ya verificas y si se visualiza el sitio vacía nuevamente la cache.

Un saludo 🖐️ 

Respondido : 06/10/2021 6:22 pm
Diana
 Diana
Usuario eminente

Hola Argenis, 

He ido a la ruta: Cpanel > Administrador de archivos > Public_html > dominio > wp-config.php , he escogido el dominio de dianaspeaks.net pero no encuentro: wp-config.php

Te adjunto captura de pantalla.

Captura de pantalla 2021 10 06 a las 19.40.36

 

Respondido : 06/10/2021 6:42 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Diana,

Eso es un archivo que se encuentra dentro del dominio, en la captura que envías se puede ver:

image

Un saludo 🖐️ 

Respondido : 06/10/2021 6:46 pm
Diana
 Diana
Usuario eminente

Hola Argenis, 

Eliminé las 3 líneas, purgue, vacíe cache y la web se ve. Es decir, no hubo error 404 o página en blanco. Sin embargo, las páginas continúan desconfiguradas. 

Luego eliminé únicamente la primera línea e hice todo lo anterior. Y las páginas continúan desconfiguradas. 

Ahora está con las 2 líneas puestas. Lo dejó así o las quito? Igualmente con ninguna opción funciona. 

Respondido : 06/10/2021 7:05 pm

Cursos Gratuitos WordPress

Argenis
 Argenis
Soporte CMS Webempresa Moderator

Hola Diana,

Elimina las 3, sin embargo te recuerdo lo que te comente, al eliminar debes ingresar y vaciar la cache de litespeed cache, verifica y nos comentas.

image

Un saludo 🖐️ 

Respondido : 06/10/2021 7:08 pm
Diana
 Diana
Usuario eminente

Hola Argenis, 

Eliminé las 3 líneas y vacié la caché como me enseñas en la captura de pantalla y se siguen viendo desconfiguradas las páginas.

Respondido : 06/10/2021 7:14 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Diana, 

He ingresado a la página de Sobre mí en tu sitio web y veo se muestra de forma correcta, te envió una captura de lo que veo

image

Sin embargo la página de programas aún no se ve con los estilos correctos, verifica si tienes alguna cache aún almacenada para esta página y prueba borrarla. De igual forma verífica lo siguiente

Ingresa a la sección de Ajustes -> Enlaces permanentes y si realizar ningún cambio pulsa en el botón guardar cambios luego comprueba si con ello esta página carga de forma correcta

Screenshot (76)

Verifica esto y nos comentas como ha ido todo

Un Saludo 

 
Esta publicación ha sido modificada el hace 3 semanas por Karen Rios
Respondido : 06/10/2021 7:30 pm
Página 1 / 3