Actualizar de 1.5 a 2.5 ¿es recomendable?  

Página 1 / 2
 
Juan Rivero Prada
 Juan Rivero Prada
Usuario eminente

Buenas tardes,

nos ha llegado vuestro mail informando sobre la posibilidad de actualizar a joomla 2.5. Nuestra pregunta es: Teniendo joomla 1.5, es recomendable actualizar "tanto"? Perderemos algunas posibles funcionalidades? Qué pasa con extrensiones y componentes extra que hayamos instalado, puede que dejen de funcionar?

Muchas gracias y un saludo

Juan Rivero

URL del sitio: http://www.partidodemayoresyautonomos.com

Citar
Respondido : 07/03/2012 4:26 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola Juan

Si tienes un sitio web en Joomla 1.5 funcionando sin problema , no es estrictamente necesario que lo cambies a Joomla 2.5.

Pasar de Joomla 1.5 a 2.5 es una migración que puede involucrar muchas horas , incluye verificar si la plantilla usada esta disponible para esta versión, asi como las extensiones que estas usando, asi como pasar los datos de cada extensión, etc.

Si tienes un proyecto nuevo si es recomendable hacerlo en Joomla 2.5

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/03/2012 4:34 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ivan
 Ivan
Estimable Member

Entonces porque seguiis haciendo las webs para vuestros clientes en joomla 1.5?

Yo me estoy viendo que me entregasteis la web hace unos meses, y ahora me tengo que poner yo a actualizar todo desde la 1.5 cuando ya lo habiais podido montar sobre la version 2.5

O que me sugieres que haga?

Me imgino que cuando sacan una nueva version, sera porque sacan cosas nuevas, novedades que siempre estaran bien...

ResponderCitar
Respondido : 12/04/2012 2:11 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Ivan,

Depende de los requerimientos de cada cliente que se proceda a realizar en una versión u otra, en tu caso al no saber la url del sitio desconozco los motivos.

Un ejemplo puede ser, una tienda virtual con Joomla! 2.5, pero hace unos meses Virtuemart 2.0 no funcionaba con esa versión, por lo tanto no se puede realizar el sitio web con 2.5 y hay que realizar con 1.5.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 13/04/2012 11:18 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Ivan
 Ivan
Estimable Member

Hola, buenas noches.

La pagina web que me habeis hecho es http://bentrone-cp17.webjoomla.es || esta casi tal cual a como me la habeis entregado, lo unico que he hecho es trastear un poco para ver como se pueden poner articulos, poner algun que otro producto en la tienda y asi.. poca cosa, que realmente lo tendre que borrar todo para poner los articulos en la tienda con su debido precio y caracteristicas, al igual que noticias y alguna que otra imagen.

Si es posible actualizar, me gustaria que lo hicieseis vosotros, ya que mi formacion es casi nula sobre joomla, y los usuarios y contraseñas que usteden han creado siguen siendo los mismos, con lo que, podreis actualizarlo sin ningun problema, de hecho lo prefiero, antes de que meta yo la pata y me pueda cargar algo.

Los demas modulos y extendiones a parte del virtuemart, se han actualizado para esta version?? y la plantilla?

Un saludo

ResponderCitar
Respondido : 13/04/2012 10:10 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ivan,

El planteamiento para realizar una migración de Joomla! 1.5 a 2.5 es el siguiente:

- Podrás migrar si tus actuales extensiones ya están disponibles en Joomla! 2.5, lo cual deberás verificar en el JED: http://extensions.joomla.org/search?q=joomla+1.7
- NO podrás migrar si tus extensiones no están disponibles para Joomla! 2.5, y esta premisa es fundamental para seguir hablando de migraciones.
- Podrás migrar si ADEMÁS de tus extensiones, tu plantilla en uso esta disponible para Joomla! 2.5.
- Podrás migrar a Joomla! 1.7 si tus extensiones están disponibles para Joomla! 2.5 pero NO deberías migrar si tu plantilla no está disponible para esta rama, o por el contrario tendrás, tras la migración, pasar por un proceso de ADAPTACIÓN de la misma a una liberada para 2.5 y reajuste de módulos a nuevas posiciones.

Importante volver a leer el siguiente documento:

- https://www.webempresa.com/blog/item/468-joomla-17-preguntas-frecuentes-faqs.html

Recomendación: no realizar una migración sin previamente hacer un respaldo del sitio web, preferiblemente con Akeeba Backup.
-

Tras analizar estos puntos, la migración actualmente es relativamente sencilla y con extensiones como jUpgrade se realiza de forma rápida desde Joomla! 1.5 a Joomla! 2.5 en un solo proceso.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/04/2012 10:26 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ivan
 Ivan
Estimable Member

Ya hice el backup, clone el sitio y esta montado listo para actualizar...

Ahora me queda una duda muy importante y de usuario muy novel...

Como se cuales no son las extensiones que no pertenecen al propio joomla??

Son las que salen en el menu que se desplegan cuando en Administrador/Componenents? los que se desplegan en la lista de componentes?

o en....

Gestor de extensiones

Gestor de extensiones / Componentes

Ahi hay unos que ponen Joomla Proyect.. estos que son los propios del joomla?
Los que ponen a otros atores son los que tengo que buscar si existe version para 2.5?

La plantilla que uso en mi web, si esta para la version 2.5

ResponderCitar
Respondido : 25/04/2012 11:35 am
Miguel Tuyaré
 Miguel Tuyaré
Honorable Member

Hola Lucas:

Para saber cuáles son las extensiones del núcleo has lo siguiente desde la administración:

Ve a Extensiones -> Gestionar Extensiones -> Gestionar

Las que están con un candado son propias de Joomla, por lo tanto están bloqueadas.

Las demás son las instaladas luego.

Orientar personas, despertar vida.

ResponderCitar
Respondido : 25/04/2012 2:09 pm

Cursos Gratuitos WordPress

Ivan
 Ivan
Estimable Member

estas son las extensiones que creo k no son propias del joomla:

BreezingForms || Hay version para 2.5
Akeeba || Hay version para 2.5
CustomQuickIcons || Version 1.5 / No hay actualizacion para la 2.5
CSVI VirtueMart || Hay version para 2.5
Favorites || Hay version para 2.5
IM Reports || Version 1.5 / No hay actualizacion para la 2.5
J!Position || Version 1.5 / No hay actualizacion para la 2.5
JCE || Hay version para 2.5
masscontent || Version 1.7 / No hay actualizacion para la 2.5
ninjaXplorer || Version 1.5 / No hay actualizacion para la 2.5
PhocaFavicon || Hay version para 2.5
PhocaPDF || Hay version para 2.5
Translations Manager || Version 1.5 / No hay actualizacion para la 2.5
versions || Version 1.6 / No hay actualizacion para la 2.5
VirtueMart || NO SE SI LO HAY PARA 2.5
VirtueMart Dashboard || Hay version para 2.5
VirtueMart Analytics || NO SE SI LO HAY PARA 2.5
Widgetkit || Hay version para 2.5
Xmap || Version 1.5 / No hay actualizacion para la 2.5

Los que no hay para version 2.5 son realmente necesarios para actualizar la web?

ResponderCitar
Respondido : 25/04/2012 11:43 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Ivan,

En el caso de Virtuemart y Xmapp son necesarios actualizarlos, y se encuentran actualizados para Joomla 2.5 te adjunto los links:

Virtuemart
http://virtuemart.net/downloads

Xmapp
http://extensions.joomla.org/extensions/structure-a-navigation/site-map/3066

En el caso de VirtueMart Analytics puedes reemplazarlo por Sales Analytics,

Sales Analytics
http://analytictools.latitudweb.com/products/sales-analytics.html

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/04/2012 12:01 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ivan,

Te comento sobre las extensiones que citas:

BreezingForms || Hay versión para 2.5 <- Actualizable con jUpgrade.
Akeeba || Hay version para 2.5 <- Hay versión, desde la 3.3.x todas son multiversión.
CustomQuickIcons || Version 1.5 / No hay actualizacion para la 2.5 <- 2.5 dispone de versión.
CSVI VirtueMart || Hay version para 2.5 <-- La versión 4.x es para 2.5 y es de Pago.
Favorites || Hay version para 2.5 <-- No se a que te refieres, detallalo.
IM Reports || Version 1.5 / No hay actualizacion para la 2.5
J!Position || Version 1.5 / No hay actualizacion para la 2.5 <- Solo funciona en Joomla! 1.5
JCE || Hay version para 2.5 <- Desde la versión 2.0.x de JCE es multiversion.
masscontent || Version 1.7 / No hay actualizacion para la 2.5 <- Solo funciona en Joomla! 1.5
ninjaXplorer || Version 1.5 / No hay actualizacion para la 2.5 <- Dispones de eXtplorer.
PhocaFavicon || Hay version para 2.5
PhocaPDF || Hay version para 2.5
Translations Manager || Version 1.5 / No hay actualizacion para la 2.5 <- Joomla! 2.5 utiliza multiidioma por lo que no es necesario.
versions || Version 1.6 / No hay actualizacion para la 2.5 <- Solo funciona en Joomla! 1.5
VirtueMart || NO SE SI LO HAY PARA 2.5 <- Naturalmente que hay, la versión 2.0.x
VirtueMart Dashboard || Hay version para 2.5
VirtueMart Analytics || NO SE SI LO HAY PARA 2.5
Widgetkit || Hay version para 2.5
Xmap || Version 1.5 / No hay actualizacion para la 2.5 <- Si hay versión para 2.5

Te recomiendo visites con regularidad nuestro Blog pues publicamos mucha información sobre extensiones disponibles para Joomla! 2.5

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/04/2012 12:04 am
Ivan
 Ivan
Estimable Member

Antes de nada, agradeceros toda la ayuda que me estais ofreciendo por responder mis mensajes en el foro.

En cuanto al "Favorites" me pone lo siguiende: MobyJam Solutions - http://virtuemart.MobyJam.net

Realmente no tengo ni idea de lo que es...

Hay algun tema en el que hableis sobre como se debe de hacer la actualizacion del virtuemart de la 1.1.9 a la 2.0.6? Despues de hacer la actualizacion tendre que configurar todos los datos de las cuentas, pasarelas de pago y demas??

Una ultima pregunta.. Realmente cuando debo actualizar las extensiones para la version 2.5, antes de ejecutar el JUpgrade o despues??

ResponderCitar
Respondido : 26/04/2012 12:41 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Ivan

Según verifico el componente Virtuemart Wishlist direcciona al siguiente enlace y esta disponible para Joomla 2.5: http://www.vmwishlist.com/ , sobre la actualización de los productos puedes hacerlo mediante CSV Improved te adjunto el siguiente vídeo tutorial:

Introducción a CSV Improved
http://www.videosjoomla.com/videos-joomla/item/152-introducci%C3%B3n-a-csv-improved

Sobre la actualización por medio de JUpgrade te adjunto el siguiente blog con su respectivo vídeo tutorial:

Migrando Joomla 1.5 a Joomla 2.5 con Jupgrade
https://www.webempresa.com/blog/migrando-joomla-15-a-joomla-25-con-jupgrade.html

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/04/2012 12:56 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ivan,

Primero de todo, haz una copia de seguridad de los datos de tu web antes de actualizar para que, en caso de que se produzca cualquier tipo de problema, se pueda volver a la versión anterior. Para ello, te recomiendo que utilices el Akeeba Backup.

A continuación descárgate la última versión de Virtuemart 2.0 que podrás encontrar en el siguiente enlace:

- http://virtuemart.net/downloads

El archivo que te descargarás tendrá un nombre como com_virtuemart.2.0.X_extract_first.zip en donde X es la versión de Virtuemart. Tienes que descomprimir el archivo y te aparecerán 2 nuevos archivos. Estos son los archivos que tienes que instalar para realizar la actualización.

Una vez que hayas actualizado verifica que todo siga funcionando. Lo mejor es que hagas alguna prueba de compra.

En el caso de que se produzcan fallos es posible que tengas un template overwrite de las plantillas de Virtuemart. Esto significa que la plantilla de Joomla que estás usando está aplicando sus propias plantillas de Virtuemart. Para comprobar si el fallo está producido por esto vete a templates/NOMBRE_PLANTILLA_JOOMLA/html (en donde NOMBRE_PLANTILLA_JOOMLA es la plantilla de Joomla que está usando) y comprueba si en este directorio ves una carpeta con nombre com_virtuemart. De ser así, prueba a renombrarla como com_virtuemart_PRUEBA y comprueba si los fallos se solucionan.

Ten en cuenta que al hacer esto cambiará el aspecto de las distintas páginas de la tienda.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/04/2012 1:09 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ivan
 Ivan
Estimable Member

Cuanto puede tardar JUpgrade en actualizar??

Lleva ya casi 2 horas y aun sigue en el primer paso: Checking and cleaning...

Y parece que no hace nada.. ya lo intente varias veces con el mismo tiempo.. y no consigo.. voy a dejarle mas horas a ver que pasa.

ResponderCitar
Respondido : 26/04/2012 8:09 am
Página 1 / 2

Por favor Iniciar Sesión o Registro