Cambiar imagen al cambiar de idioma  

 
Ignacio
 Ignacio
Usuario experto

Buenas tardes,

Tengo un problema al utilizar el joomfish. Resulta que he instalado un componente llamado HTML MAPS, que me crea zonas interactivas, y hasta aqui todo bien.

Pero cuando intento traducir al catalan con el Joomfish, me lo hace todo bien, menos el cargar la imagen que deberia. Es decir, los enlaces si los traduce, traduce tambien las urls de destino, pero la imagen que me muestra, sigue siendo la que tengo en castellano.

Asi que lo unico que tengo que hacer, es que cuando clickee sobre la bandera catalana, cambie la foto, pero no encuentro como.

Espero que alguien pueda ayudarme.

www.alphanet.cat/portal/es

Muchas gracias por todo.

Saludos.

Citar
Respondido : 27/03/2011 4:33 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Ignacio

Para que funcione las traducciones tendrías que integrar el componente que utilizas para mapeo html Maps con Joomfish.

Creo que puedes prescindir del componente de mapeo, usualmente un mapeo es código html, tal como lo puedes ver en tu sitio web al ver el código fuente, el mensaje que sale en el fondo amarillo esta hecho con javascript, si no utilizas el módulo se mostrará en formato standard.

Sugiero crees un módulo personalizado y pegues ese código generado por el componente, es decir lo que esta dentro de la etiqueta htmlmap_center (al ver el código fuente de tu página con el boton derecho del mouse)

Una vez creado el componente personalizado entonces puedes editarlo desde joomfish cambiando los textos de idioma y la imágen.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/03/2011 4:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ignacio
 Ignacio
Usuario experto

Hola Jhon,

He probado lo que me has comentado. He recogido el codigo html que genera la pagina, para poder luego traducir.

Pero me pasa, que entonces no me funciona la parte de las zonas interactivas. El codigo está, pero no funciona.

Ahora esta, justo como como me has comentado.

Saludos y gracias.

Nacho

ResponderCitar
Respondido : 27/03/2011 5:26 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Ignacio

La imagen debe hacer referencia al mapa, en tu caso debes agregar un atributo a la imagen con el siguiente valor:

usemap="#htmlmap_mod123_1"

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/03/2011 5:34 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ignacio
 Ignacio
Usuario experto

Hola Jhon,

Oye, muchisimas gracias!!!! Ya funciona! Tenia problemas con el editor Joomla, que no me recogia el atributo y al guardar, desaparecia.

Asi pues, he desconectado el editor, lo he dejado en html pelado, y ya me esta funcionando.

Muchas gracias por todo y saludos.

Nacho

ResponderCitar
Respondido : 27/03/2011 5:59 pm

Por favor Iniciar Sesión o Registro