CSVI y Virtuemart, ya casi casi lo logro pero sigo teniendo un par de problemas...  

Página 1 / 2
 
Marta
 Marta
Usuario experto

Buenos días y feliz domingo! 🙂

Llevo intentando subir mis productos con CSVI bastante tiempo, y siempre me encuentro con inconvenientes tontos que he ido resolviendo. Los últimos son los que siguen:

Estoy utilizando una hoja de cálculo de Open Office para manipular los datos, ya que a diferencia de Excel me permite escoger UTF8 y guardar como CSV sin problemas.
Descubrí que como "product_name" me permitía añadir tildes y ñ sin problemas, no así en las descripciones, que tenía que insertar en html. El problema está en las tildes o eñes de los atributos.
Por ejemplo: si pongo una palabra directamente con "ñ" en el csv se me corta ahí toda la cadena, y si lo pongo como html (Tamaño) me da de alta dos atributos, uno "tamañ" (con cero variables) y otro "o" con las variables pertinentes.
Aquí van los pantallazos:

Por otro lado, y este es el último super error, he borrado todos los productos que tenía (mal importados), y los he vuelto a subir (con diferente sku) una vez. Algo se ha debido de "quedar enganchado" en la base de datos, porque aun habiendo subido los primeros 400 productos correctamente (así se ve en el backend, este pantallazo es el de la categoría de lienzos, por ejemplo)

En el frontend se muestra únicamente un producto igual para los 400 diferentes que se han subido (este es el frontend de la misma categoría que antes mostré el backend)

Para intentar forzar un poco a que me muestre los artículos reales que están subidos, he intentado hacer una búsqueda de la palabra "amarillo" (hay 23 productos subidos con ese color en el nombre) y me salen los siguientes errores en la página de resultados:

Evidentemente, al acabar los errores me sigue mostrando un listado del producto "enganchado"

En fin, ¿cómo hago para "desenganchar" el producto ese y que se visualicen bien mis productos? ¿Qué tengo que poner en vez de "ñ" y "ñ" en los atributos? Estaré eternamente agradecida a quien me pueda resolver, por fin, estos problemas y me permita abrir de una vez por todas la tienda 🙂

Un abrazo,

Marta.

Citar
Respondido : 23/10/2011 11:37 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Marta

Puedes adjuntar un ejemplo de tu hoja de open office con algunos productos para hacer una prueba de las tildes y eñes?

Prueba eliminando todo, productos y categorías . Es recomendable realizar tus pruebas de importación en una copia de tu sitio web para evitar este tipo de problemas.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/10/2011 2:04 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Marta
 Marta
Usuario experto

Aquí va el ejemplo de la hoja de cálculo... con algunas tildes y eñes incluídas. No eliminé las categorías, sólo los productos... ¿crees que debería eliminar también las categorías y volver a subirlo todo otra vez? ¿No será simplemente que "algo" está cogiendo un id de producto concreto que ya se borró pero no se borró bien y que con que lo quite de la base de datos bastaría? :-/

Gracias Jhon, por la ayuda...

ResponderCitar
Respondido : 23/10/2011 4:06 pm
Marta
 Marta
Usuario experto

No me deja subir el archivo... o pone no encontrado. ¿alguna otra forma de subirlo?

ResponderCitar
Respondido : 23/10/2011 4:08 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Marta,

Comprime el archivo en formato .zip para poder subirlo sino el Firewall lo bloqueará.

Yo también he tenido problemas con OpenOffice para cargar items de VirtueMart que incluían tildes o caracteres como "ñ" y me pase a LibreOffice y si me funcionó.

No es vinculante pero en mi caso funciono.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/10/2011 5:30 pm
Marta
 Marta
Usuario experto

Gracias Gnumax, no sabía que tenía que comprimirlo... Ahí mando el ejemplo. Luego me descargaré el "libreoffice" y haré una prueba como dices (no lo conozco), a ver se me facilita por ahí 🙂 Gracias por la idea.

Por cierto, ¿se te ocurre a tí algo con respecto a que sólo se visualice un producto de los 400 que hay? :-/

Ese es el segundo problema que tengo que resolver :-/

ResponderCitar
Respondido : 23/10/2011 6:26 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Marta,

Que solo se visualice un producto, entiendo que el primero de la lista, es porque no está procesando correctamente los registros, que después del primero habrá alguna línea o sentencia que evita que continúe el proceso de importación, pero hay que verlo en detalle, es solo una afirmación superficial por mi parte.

LibreOffice es la consecución "libre" de OpenOffice. este programa fue comprado por Oracle y paulatinamente lo fue cerrando y se volvio muy restrictivo y entonces la comunidad de desarrolladores de OpenOffice abandonó el proyecto (por privativo) y creo un fork llamado LibreOffice que ahora es el estándar y el que masivamente se ha ido implantando por que es un proyecto libre que respeta las licencias originales de lo que en su día fue OpenOffice.

Ahora mismo OpenOffice es un proyecto muerto o estancado.

Habrá que hacer pruebas con el archivo que adjuntas.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/10/2011 7:01 pm
Marta
 Marta
Usuario experto

Hola Gnumax,

No es el primero de la lista, sino el 135... ni siquiera es el primero de su categoría. Para más inri, ese que se mostraba en la mañana, cuando he sacado los pantallazos del primer mensaje, no es el mismo que sale ahora, sin haber hecho ninguna modificación ni tocado para nada la tienda :blink:

No creo que sea eso que dices, que el proceso de importación no se completa, porque la importación se realiza adecuadamente, como podrás comprobar en los pantallazos del backend que colgué en el primer mensaje. No es que los productos no estén en el virtuemart, es que en el proceso de mostrarse interpreta todas las llamadas como si fuera a uno solo, no sé si me explico, y muestra uno solo las n veces que productos hay, no sé si me explico. ¿alguna otra idea?

ResponderCitar
Respondido : 23/10/2011 7:38 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Marta,

Prueba a guardar el archivo de excel en formato de Office (de Microsoft) y revisarlo, una vez revisado trata de importar los datos con CSVImproved a ver si carga todos correctamente.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/10/2011 8:00 pm
Marta
 Marta
Usuario experto

Hola Gnumax,

Mis primeros problemas de exportación han sido con Excel. Ya sé que ese no me vale, creo que porque no me exporta los productos en utf8. Por eso probé el OpenOffice, porque en algún lugar de la red ponía que permitía escoger el lenguaje al abrir el archivo (como efectivamente hace).
Ahora, haga lo que haga, tengo que eliminar todos los artículos que están en la tienda y volver a subirlos correctamente, probaré con LibreOffice como proponías en tu mensaje anterior. Al haberse importado mal los atributos no puedo simplemente "picar" por encima, porque me duplicaría los atributos y tendría que borrar los incorrectos de uno en uno, que es algo que quiero evitar a toda costa. Así que tengo que borrar todos los productos, que es algo que ya hice anteriormente. Tomé la precaución la ocasión anterior de cambiar los sku para que no tomara datos de los productos erróneos, pero la verdad es que me gustaría "limpiar" la base de datos para que estuviera vacía de nuevo al subir los productos ya definitivamente correctos con LibreOffice, y que volviera a contar de cero los ids... ¿es posible hacer eso? ¿cómo? ¿desde el Cpanel? ¿qué es exactamente lo que hay que tocar para no cargarse nada más?
Yo creo que si limpiara todo quizá no volviera a mostrar un artículo solo en el front end en vez de los artículos que corresponden. Es una cosa mágica e incomprensible para mí. Además, ese artículo que muestra no es siempre el mismo.
Ayer en la mañana era un color de la categoría pintura en seda (línea 135 de la hoja de cálculo):

Ayer en la noche era un color de la categoría de acrílicos (línea 12 de la hoja de cálculo):

Hoy en la mañana es un producto de la categoría de lienzos (línea 64 de la hoja de cálculo):

No encuentro ningún criterio lógico por el que esto esté pasando, así que me parece que, a menos que a vosotros se os ocurra alguna solución, lo mejor que puedo hacer es borrar todos los productos y categorías de virtuemart y subirlo de nuevo, a ver si igual de mágicamente el asunto se arregla. ¿me ayudáis y me decís cómo puedo hacerlo?

Gracias!

ResponderCitar
Respondido : 24/10/2011 9:57 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Marta

Tal como te comentamos anteriormente, es recomendable hacer pruebas en un sitio web alternativo antes de realizar la importación final.

Puede desinstalar virtuemart y todos sus componentes anexos, módulos , plugins, etc, y luego eliminar también las tablas de la base de datos , usualmente tienen el prefijo "vm" con esto las podrás identificar. Asegúrate de realizar un backup de tu sitio web.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/10/2011 1:54 pm
Marta
 Marta
Usuario experto

Hola Jhon,

Gracias por tu respuesta... me da algo de miedo toquetear sin más, porque creo que podría equivocarme al seleccionar los componentes anexos, módulos, plugins, etc. que estén relacionados con virtuemart. No sé cuáles son 🙁

¿crees que podría hacer una copia del sitio web completo simplemente copiando todas las carpetas del ftp y pegándolas en otra carpeta nueva tipo "copiatienda" en el mismo ftp y hacer las pruebas con fidelidad en esa copia? Por si las flyes y la cago... :dry:

ResponderCitar
Respondido : 25/10/2011 10:24 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Marta,

Una copia de seguridad de un sitio web, no solo es copiar archivos, sino que copiar también la base de datos.

La mejor manera de mover tu Joomla! a "cualquier" otro lugar "remoto o local" es mediante el uso de la extensión "gratuita" llamada Akeeba Backup, la cual te permite realizar una copia completa de tu sitio y base de datos en formato .jpa (formato propietario de la extensión y el más recomendado) que en un solo archivo te permite llevarte tu instalación a donde quieras o mantenerlo como archivo de seguridad.

Te adjuntamos unos vídeos para poder copiar y restaurar un Joomla! de un Hosting a otro o en el mismo Hosting, ya sea local o remoto:

Como copiar tu Joomla con Akeeba Backup o JoomlaPack: https://www.webempresa.com/videos/akeeba_copiadeseguridad/akeeba_copiadeseguridad.html

Como restaurar tu Joomla con Akeeba Backup o JoomlaPack: https://www.webempresa.com/videos/akeeba_restauracion/akeeba_restauracion.html

En el caso que pongas una contraseña al realizar un backup apúntala para luego introducirla en la restauración.

------------------------------

Precaución de no poner los mismos datos en la base de datos, ya que sobreescribirias la actual. Hay que crear una nueva, y un usuario con permisos totales sobre la misma.

------------------------------

Otra opción de clonar joomla!, pero en este caso completamente manual es:
https://www.webempresa.com/videos/joomla-backup/joomla-backup.html
y luego subir como se indica:
https://www.webempresa.com/videos/local-a-servidorwebempresa-1/local-a-servidorwebempresa-1.html

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 25/10/2011 4:14 pm
Marta
 Marta
Usuario experto

Vale. Ya he tocado todo lo que he podido, he intentado borrar y reinstalar y me lo he cargado todo varias veces (gracias Jordi por el súpertutorial de copia de seguridad, me ha salvado la vida ;-))
No entiendo que pasa, incluso no estando en producto único que se muestra en todos lados en la base mysql, sigue viendose en el frontend! No comprendo que falla y me rindo, porque necesito abrir ya... ¿Podéis hacerlo vosotros? Seguro que os cuesta menos... ¿Cómo vais de tiempos? ¿Puedo contratados un par de horas de mantenimiento para que lo veáis mañana?
Sería estupendo poder abrir pronto... :huh:

ResponderCitar
Respondido : 27/10/2011 4:03 pm

Cursos Gratuitos WordPress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Marta,

Perfecto que te hayan sido de utilidad nuestros tutoriales 🙂

Si deseas soporte técnico de Webempresa aquí tienes más información sobre el Servicio de Mantenimiento Joomla!:
https://www.webempresa.com/web-empresa-joomla-servicios/soporte-joomla.html

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 28/10/2011 7:44 am
Página 1 / 2

Por favor Iniciar Sesión o Registro