Dónde pegar este código en .htaccess  

Página 1 / 2
 
Alceste
 Alceste
Noble Member

Hola,

Debo poner este código en el archivo .httaccess pero no sé donde pegarlo. Sé que es al principio pero veo texto de por medio y me entran dudas. Adjunto mi archivo httaccess por si podéis indicarme el lugar exacto.

Debo poner este fragmento para redirigir de urls sin sufijo html a urls con sufijo html

RewriteEngine On
RewriteCond %{REQUEST_URI} ! .html$
RewriteCond %{REQUEST_URI} ! /$
RewriteRule ^(.*)$ $1.html

Y tambien tengo que poner este para redirigir de urls sin www a urls con www

RewriteEngine On
RewriteCond %{HTTP_HOST} ^midominio.es
RewriteRule (.*) http://www.midominio.es/$1 [R=301,L]

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 13/03/2013 7:31 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alceste,

Puedes poner al inicio del archivo.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 13/03/2013 7:52 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola Jordi,
Disculpa mi ignorancia pero prefiero asegurarme.
El archivo empieza así:

##
# @version $Id: htaccess.txt 21064 2011-04-03 22:12:19Z dextercowley $
# @package Joomla
# @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##

¿Debo ponerlo antes de esto? Es decir, ¿sería correcto así? (Pongo en azul lo que voy a pegar)

RewriteEngine On
RewriteCond %{REQUEST_URI} ! .html$
RewriteCond %{REQUEST_URI} ! /$
RewriteRule ^(.*)$ $1.html

RewriteEngine On
RewriteCond %{HTTP_HOST} ^midominio.es
RewriteRule (.*) www.midominio.es/$1 [R=301,L]

##
# @version $Id: htaccess.txt 21064 2011-04-03 22:12:19Z dextercowley $
# @package Joomla
# @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##
ETC

ResponderCitar
Respondido : 13/03/2013 8:23 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alceste,

Correcto !!

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 13/03/2013 8:26 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Hola Jordi,

He pegado el código pero algo debe estar mal. Luego la página no se cargaba y arrojaba error el servidor. ¿Puede ser que la redirección de urls sin sufijo a urls con sufijo esté redireccionando también la página de inicio y esto cause el error?

Saludos

ResponderCitar
Respondido : 13/03/2013 9:16 am
Hicham
 Hicham
Miembro Admin

Hola Alceste,

Sustituye el código de la redirección con el siguiente:

RewriteCond %{REQUEST_URI} !.html$
RewriteCond %{REQUEST_URI} !/$
RewriteCond %{REQUEST_FILENAME} !index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) /$1.html [R,L]

Con esto no se redirecciona el index.php.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/03/2013 10:42 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola,
El redireccionamiento a html produce un problema con virtuemart. No se pueden añadir productos a la cesta, se queda colgado. Se soluciona quitando el redireccionamiento siguiente:

RewriteCond %{REQUEST_URI} !.html$
RewriteCond %{REQUEST_URI} !/$
RewriteCond %{REQUEST_FILENAME} !index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) /$1.html [R,L]

Este redireccionamiento era para evitar contenido duplicado, redirigiendo las pag sin sufijo html a páginas con sufijo html, pero excluyendo la página de inicio y otras en las que no fuera conveniente. Creo que el problema está en la parte del fragmento anterior en rojo que hace referencia a index.php ya que virtuemart lo utiliza.

http://www.midominio.es/ index.php?page=checkout.index&option=com_virtuemart&Itemid=103&redirected=1&Itemid=103

¿Se pordrían excluir de este direccionamiento las urls correspondientes a virtuemart? ¿O se podría limitar la parte de redireccionamiento que afecta a index.php solo a la página de inicio?

Saludos

ResponderCitar
Respondido : 14/03/2013 7:06 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alceste,

Se pueden excluir url's, revisa http://www.sitepoint.com/forums/showthread.php?750250-htaccess-redirect-all-urls-except-some-and-exclude-my-own-IP

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 14/03/2013 8:28 am

Cursos Gratuitos WordPress

Alceste
 Alceste
Noble Member

Hola Jordi,

Es que más que excluir unas urls concreta, creo que el tema está en la parte que redirige de php.index... Voy un poco perdido y prefiero esperar a que me podáis pasar un fragmento hecho, tal vez Hicham pueda modificarlo 🙂

Saludos

ResponderCitar
Respondido : 14/03/2013 8:40 am
Hicham
 Hicham
Miembro Admin

Hola Alceste,

Prueba el siguiente código :

RewriteCond %{REQUEST_URI} !.html$
RewriteCond %{REQUEST_URI} !/$
RewriteCond %{REQUEST_URI} !/index.php?option=com_virtuemart.*
RewriteCond %{REQUEST_FILENAME} !index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) /$1.html [R,L]

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2013 11:09 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola Hicham

Agradezco mucho tu ayuda.

He pegado el nuevo código pero sigue fallando cuando clico en "Añadir al carro" la página se queda colgada.

Lo he probado con esta url (sustituye "midominio" por el dominio real)

http://www. midominio.es/es/tienda/details/487/67/outlet/venecianas/venecianas.html

Saludos y gracias 🙂

ResponderCitar
Respondido : 14/03/2013 11:26 am
Hicham
 Hicham
Miembro Admin

Hola Alceste,

Pues a mi me funciona bien sin ningún tipo de error.

Envíanos una captura de pantalla de cómo lo ves desde tu navegador.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2013 11:45 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Hola,
Es que lo he quitado. Si pongo el código se queda colgado al "añadir al carro". No te puedo poner una captura de pantalla porque simplemente la página se queda en blanco mientras el navegador intentar cargar la url.

Contenido solo visible a usuarios registrados

Saludos y gracias por tu ayuda. Espero tus indicaciones 🙂

ResponderCitar
Respondido : 14/03/2013 12:21 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Personalmente no te recomiendo que realices un redireccionamiento de urls sin la extensión html a url con html, ya que te pueden provocar muchos problemas, y no solo en la tienda.

Tienes que tener en cuenta que en la web habrá varias páginas que no carguen con urls amigables y en todas ellas pueden surgir problemas. No bastaría con hacer un repaso a los distintos enlaces de la web ya que seguro que se quedarán cosas por revisar.

Un redireccionamiento contrario (urls con html a urls sin ella) es más viable porque no afectaría tanto al funcionamiento de la web.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2013 1:28 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alceste
 Alceste
Noble Member

Hola Pablo,

La idea era redireccionar de urls con sufijo html a urls sin sufijo html, como dices, pero el problema viene porqué google lo considera contenido duplicado y las urls sin sufijo no están todas indexadas, sinó solo una parte, mientras que las urls con sufijo están todas indexadas. A tenor de esto, en el foro de webmater me sugirieron en un post que redireccionara al revés.

Ahora tengo en la configuración global que active los sufijos (que es como lo he tenido des del inicio, por desgracia). Una opción seria desactivar los sufijos y esperar a que Google indexe todas las urls sin sufijo, (a pesar de que empeoraré temporalmente el tema del contenido duplicado y puedo perder indexación) y luego redireccionar de las urls con sufijo html a las urls sin sufijo, tal como me indicas, para darle una solución válida y definitiva. ¿Te parece una opción viable?

La verdad es que ya no sé por donde ir. No logro establecer la gravedad que puede conllevar el contenido duplicado ni el tiempo que tardaría en restablecerse el nivel de indexación. Aun así, veo que si no abordo el problema de una vez lo voy a ir arrastrando...

Sé que no me puedes dar una solución 100%, pero ¿qué harías en mi lugar? 🙂

Saludos

ResponderCitar
Respondido : 14/03/2013 2:12 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro