Avisos
Vaciar todo

Error con las marcas de phocamaps  

 
Enoc
 Enoc
Reputable Member

Hola!

Estoy usando el componente phocamaps en joomla 1.5.

Hasta ahora me ha funcionado perfectamente, pero el otro día nos dimos cuenta de que en el mapa han desaparcecido varias marcas. Quedan algunas pero otras ya no están y si creo una nueva no aparece en ese mapa. En cambio si esa misma marca que he creado se la asigno a otro mapa si que aparece en ese otro mapa. He mirado una y otra vez el mapa pero no veo nada raro.

El enlace para ver el mapa es este:

Contenido solo visible a usuarios registrados

Citar
Respondido : 01/10/2012 10:24 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Enoc,

Analizando con Firebug, el apartado de mapa, indica que hay varios errores.
No encuentra el fichero geoXML3.js
Contenido solo visible a usuarios registrados
Al igual que detecta un error de sintasix:

SyntaxError: invalid decrement operand
var phocaPoint96 = new google.maps.LatLng(43.146777, --1.526393);

Es extraño que tengan un doble signo negativo unas coordenadas

Saludos

ResponderCitar
Respondido : 01/10/2012 10:36 am

Cursos Gratuitos WordPress

Enoc
 Enoc
Reputable Member

Te parece que puede ser una solución actualizar el componente a la versión 1.1.2? ahora tengo la 1.1.1

En ese caso , ¿como lo debop hacer para no perder el mapa y las marcas que ya tengo creadas?

Un saludo

ResponderCitar
Respondido : 01/10/2012 10:52 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Puede que sea buena idea actualizar tu Phoca Maps a la nueva versión para comprobar si se soluciona el problema.

Antes de hacerlo, realiza una copia de seguridad de tu web. De esta forma, en el caso de que detectes problemas, podrás volver al estado anterior. Te recomiendo que hagas las copia con el Akeeba Backup.

ResponderCitar
Respondido : 01/10/2012 11:31 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enoc
 Enoc
Reputable Member

ok, pero al actualizar el componente perderé la info que ya tengo metida ahora: las marcas, y el mapa?

ResponderCitar
Respondido : 01/10/2012 11:38 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Todo esto depende del propio componente en sí. Normalmente nunca se pierden los datos con la actualización porque se suele reescribir el código y actualizar algún campo de la base de datos.

Pero precisamente por eso te digo lo de hacer la copia de seguridad, ya que podrías volver a un estado anterior en el caso de perder los datos.

ResponderCitar
Respondido : 01/10/2012 12:00 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enoc
 Enoc
Reputable Member

Ya lo he actualizado y lo ha hecho perfectamente, no he perdido ningún dato!
el problema continua... 😉 voy a probar a crear un nuevo mapa desde cero

ResponderCitar
Respondido : 01/10/2012 1:34 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Enoc.

Las coordenadas que ponéis en el mapa, ¿son correctas?:

(43.146777, --1.526393);

Tal como os indique anteriormente, no es normal el tener un doble signo de "resta" (--1.526393)

Saludos

ResponderCitar
Respondido : 01/10/2012 2:33 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enoc
 Enoc
Reputable Member

No encuentro en el mapa esas coordenadas, tenemos puestas otras:

42.81074823185795 | -1.644287109375

¿Dónde has visto esas?

ResponderCitar
Respondido : 01/10/2012 3:09 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola

He visualizado analizando con Firebug.

Saludos

ResponderCitar
Respondido : 01/10/2012 3:19 pm

Cursos Gratuitos WordPress

Enoc
 Enoc
Reputable Member

ok, creo que lo mejor va a ser crearlo de nuevo y asignar cada marca a ese nuevo mapa.

Un cosa en la captura que me has pasado el mapa no ha cargado, pero ¿si que te carga, no? me imagino que has hecho la captura antes de que cargue ¿es así?

Un saludo

ResponderCitar
Respondido : 01/10/2012 3:28 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Enoc

La captura enviada por Jordi sólo me aparece en el navegador Firefox, lo he probado con google chrome y safari y en estos navegadores si se muestra correctamente.

Prueba realizar nuevamente el mapa y verifica en firefox.

Saludos.

ResponderCitar
Respondido : 01/10/2012 11:06 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Enoc
 Enoc
Reputable Member

Ya he encontrado el error, era una tontería!

Jordi tenía razón, había una coordenada mal metida, pero no en el mapa sino en una de las marcas, tenía dos simbolos negativos, es decir --1.526393

Pasando las marcas al nuevoo mapa que había creado me he dado cuenta! sólo por ese error se dejaban de ver un monton de marcas y en firefox no se veia el mapa!!

Voy a informar a phocamaps de este bug

Gracias por todo!!

ResponderCitar
Respondido : 03/10/2012 10:58 am