Errores en la Página  

 
Manuel
 Manuel
Usuario eminente

Hola estimado equipo de webempresa. Soy cliente de ustedes, Manuel, con dominio http://www.risoterapiabarcelona.com/ y al acceder a mi web me aparece abajo y a la izquierda del navegador, el icono con el mensaje Listo pero con errores en la página. Me gustaría solventar dichos errores que por otro lado no sé si dicho mensaje de error se refiere a errores de tipo código http://validator.w3.org/ que sí tiene la web. ¿Qué puedo hacer?

Citar
Respondido : 17/06/2011 10:27 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Manuel,

Corregir errores de validación XHTML o CSS no es tarea compleja pero tampoco es cosa de cinco mintos pues intervienen bastantes factores si se desea conseguir una depuración 99,99%.

Tu validación actual W3C es:

- http://validator.w3.org/check?uri=risoterapiabarcelona.com&charset=%28detect+automatically%29&doctype=Inline&group=0

Llegados a este punto habría que analizar que entradas en tu código no validan bien y para que navegadores, pues presupongo que el problema principal lo estas teniendo con Internet Explorer, pero no se que versión usas, imagino que no es la 8 ni la 9.

A partir de aquí habria que saber que extensiones utilizas, que scripts cargas directa o indirectamente en la página, que llamadas externas hacen tus scripts para cargar código externo, ya que influirá en la validación y un etc., algo más largo de lo que podemos destacar en primera instancia.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/06/2011 2:38 pm

Cursos Gratuitos WordPress

David Noguera
 David Noguera
Miembro Admin

Hola Manuel,

si te fihas, en explorer cuando pinchas en ampliar información pinchando sobre el mensaje de error de la esquina inferior izquierda, señala que el error está en la línea 1. Fíjate que lo primero que aparece en el documento es un retorno de carro, elímina ese retorno de carro del fichero index.php de tu plantilla para que el primer caracter que lea el navegador sea el "<" del DOCTYPE y carga de nuevo para ver si aparece el mensaje de error.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/06/2011 9:47 pm
Manuel
 Manuel
Usuario eminente

Hola, ya veo el retorno de carro que debo quitar pero no sé cómo acceder al código de este index.php porque cuando accedo desde el cpanel, veo varios index.php, uno general otro de plantilla (templates) ,otro en administrator, pero no el que de verdad necesito modificar. ¿Me podéis decir cómo acceder al mismo? Gracias!

ResponderCitar
Respondido : 20/06/2011 11:35 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David Noguera
 David Noguera
Miembro Admin

Hola Manuel,

en tu caso estás usando la plantilla Kianyte, por tanto el fichero index.php de tu plantilla estará en la ubicación

/templates/ja_kyanite_ii/index.php

Haz una copia de seguridad del fichero antes por si necesitas volver a trás rápidamente en un momento dado.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/06/2011 12:27 pm
Manuel
 Manuel
Usuario eminente

Te garantizo que ya entro al archivo index.php que me dices siguiendo la ruta que me dices pero el código que yo veo no tiene la linea DOCTYPE, vamos que no aparece el mismo código que cuando vas a la home y le das a "ver código fuente". Tiene que ver con el tema de codificación us-ascii que quizás haya que elegir otro tipo de codificación?

Mira, esto es lo primero que me encuentro cuando entro al index.php:

<?php
/*
# ------------------------------------------------------------------------
# JA Kyanite II - Version 1.1 - Licence Owner JA42716
# ------------------------------------------------------------------------
# Copyright (C) 2004-2009 J.O.O.M Solutions Co., Ltd. All Rights Reserved.
# @license - Copyrighted Commercial Software
# Author: J.O.O.M Solutions Co., Ltd
# Websites: http://www.joomlart.com - http://www.joomlancers.com
# This file may not be redistributed in whole or significant part.
# ------------------------------------------------------------------------
*/

// no direct access
defined( '_JEXEC' ) or die( 'Restricted access' );
include_once (dirname(__FILE__).DS.'libs'.DS.'ja.template.helper.php');

y sin embargo, si voy a la home y digo "Ver código fuente2 entonces, en esas primeras 16 lineas me encuentro este otro código:

Risoterapia Barcelona

Como ves, nada que ver el código. Vamos que mis conocimientos no me dan para más. A ver si me echaís un cable.

ResponderCitar
Respondido : 20/06/2011 1:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

Hola Manuel,
OK sí, es verdad, no caí en que JoomlaArt trabaja con su propio framework. Es probable entonces que que el fichero que haya que modificar sea este:

/templates/ja_kyanite_ii/layouts/default.php

He revisado una plantilla kianyte que tengo a mano y aproximadamente en la línea 34 de este fichero hay un retorno de carro, bórralo y comprueba que ya no aparezca en la home de tu sitio.

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/06/2011 1:09 pm
Manuel
 Manuel
Usuario eminente

Hola David,
Ya he eliminado ese retorno de carro del coumento que me dices y si vas a la home "ver código fuente" ya no aparece pero el error del navegador, abajo a la izquierda, sigue apareciendo al acceder a mi web: http://www.risoterapiabarcelona.com/

¿Cuál debe ser el problema?

Una cosa, cuando edito la página que me has dicho templates/ja_kyanite_ii/layouts/default.php, resulta que el código no es exactamente el mismo que se ve cuando vas a la home y le das a "Ver código fuente". Aquí te pongo el código que se ve al intentar editar el archivo que me has dicho:

<html xmlns=" http://www.w3.org/1999/xhtml" xml:lang="language; ?>" lang="language; ?>">

loadBlock('head') ?>

<body id="bd" class="fsgetParam(JA_TOOL_FONT);?> browser();?>">

Aquí te pongo el código que se ve al "Ver código fuente en la home":

Risoterapia Barcelona

A ver si ves donde puede hayarse el error!

ResponderCitar
Respondido : 20/06/2011 1:28 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

Hola Manuel, lo que comentas de que el código no es igual, es normal, el código que ves es código PHP que se ejecuta en el servidor, pero lo que llega la página final no es PHP es solo HTML.

He visto que has envíado un nuevo mensaje en el foro tratando el mismo el tema, lo he eliminado ya que es un mensaje repetido, usemos siempre este hilo para este problema.

Gracias

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/06/2011 3:24 pm
Manuel
 Manuel
Usuario eminente

De acuerdo David, seguiremos en este hilo. Entonces, ¿Cuál puede ser el problema para que me de ese "error de página" al entrar a mi web http://www.risoterapiabarcelona.com/? Como he dicho, el problema que pone es "null" es nulo o no es un objeto. Linea 1 caracter 131.

ResponderCitar
Respondido : 20/06/2011 4:20 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Manuel

El error podría ser por un archivo javascript que se esta cargando, usualmente en IE siempre tendrás algún tipo de inconveniente.
Te sugiero desactivar algunos plugings de tu sitio web, como el jceutilities y el MM_functions

También puedes ver en el código fuente que archivos javascript estan cargando y revisarlo, claro esto es un trabajo más tedioso.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/06/2011 5:44 pm
Manuel
 Manuel
Usuario eminente

Gracias, los errores estaban en el código antiguo de los videos de youtube. Porblema solucionado. Un abrazo.

ResponderCitar
Respondido : 20/06/2011 10:38 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Por favor Iniciar Sesión o Registro