Favicon no se ve en IE  

 
Ivan
 Ivan
Usuario experto

Hola,

He sustituido el favicon de vuetro pack Joommla por uno propio. El caso es que en firefox casi nunca se ve la primera vez que entro a la web, pero cuando recargo sí que se ve. Sin embargo en Internet Explorer no se ve nunca. Visualizo el código y efectivamente, aparece la linea que es la que tiene que aparecer y el favicon está donde indica el href. A ver si me podéis indicar algo porque yo no le encuentro ninguna explicación, he estado buscando y mirando y no encuentro nada que aporte más información a parte de la que ya os comento.

Un saludo y gracias,

Iván

Citar
Respondido : 06/06/2011 12:10 pm
David Noguera
 David Noguera
Miembro Admin

Hola Ivan,

esto suele pasar por la caché.. Prueba accediendo desde otro ordenador diferente donde nunca hayas accedido a la web y comprueba si visualizas bien el favicon. Si lo visualizas bien es un tema e caché.. tendrás que vaciar la caché de tu navegador...

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/06/2011 1:31 pm

Cursos Gratuitos WordPress

Ivan
 Ivan
Usuario experto

Hola David,

El Favicon no se visualiza en Internet Explorer desde ningún ordenador (lhe borrado la caché de los navegadores en mi ordenador y loo he probado desde otro como tu has sugerido y nada) y como te digo con firefox la primera vez que accedes a la wev no se visualiza, pero si recargas ya sí que se visualiza. Es muy extraño y por eso ando un poco perdido. A ver si me podéis dar alguna idea o alguna orientación.

Un saludo y gracias de nuevo,

Iván

ResponderCitar
Respondido : 06/06/2011 4:32 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola Ivan

El ícono debe tener extensión .ico, algunas navegadores aceptan el .png , pero IE tiene problemas.
Puedes enviar la url de tu sitio web para verificar lo que comentas.

Ayudaría también ver cual es la versión final del ícon a través de una captura de pantalla

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/06/2011 5:04 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ivan
 Ivan
Usuario experto

Hola Jhon,

El favicon está en extensión .ico (te lo envio como fichero adjunto). La url es www.dehesaboyal.es y la versión de internet explorer con la que he probado es la 8, aunque yo siempre utilizo firefox.

Un saludo,

Iván

ResponderCitar
Respondido : 07/06/2011 7:44 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Iván,

¿ Visualizas el favicon en la plantilla original http://templates.joomlart.com/ja_larix/ ?

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 07/06/2011 12:17 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ivan
 Ivan
Usuario experto

Hola Jordi,

En la url que me pones no visualizo favicon, entre otras cosas, parece que no tiene favicon ya que he visualizado el código fuente de la página y no aparece el tag por lo que creo que no tiene.

Además yo he instalado el joomla que vosotros ofrecéis al contratar un hosting joomla, por lo que lo único que he hecho es cambiar el favicon de webempresa por el de mi cliente. Así que supongo que en IE no se ve porque es la versión 8, aunque no puedo comprar con el joomla "limpio" recien instalado porque no utilizo este explorador, pero lo del firefox no me lo explico, el por qué unas veces se ve y otras nos (nunca se ve cuando se accede la primera vez), es la versión 4 de firefox. ¿Puede que sea por las versiones de los navegadores que estoy utilizando? aunque me parece extraño, porque una cosa tan simple como un favicon...

Gracias y un saludo,

Iván

ResponderCitar
Respondido : 07/06/2011 4:20 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola Ivan

Un posible problema puede ser por que la dimensión de tu favicon es mayor a 16x16px, vemos que la referencia es correcta pero con un tamaño mayor a 16px

Tal como se muestra en el siguiente link

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/06/2011 8:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ivan
 Ivan
Usuario experto

Efectivamente Jhon, el problema con IE8 ya está solucionado, redimensionando el favicon a 16x16. En firefox me sigue pasando lo mismo, la primera vez que entro no sale, pero cuando recargo o navego por la web sí que sale, puede que sea por la versión 4 de firefox, pero el "gran problema" que eran con IE8 ya está solucionado.

Muchas gracias,

Iván

ResponderCitar
Respondido : 08/06/2011 1:28 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ivan,

Por curiosidad ¿en que carpetas de tu Joomla! has copiado el favicon.ico?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/06/2011 2:34 am

Cursos Gratuitos WordPress

Ivan
 Ivan
Usuario experto

Hola,

El favicon lo tengo en la raíz, ya que ahí estaba el que venía por defecto de webempresa y el tag shortcut icon indica el /favicon.ico cuando se genera el código de la web.

Un saludo,

Iván

ResponderCitar
Respondido : 09/06/2011 3:48 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola Ivan

Los favicon suelen trabajar a nivel de template, prueba moviendo el favicon a la carpeta de template que estas usando.
Por ejemplo : /templates/tu_template_actual/favicon.ico

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/06/2011 3:53 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ivan
 Ivan
Usuario experto

Hola Jhon,

Pues verás, he hehcho lo que comentas, y parece que funciona perfectamente, al menos de momento, inlcuso el tag link href="/templates/ja_larix/favicon.ico" rel="shortcut icon" type="image/x-icon" ya me apunta al favicon dentro del template y no al que estab en la raiz.

Por si alguien lee esto, resumo lo que he hecho.

  1. Redimensionar le favicon de 32x32 a 16x16
  2. Colocar el fichero favicon.ico en la raiz de la web y en la raiz del template que estemos utilizando

Muchas gracias a todos por ayudarme. Creo que podemos dar el tema por cerrado.

Un saludo,
Iván

ResponderCitar
Respondido : 13/06/2011 10:16 am
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola Ivan

Que bueno que solucionaste tu problema.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/06/2011 1:54 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Por favor Iniciar Sesión o Registro