Avisos
Vaciar todo

Formulario contacto english no funciona  

 
Juan
 Juan
Usuario experto

Hola,
Cuando la página está traducida al inglés (Joomfish), en el apartado "Contact" del menú principal aparece el siguiente mensaje [No form id or name provided!] .
Url: Contenido solo visible a usuarios registrados

Gracias y un saludo.

Citar
Respondido : 27/11/2011 11:19 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Juan José Alagón Baldellou,

Si utilizas el Formulario de Contacto nativo de Joomla!, cuando se muestre en otro idioma este debe aparecer ya que no le afcetan las cadenas pues las tomará del correspondiente archivo en-GB.

Otra cosa diferente es si utilizas BreezingForms para el formulario de contacto, entonces debes revisar en Joom!Fish si modificaste el nombre del formulario pensando que era una cadena y por eso te da error.

Saludos

ResponderCitar
Respondido : 28/11/2011 12:05 am

Cursos Gratuitos WordPress

Juan
 Juan
Usuario experto

Hola,
para la traducción he cambiado la etiqueta name, en la opción que dá joomfish para traducir.
Al hacer este cambio en la página web traducida no se encuentra el formulario.
Envío imágen para más detalles.

Gracias y un saludo.

ResponderCitar
Respondido : 08/12/2011 6:05 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Debes haber cambiado el nombre del formulario, en la parte inferior de la pantalla de traducción (no se ve en tu captura), No debes traducir el nombre del formulario, envía una captura de lo que traduces.

Saludos.

ResponderCitar
Respondido : 08/12/2011 3:38 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Juan
 Juan
Usuario experto

Hola,
envío captura. Sólo he cambiando Etiqueta name y Etiqueta Menú Alias.
Gracias por vuestra ayuda.
Contenido solo visible a usuarios registrados

ResponderCitar
Respondido : 08/12/2011 4:56 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Esa es una traducción del módulo Breezing forms? , por que parece ser una traducción del elemento de menú

La traducción del formulario es independiente a la traducción del menú. Revisa el siguiente hilo de discusión:
https://www.webempresa.com/foro/6-Joomla-15/652-Traducir-Breezing-forms.html

Saludos.

ResponderCitar
Respondido : 08/12/2011 8:32 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Juan
 Juan
Usuario experto

Hola,
Gracias. El hilo me ha servido para traducir el formulario.
Funciona correcto menos cuando traduzco el menú.
Cuando tengo el apartado de "Contacto" del menú sin traducir, va perfectamente, el formulario me aparece en el idioma traducido (inglés). No obstante cuando publico la traducción del menú, traduciendo la palabra "Contacto" por "Contact", no me aparece el formulario traducido sino la expresión [No form id or name provided!] . No localiza el formulario.

Esta es la captura del menú traducido:
Contenido solo visible a usuarios registrados

Podríais ayudarme a encontrar una solución?

Gracias y un saludo.

ResponderCitar
Respondido : 08/12/2011 10:40 pm
Juan
 Juan
Usuario experto

Hola de nuevo.
He seguido los pasos indicados en este hilo https://www.webempresa.com/foro/18-Pack-Empresa/28117-Problemas-con-pagina-de-contacto.html#28117
- En la administración de Joomla vete en el menú superior a Menús->Menú principal.
- En el listado de menús que se muestran pulsa en el último con nombre Contacto.
- Pulsa el botón Cambiar tipo que se muestra en el centro.
- En el listado Selecciona tipo de ítem del menú selecciona la opción Breezinforms.
- En la parte derecha de parámetros pon el valor contacto en el parámetro Form name y pulsar Guardar.

Pero sigue sin funcionar.

Gracias y un saludo.

ResponderCitar
Respondido : 08/12/2011 11:00 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

Hola Juan José,

en esta URL no puedo ver nada:

www.e-tecnalsolutions.com/index.php?option=com_breezingforms&Itemid=69&lang=en

Por otro lado, si lo que pasa es que cuando estás en ingles no aparece nada, supongo que el problema es que traduces el nombre del formulario, que se llama contacto, y le pones "contact". Esa cadenas no has de traducirla, pro que es el nombre del formulario, y si la traduces, BreezingForms no sabe encontrar el formulario "Contact", por que no existe.. lo que has de hacer es traducir el formulario en sí, si no lo has traducido ya mírate este vídeo:

http://www.youtube.com/watch?v=6Kqx2NPPwSQ

Saludos

ResponderCitar
Respondido : 09/12/2011 3:47 pm
Juan
 Juan
Usuario experto

Hola,
El vídeo que me indicas me lo seguí para traducir el formulario.
Lo tengo traducido y funciona perfectamente siempre y cuando no tenga también traducido el menú principal.
En las imágenes que he adjuntado verás las dos opciones (con menú sin traducir encuentra el formulario traducido al inglés, pero con el menú traducido no).
Contenido solo visible a usuarios registrados
Cuando el apartdo "Contacto" del menú principal lo traduzco a "Contact" es cuando no encuentra el formulario.
El problema es que si la página está traducida al inglés me gustaría que el menú principal también lo estuviera.

Gracias y un saludo.

ResponderCitar
Respondido : 11/12/2011 4:11 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Juan

Elimina el item de menú y crealo de nuevo, en Joomfish no debes cambiar la referencia al formulario para ningún idioma.

Puedes enviar capturas de pantalla para ver la configuración tanto del item de menú como de la traducción del item de menú en joomfish

Saludos.

ResponderCitar
Respondido : 11/12/2011 4:17 pm
Juan
 Juan
Usuario experto

Hola Jhon, muchas gracias.
Ha funcionado a la perfección.
He creando de nuevo el item contacto en el menu principal y posteriormente lo he traducido con Joomfish.

Saludos!

ResponderCitar
Respondido : 11/12/2011 5:24 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación