Avisos
Vaciar todo

Galería de imágenes con popups  

 
Marí­a
 Marí­a
Honorable Member

Hola, para mostrar fotos, uso el componente Media que venía con la plantilla Teline II

Para usarlo con fotos distintas lo que hago es copiar el que venía instalado y sustituir las rutas de las imágenes.

1. Pero tengo un comportamiento incorrecto. Se ve por ejemplo, en el sitio www.cmarosa.org, en el menú Vida colegial>Imagen de la semana.
Si pincho en la primera foto no se abre en una imagen emergente sino que se abre en una nueva ventana. En cambio si cambio de pestaña, y me voy a la pestaña con nombre Excursiones, pincho la úlitma foto y todo bien, vuelvo a la pestaña Imagen de la semana, pincho en la foto que antes se abría en una nueva página y ahora no, ahora funciona correctamente abriéndose en un popup.
El código es:

2. Por otro lado, veo que siempre tengo que publicar dos pestañas por lo menos, con una sólo, por ejemplo Imagen de la semana, el contenido no se muestra.... Esto es correcto?

Gracias,
María

Este debate ha sido modificado el hace 3 meses por antonio
Citar
Respondido : 12/10/2012 5:12 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola María

He probado lo que comentas pero he visto que se comporta correctamente.
Lo he probado en firefox, safari y google chrome.

En que navegador estas visualizando?

Realiza la prueba en otro navegador y verifica si te ocurre lo mismo.

Saludos.

ResponderCitar
Respondido : 12/10/2012 8:39 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Marí­a
 Marí­a
Honorable Member

Acabo de probar con Chrome y efectivametne va bien.
No funciona con el Explorer... y para mí resulta un problema, porque analizando el tráfico del sitio, el 51% de las visitas usan Explorer, le sigue muy por detrás chrome con 20%... y el resto un porcentaje bastante bajo...

Cómo podría resolverlo en el Explorer?

Gracias,

María

ResponderCitar
Respondido : 12/10/2012 9:21 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola María,

Que un sitio web se vea mal en Internet Explorer, u otros navegadores, puede ser debido a varios factores y no es un problema exclusivo de Joomla!, ya que sucede a todos los CMS del mercado:

Generalmente la plantilla es posible que no este preparada para verse correctamente en las diferentes versiones (En IE6 puede ser porque esa plantilla no es soportada u ofrece compatibilidad con ese navegador, en IE7 porque la plantilla no esta bien configurada, y con IE8 a veces sucede que la plantilla no este configurada bien para ese navegador, ya que fue realizada con anterioridad a la aparición del mismo). Hay que modificar la plantilla, y establecer hacks para cada navegador en las CSS.

Puede ser que la plantilla esté bien configurada, pero los contenidos y módulos insertados no estén bien configurados, o se dejen etiquetas de código abiertas, o imágenes demasiado grandes y se produzcan desbordamientos en la plantilla, hay que tener en cuenta que IE en algunos aspectos es mucho más sensible que Firefox.

Los distintos navegadores pueden llegar a interpretar de forma distinta los atributos CSS que se estén aplicando a una plantilla. De ahí que puedan existir diferencias.

Por norma general, siempre se intenta usar código HTML y CSS que sean compatibles con todos los navegadores, o al menos la mayor parte de los mismos.

El trabajo a realizar para arreglar los problemas con IE consistiría en ir analizando que partes de la web son las que provocan problemas con IE para realizar las modificaciones oportunas. En Webempresa.com no ofrecemos soporte sobre la versión Internet Explorer 6.

Puedes optar por instalar o habilitar (en nuestros packs ya se incluye dicho plugin instalado) "IE Compatibility" y ajustarlo a la emulación que necesites corregir o adaptarlo.

- IE Compatibility: http://extensions.joomla.org/extensions/style-a-design/browsers-a-web-standards/7623 [Enlace despublicado actualmente en el JED]
- http://downloads.ijoomla.com/joomla-downloads/style-a-design/browsers-a-web-standards/ie-compatibility

Saludos

ResponderCitar
Respondido : 12/10/2012 10:54 pm

Cursos Gratuitos WordPress

Marí­a
 Marí­a
Honorable Member

Hola, ninguno de los dos enlaces que has puesto funciona... conoces alguno que sí esté activo?
Gracias,
María

ResponderCitar
Respondido : 13/10/2012 10:35 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola María,

Al tratarse de una extensión cada vez más en desuso porque las nuevas versiones de IE cumplen "un poco mejor" con los estándares (aun muy lejos) web, es por lo que es dificil localizar dicha extensión y el autor parece ser que ya no la sigue manteniendo.

Te la facilitamos a continuación.

Saludos

ResponderCitar
Respondido : 13/10/2012 10:55 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Marí­a
 Marí­a
Honorable Member

Hola,

la verdad es que ya tenía ese plugin instalado y activado, funcionando para la opción Emultae I7

Lo desinstalé y volví a subir el paquete que recomiendas, pero el comportamiento sigue siendo el misimo....

Alguna otra idea?

Un saludo,
María

ResponderCitar
Respondido : 13/10/2012 11:15 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola María,

En todos los navegadores que he probado el funcionamiento es correcto, se muestra en una ventana modal ampliada la imagen:

En IE se abre en una ventana nueva. En ningún navegador he observado que se produzcan errores de javascript y en IE no he podido evaluarlo correctamente.

Otra solución seria sustituir el actual módulo JA Highslider por un mosaico de imágenes creado con Phoca Gallery.

- https://www.webempresa.com/blog/crear-un-mosaico-de-imagenes-para-galerias-de-phoca-gallery.html?tmpl=component&print=1

Saludos

ResponderCitar
Respondido : 13/10/2012 11:43 am

wpdoctor-revisa-la-salud-de-tu-wordpress