Avisos
Vaciar todo

Instalar 2 Joomla diferentes en el mismo dominio  

 
jose
 jose
Usuario eminente

Hola y Feliz 2012 a todos.

Quiero instalar una versión de prueba de mi sitio joomla, con lo que he copiado todos los archivos de la web original al directorio "Pruebas", he creado una nueva base de datos y importado todos datos y he modificado el archivo de configuración, todo funciona perfectamente.

El problema es que la web instalada en el directorio "pruebas" lee el archivo de configuración del directorio raiz en lugar del directorio "pruebas", con lo que ambas web trabajan con la misma base de datos y no cada una con la suya.

He probado a borrar el archivo de configuración del directorio "pruebas" y la web funciona perfectamente.

En cambio la parte de administrador si que funciona con la base de datos correcta.

¿ Cómo puedo cambiar esto ?

Saludos Y muchas gracias.

Citar
Respondido : 02/01/2012 4:04 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Jose

La mejor manera de mover tu Joomla! a "cualquier" otro lugar "remoto o local" es mediante el uso de la extensión "gratuita" llamada Akeeba Backup, la cual te permite realizar una copia completa de tu sitio y base de datos en formato .jpa (formato propietario de la extensión y el más recomendado) que en un solo archivo te permite llevarte tu instalación a donde quieras o mantenerlo como archivo de seguridad.

Te adjuntamos unos vídeos para poder copiar y restaurar un Joomla! de un Hosting a otro o en el mismo Hosting, ya sea local o remoto:

Como copiar tu Joomla con Akeeba Backup o JoomlaPack: https://www.webempresa.com/videos/akeeba_copiadeseguridad/akeeba_copiadeseguridad.html

Como restaurar tu Joomla con Akeeba Backup o JoomlaPack: https://www.webempresa.com/videos/akeeba_restauracion/akeeba_restauracion.html

En el caso que pongas una contraseña al realizar un backup apúntala para luego introducirla en la restauración.

Saludos

ResponderCitar
Respondido : 02/01/2012 4:07 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

jose
 jose
Usuario eminente

He hecho la copia con el Akeeba Backup en local y luego la he restaurado en vuestro hosting y sucede exáctamente lo mismo.

La parte de administración sí me leer la nueva base de datos con los datos que contiene, pero la parte pública no se modifica y no aparecen los cambios realizados en la parte privada.

Incluso borrando el archivo configuration.php la parte pública sigue funcionando sin problemas.

Comentar que estoy accediendo a través de la URL temporal que dais, en este caso

http://viajesma-cp35.webjoomla.es/pruebas
-> funciona perfectamente aun sin el configuration.php

En cambio el

http://viajesma-cp35.webjoomla.es/pruebas/administrator/

- > no funciona como era de esperar.

No sé qué hago mal...

¿ Me podéis ayudar ?

Saludos

ResponderCitar
Respondido : 02/01/2012 8:07 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola José

Lo que comentas en tu primer post no es posible, el front-end y back-end siempre usan la misma base de datos. A veces puede parecerte diferente si tienes algún componente SEO trabajando configurado con la url de tu sitio web, esto también en algunos casos pasa en virtuemart en donde configuras URLs del sitio (url y secure url).

Asegúrate ademas en el archivo configuration.php que tengas la variable $live_site vacía

Saludos.

ResponderCitar
Respondido : 02/01/2012 9:05 pm

Cursos Gratuitos WordPress

jose
 jose
Usuario eminente

Ya esta solucionado, era un problema de redirección por iframe.
Por eso la página principal no funcionaba y la parte de administrador si.

Muchas gracias.

ResponderCitar
Respondido : 02/01/2012 10:12 pm