Item de menu vacio  

 
NeroCaes
 NeroCaes
Estimable Member

Hola, tengo la siguiente duda:

Estoy trabajando en una página que tiene un menú con sus respectivos submenus. Quisiera saber como puedo poner el item de menú vacio de forma que me respete los parametros avanzados que uso en el resto del menú.

Ahora mismo estoy usando el tipo separador, pero el problema es que con este tipo, no me aparecen los parametros avanzados que me permitan configurar este item.

No se si me he explicado. Espero haberme sabido explicar.

Saludos y gracias.

Citar
Respondido : 26/01/2011 6:55 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Francis,

No te he entendido muy bien que digamos, pero si lo que quieres es un elemento de menú que no enlace con nada pero que sirva para dividir elementos de un submenú, una opción es crear enlaces que apunten a #.

En el Gestor de Menús generas un vínculo a "url externa" y como link le pones "#" (sin comillas) y listo.

Si no te referías a esto, perdona pero tendrás que ser mas gráfico. 🙂

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/01/2011 7:14 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

NeroCaes
 NeroCaes
Estimable Member

Imaginaba que no me había explicado bien.

Te detallo de forma más específica.

Estoy haciendo esta web www.detectoresgarrett.com

En la página principal pincha sobre hooby, y en la siguiente página, sobre Pulse Aquí de cualquiera de los dos equipos.
Verás que al entrar en la siguiente página, arriba te aparecen parametros del artículo y no aparece el menú. Esto parece que es debido a que entras en una sección determinada del menú, donde el item principal del menú que está activo, no tiene configurados los parametros del componente. Como para el item de menu vacio uso el tipo separado, no me da opciones para configurar el componente de menú y como se verán las páginas. Si por ejemplo asigno a ese item de menu ver un artículo, entonces si me deja configurar el componete, y ya si se vé el menu, pero no quiero que estos elementos de menú sean seleccionables.

Espero que me hayas entendido.

Muchas gracias.
Saludos.

ResponderCitar
Respondido : 26/01/2011 7:37 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Francis

Cuando creas tu enlace te sugiero agregar la siguiente variable : Itemid=2, de esta manera mantienes el menú seleccionado, por ejemplo:

http://www.detectoresgarrett.com/index.php?option=com_content&view=article&id=18&Itemid=2

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/01/2011 12:07 am

wpdoctor-revisa-la-salud-de-tu-wordpress

NeroCaes
 NeroCaes
Estimable Member

Hola:

Gracias por la respuesta, pero esto no soluciona el problema ya que el enlace estaba así. Sin embargo si le cambio el 2 por 46 que es la ruta del enlace, entonces si que trabaja de forma correcta. Así que lo he modificado. No obstante me queda la duda del motivo por el que no trabaja. Creo que podría tratarse de un bug.

Saludos.

ResponderCitar
Respondido : 27/01/2011 1:38 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Francis

Tu url estaba sin el último parámetro, y no salía el menú
http://www.detectoresgarrett.com/index.php?option=com_content&view=article&id=18

y la que te envié, si permite que salga el menú
http://www.detectoresgarrett.com/index.php?option=com_content&view=article&id=18&Itemid=2

El bug tiene que ver con tu template ya que al no poner el último parámetro debería al menos salir el menú sin ningún item de menú activo.
Agregando el último parámetro logras activar un item de menú (item de menú con id =2) y tu template lo identifica como elemento seleccionado.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/01/2011 2:28 am

Cursos Gratuitos WordPress

NeroCaes
 NeroCaes
Estimable Member

Efectivamente, así era. Ahora ya todo funciona correctamente.

Me encanta este foro.

Muchisimas gracias.
Saludos.
Francis.

ResponderCitar
Respondido : 27/01/2011 3:36 am

Por favor Iniciar Sesión o Registro