Personalizar estilo tamaño fuente en Remository  

 
Pedro
 Pedro
Usuario experto

Hola soy novato en Joomla, y os ruego que me disculpéis si algo de lo que pregunto es obvio o ya está contestado (he buscado previamente en el foro y no lo encuentro).
Deseo cambiar varias cosas de mi pagina de repositorio.

Los tamaños de las letra con que se crean las carpetas ( son descomunales).
Igualmente los del resto de elementos, por ejemplo los tamaños de letra de los nombres de archivo.....

¿Se puede eliminar o modificar el título principal? En mi caso "Descargas del IES Cornelio Balbo".

Supongo que habra que modificar en una hoja css estos parámetros, pero he estado "trasteando" en alguna y no acabo de dar con la tecla.
Te agradecería que me dijeras en cual esta dicha configuración, y si me dices al menos donde tengo que cambiar al tamaño de los textos me harías un gran favor.
En este enlace ves como está ahora mismo.

http://iescorneliobalbo.com/joomla/index.php?option=com_remository&Itemid=102

Si necesitas algún dato más dímelo. Muchas gracias de antemano.

Citar
Respondido : 01/10/2011 8:06 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Pedro,

Los titulos te aparecen tan grandes porque utiliza la etiqueta

que provoca que sean de semejente tamaño.

Este cambio, previa copia de seguridad, puedes realizarlo en el archivo siguiente del componente:

- /components/com_remository/v-classes/remositoryFileListHTML.php

Debes localizar en la línea 184 lo siguiente:

			
				

repository->RemositoryBasicFunctionURL($func, $container->id)}"> $icon $name

Si observas pinta un h3 para mostrar entre otros el título. Puedes cambiarlo a h4 por ejemplo, que es de menor tamaño.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar

Respondido : 01/10/2011 10:22 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pedro
 Pedro
Usuario experto

Gracias por tu respuesta.
Efectivamente localizo lo que me dices pero no en la linea 184, si no en la 54. En concreto es esto:

LIST_HEADING;

}

protected function displayContainer ($container, $func) {
$icon = $container->icon ? $this->repository->RemositoryImageURL('folder_icons/'.$container->icon) : $this->repository->RemositoryImageURL('folder_icons/folder_yellow.gif');
$name = $this->show($container->name);
return <<<SHOW_CONTAINER

repository->RemositoryBasicFunctionURL($func, $container->id)}">
$icon
$name

{$this->displayFolderCounts($container)}

{$this->displayDescription($container)}
{$this->displayAllSubcontainers($container, $func)}

Cambio h3 por h4 y no ocurre nada.
Algo se me escapa.
Gracias de nuevo

ResponderCitar
Respondido : 02/10/2011 12:22 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Pedro

Actualmente veo que el listado sale con etiquetas h1
http://iescorneliobalbo.com/joomla/index.php?option=com_remository&Itemid=102

Supongo que has logrado cambiar el archivo, pero tal como te comentó gnumax debes cambiarlo por h4 h5 o h6, o simplemente por

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/10/2011 3:31 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Pedro,

Efectivamente has hecho el cambio, pero veo que has aplicado h1 (mayor tamaño) en vez de h4 o h5 (menor tamaño), no se si es lo que querías hacer o ha sido un error tuyo.

Nivel jerárquico de encabezados en etiquetas de HTML:

  • h1: encabezado de primer nivel
  • h2: encabezado de segundo nivel
  • h3: encabezado de tercer nivel
  • h4: encabezado de cuarto nivel
  • h5: encabezado de quinto nivel
  • h6: encabezado de sexto nivel

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/10/2011 8:16 pm
Pedro
 Pedro
Usuario experto

Gracias por vuestras respuestas:
Es más un olvido que un error.
Probé lo que me dijisteis, y puse h4, pero ante que no veía cambios aparentemente puse h1 (para "notar" el cambio), y todo siguió igual (se me olvidó cambiarlo anoche).
Ahora tiene h6 (el tamaño más pequeño), pero sigue igual. Comprobadlo, lo he dejado en h6 a posta.
Gracias

ResponderCitar
Respondido : 03/10/2011 6:32 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Pedro,

http://iescorneliobalbo.com/joomla/index.php?option=com_remository&Itemid=102 efectivamente no se nota el cambio, la etiqueta h4 queda sin efecto por las CSS de los enlaces: Biologia, Prueba y Secretaría, que muestran a un tamaño enorme.

Ello es debido a que al ser enlaces, cogen el estilo de archivos de la plantilla template.css (línea 46):

h1, h2, h3, h4, h5, h6, h1 a, h2 a, h3 a, h4 a, h5 a, h6 a, h1 a:link, h2 a:link, h3 a:link, h4 a:link, h5 a:link, h6 a:link, h1 a:visited, h2 a:visited, h3 a:visited, h4 a:visited, h5 a:visited, h6 a:visited, h1 a:hover, h2 a:hover, h3 a:hover, h4 a:hover, h5 a:hover, h6 a:hover {
    font-family: Arial,Helvetica,Sans-Serif;
    font-size: 32px;
}

Tienes que cambiar el tamaño del font-size.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 03/10/2011 9:08 am
Pedro
 Pedro
Usuario experto

Muchas gracias a todos.
Por fin se ha solucionado.
Sin vuestra ayuda hubiera sido imposible.
Efectivamente tenía razón Jordi he cambiado a 16px y se quitó esa letra tan grande

ResponderCitar
Respondido : 03/10/2011 11:20 pm

Cursos Gratuitos WordPress

Por favor Iniciar Sesión o Registro