¿Por qué al editar JCE en modo gráfico se fastidia el código introducido?  

 
Luis Miguel
 Luis Miguel
Honorable Member

Tengo introducido código para mirar el tiempo y las olas, el código está cogido de una pagina web, lo introduzco en modo código y al guardar funciona perfectamente, pero al volver por cualquier motivo al articulo sale en modo gráfico y al guardar deja de funcionar el código.

¿Hay alguna manera de que esto no pase?

Me imagino que de esto se habrá escrito algo pero he intentado buscar y no encuentro nada.

URL del sitio: http://www.beta.predatorsurf.com/index.php?option=com_content&view=article&id=52&Itemid=60

Citar
Respondido : 04/06/2012 11:15 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Luis Miguel,

Puede ser por varios motivos, que en la configuración del editor JCE elimine algunas etiquetas de código (efectúa limpieza) o que sea un tema de la condiguracion de Joomla!, que efectúa limpieza en los artículos de etiquetas que considera prohibidas.

Para descartar un problema de Joomla!, edita el artículo sin editor (pues cambiar en tu usuario o en la configuración global).

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 04/06/2012 11:30 am

Cursos Gratuitos WordPress

Luis Miguel
 Luis Miguel
Honorable Member

He quitado el editor desde configuración global y funciona bien. Pero claro quiero mantener el editor ya que en programación estoy bastante pez

ResponderCitar
Respondido : 04/06/2012 11:40 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Luis Miguel,

Desconozco que versión del editor JCE estás usando, al igual que el código exacto que deseas utilizar.

Revisa en en componentes --> JCE Administration --> Profiles --> editar "default" --> pestaña "editor parameters" --> options --> tienes opciones que por defecto están en no, según el código que estes usando, suponiendo javascript, Allow Javascript cambiar de no a yes.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 04/06/2012 12:03 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Miguel
 Luis Miguel
Honorable Member

Fallo mio al no poner las versiones:

Joomla 1.5.26

JCE 2.0.16

Se ha solucionado como me has comentado en el post anterior.

Gracias

ResponderCitar
Respondido : 04/06/2012 12:24 pm

Por favor Iniciar Sesión o Registro