¿Porque desaparece el archivo .htaccess?  

 
jommla
 jommla
Usuario activo

Estimados, tal como dice el título el archivo .htaccess desaparece literalmente del host.

Les explico que no son todos los .htaccess los que me dan problemas, sino uno especifico que pongo en una ubicación especifica.

Tengo instalado el componente attachments vers 2.02 del 29.05.2010 del autor Jonathan M. Cameron.
Como saben, este componente me permite agregar archivos adjuntos a los artículos.

Previendo que pudiera encontrarse un bug en el componente y para que nadie me ejecute archivos de extensiones peligrosas en el directorio donde se suben los adjuntos: /public_html/attachments, fue que subí un .htaccess a ese directorio.

El asunto es, que el .htaccess funciona bien por un día, pero luego que entro al foro y bajo o subo algún adjunto, el archivo .htaccess desaparece del host!

Cuando digo que desaparece es como que lo hubiesen borrado (puedo ver los archivos ocultos, por si me sugieren eso.
Hablé con la gente de bluehost que es donde tengo alojada la web y me dijeron que no es problema de ellos ese fallo, que haga revisar toda la web con un programador!

A alguien le ha pasado algo similar? tienen alguna sugerencia?

Uso joomla 1.5.22.

Les dejo en adjunto htaccess en archivo de texto porque no se me permite subir original, por si acaso lo quieren ver. 

This topic was modified hace 6 meses por antonio
Citar
Respondido : 08/03/2011 1:07 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola naalmada,

Por lo que comentas y sin adelantarme a otras valoraciones, diría que es cosa de algún ID o Firewall que tenga habilitado el Hosting y que no permita la ejecución de ciertos scripts y que si los detecta, bien sea en archivos .php o en archivos ocultos .htaccess como es el caso, directamente los elimina, pero como digo es un poco aventurar.

Habria que saber que medidas de seguridad implementa el Hosting contra scripts y ficheros que contengan funciones o llamadas que ellos consideren que son peligrosas y tengan filtradas en aquellos scripts del servidor encargados de velar por la seguridad.

¿Tienes log de lo que sucede en tu Hosting, de los errores? algo que pueda dar una pista de que sucede. ¿Cuando accedes a tu carpeta correspondiente con el administrador de archivos del cPanel, Plesk o lo que uses, ves el archivo?.

Cualquier dato que aportes adicional podría ayudar a entender este particular caso.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/03/2011 1:36 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

jommla
 jommla
Usuario activo

Gracias gnumax por tu pronta respuesta.

Los error logs que tengo y que se repiten varias veces son:

MAIN error_log:
[Mon Mar 07 17:51:31 2011] [error] [client 113.97.73.117] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://t.touhong.com/
07 17:51:49 2011] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.

PHP error_log:
[02-Mar-2011 14:54:15] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home3/iudconli/public_html/libraries/tcpdf/tcpdf.php on line 6268

Te comento que tengo subido otro .htaccess en /public_html y funciona sin problemas y no se borra.
No se si puede ayudar en algo eso.

ResponderCitar
Respondido : 08/03/2011 1:45 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola joomla,

MAIN error_log:
[Mon Mar 07 17:51:31 2011] [error] [client 113.97.73.117] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: t.touhong.com/

Mira a ver si en el archivo .htaccess tiene realizada alguna redirección a la url http://t.touhong.com/ o un mal redireccionamiento.

PHP error_log:
[02-Mar-2011 14:54:15] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home3/iudconli/public_html/libraries/tcpdf/tcpdf.php on line 6268

Si tienes acceso al archivo php.ini, o si tu Hosting te permite tener uno personalizado en tu Hosting, revisa dicha configuración, edita tu php.ini y busca lo siguiente:

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;
max_execution_time = 30     ; Maximum execution time of each script, in seconds

Y aumentalo a 40 o 60 por ejemplo.

Si tu no tienes acceso al php.ini (suele ser lo habitual) tendrás que pedirle a tu Hosting que te aumente esa variable.

¿Es un Hosting gratuito?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/03/2011 1:51 am

Cursos Gratuitos WordPress

jommla
 jommla
Usuario activo

Es un host pago (bluehost).

Busqué a través del Cpanel pero no pude encontrar el archivo php.ini.

Será cuestión que le envie una nota al soporte técnico para que me aumente el max_execution_time.

Con respecto a si dentro del .htaccess tengo alguna redirección a alguna página, es negativo.
En el primer post envié en adjunto el archivo, pero te lo copio acá para no hacerte perder tiempo:

RewriteEngine on
RewriteRule !^(.*).(doc|pdf|txt|jpg|jpeg|pps|png|ppt|gif)$ accessdenied.gif [NC]
# For security reasons, Option all cannot be overridden.
#Options All -Indexes
Options ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch -Indexes

Que me dices de este otro error?
07 17:51:49 2011] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.

ResponderCitar
Respondido : 08/03/2011 2:02 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola jommla,

No se exactamente que objetivo tienes al implementar la linea:

- Options ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch -Indexes

¿Tu Hosting te permite ejecutar scripts CGI?

Una forma de saberlo es creandote un archivo llamado prueba.cgi e insertando el siguiente texto:

#!/usr/bin/perl
print "Content-Type: text/htmlnn";
print "CGI funciona en este servidor";

Luego lo subes a tu Hosting, a la carpeta /public_html/cgi y le das permisos 644 o 755 si con los anteriores no se ejecuta y despues lo llamas desde el navegador como:

http://www.tuweb.com/cgi-bin/prueba.cgi

Y nos cuentas el resultado.

Sobre los temas de htaccess, echale una ojeada al artículo que plucicamos hace poco en el Blog de Webempresa quizás te oriente en el tema de redirecciones y otras cosas utiles.

- https://www.webempresa.com/blog/codigos-utiles-htaccess-para-wordpress.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/03/2011 2:24 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

jommla
 jommla
Usuario activo

Hola.

Con respecto al CGI, no me muestra la página de ejemplo.

Me da error(HTTP 500 Error interno del servidor) significa que el sitio web al que está conectado tiene un problema con el servidor que impide que se muestre la página web.

El .htaccess que se borra del host, no lo hice yo, me lo hizo otro webmaster.

Con respecto al artículo sobre el .htaccess de web empresa lo veo muy completo, lo voy a estudiar.

Muchas gracias gnumax por tu amabilidad y por compartir tus conocimientos.

Seguimos en contacto.

ResponderCitar
Respondido : 08/03/2011 4:08 pm

Por favor Iniciar Sesión o Registro