Problema con Joomla  

Página 1 / 2
 
Alejandro
 Alejandro
Usuario activo

Buenos días,

les escribo porque ya no se que hacer, les cuento.

Tengo la web www.meteovalverde.es

En esta web hay una serie de imágenes tipo .jpg que son datos de la estación meteorológica que se suben al servidor cada dos minutos, los pueden ver en la misma pagina de inicio. Bueno el asunto es que desde hace unos días, los usuarios habituales y comprobado también con mis ordenadores me sucede lo siguiente.

Entras por primera vez a la web desde cualquier navegador. mozilla, explorer y safarai entre otros, y ves el jpg último que vistes la última vez que entras en la web, es decir, si entraste ayer la última vez por la tarde pues pilla la jpg de ayer por la tarde.

Este problema ha ocurrido desde hace unos días, no he instalado ninguna extensión en joomla, y no encuentro solución al problema. webempresa a visto como los ficheros están subiendo bien sin problemas, pero me hablan de algún problema en joomla y estoy perdido.

Una vez entras en la web y te percatas que los datos que deben aparecer en el jpg no están actualizados en cualquiera de los navegadores, pinchas en recargar y es entonces cuando actualiza la información del jpg.

Muchas Gracias, y les agradecería vuestra ayuda...

Citar
Respondido : 30/03/2011 7:33 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alejandro,

Se esta atendiendo esta consulta por ticket (TTQ-919348) de soporte técnico, vemos que un técnico te respondió 29 Mar 2011 2:49 PM, y en el mismo no hemos tenido respuesta por tu parte desde la fecha indicada.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 30/03/2011 2:55 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alejandro
 Alejandro
Usuario activo

Buenas tardes,

En primer lugar darle las gracias por la atención prestada ante el problema en mi web, en cuanto a la consulta planteada fui respondido muy bien y con los datos que dispone webempresa,asi mismo me indicaron que pudiera ser un problema específico con joomla ya que se podía ver como se estaban subiendo los ficheros adecuadamente etc.

Ya que usted publica datos de soporte, quisiera acalarle la contestación de este tíket que usted publica y en donde yo no interpreto que estan esperando por mi contestación.

Email enviado por ustedes;
responder a soporteLink a post de foro, solo visible a usuarios registrados.com
para XXXXXXXXXXX
fecha 29 de marzo de 2011 13:49
asunto [WEBEMPRESA #TTQ-919348]: Ayuda
Mensaje importante principalmente por los integrantes de la conversación

Apreciado cliente,

en al ruta que nos ha indicado, podemos ver el siguiente listado de imágenes, donde aparecen la fecha de creación de cada fichero:

total 1068
drwxr-xr-x 2 meteoval meteoval 4096 Jan 16 22:18 ./
drwxr-xr-x 18 meteoval meteoval 20480 Mar 23 21:19 ../
-rw-r--r-- 1 meteoval meteoval 13532 Apr 22 2010 icon01.jpg
-rw-r--r-- 1 meteoval meteoval 9590 Apr 22 2010 icon.jpg
-rw-r--r-- 1 meteoval meteoval 135788 Mar 29 14:55 vws000.jpg
-rw-r--r-- 1 meteoval meteoval 31480 Mar 29 14:56 vws002.jpg
-rw-r--r-- 1 meteoval meteoval 30539 Mar 29 14:56 vws005.jpg
-rw-r--r-- 1 meteoval meteoval 30496 Mar 29 14:56 vws007.jpg
-rw-r--r-- 1 meteoval meteoval 31347 Mar 29 14:56 vws019.jpg
-rw-r--r-- 1 meteoval meteoval 31616 Mar 29 14:54 vws021.jpg
-rw-r--r-- 1 meteoval meteoval 30592 Jun 17 2010 vws023.jpg
-rw-r--r-- 1 meteoval meteoval 28740 Apr 28 2010 vws053.jpg
-rw-r--r-- 1 meteoval meteoval 3776 Apr 22 2010 vws1006.jpg
-rw-r--r-- 1 meteoval meteoval 21083 Apr 22 2010 vws1020.jpg
-rw-r--r-- 1 meteoval meteoval 5579 Apr 22 2010 vws1021.jpg
-rw-r--r-- 1 meteoval meteoval 3219 Apr 22 2010 vws1026.jpg
-rw-r--r-- 1 meteoval meteoval 3293 Apr 22 2010 vws1027.jpg
-rw-r--r-- 1 meteoval meteoval 4357 Apr 22 2010 vws1030.jpg
-rw-r--r-- 1 meteoval meteoval 4274 Apr 22 2010 vws1031.jpg
-rw-r--r-- 1 meteoval meteoval 4065 Apr 22 2010 vws1032.jpg
-rw-r--r-- 1 meteoval meteoval 4130 Apr 22 2010 vws1033.jpg
-rw-r--r-- 1 meteoval meteoval 3868 Apr 22 2010 vws1034.jpg
-rw-r--r-- 1 meteoval meteoval 3730 Apr 22 2010 vws1035.jpg
-rw-r--r-- 1 meteoval meteoval 3883 Apr 22 2010 vws1036.jpg
-rw-r--r-- 1 meteoval meteoval 4240 Apr 22 2010 vws1037.jpg
-rw-r--r-- 1 meteoval meteoval 4053 Apr 22 2010 vws1038.jpg
-rw-r--r-- 1 meteoval meteoval 44814 Dec 8 11:56 vws1177.jpg
-rw-r--r-- 1 meteoval meteoval 14730 Mar 29 14:54 vws1626.jpg
-rw-r--r-- 1 meteoval meteoval 11137 Mar 29 14:55 vws1738.jpg
-rw-r--r-- 1 meteoval meteoval 13030 Mar 29 14:55 vws1739.jpg
-rw-r--r-- 1 meteoval meteoval 13059 Mar 29 14:55 vws1740.jpg
-rw-r--r-- 1 meteoval meteoval 13998 Mar 29 14:55 vws1746.jpg
-rw-r--r-- 1 meteoval meteoval 54871 Apr 22 2010 vws736.jpg
-rw-r--r-- 1 meteoval meteoval 59498 Apr 22 2010 vws738.jpg
-rw-r--r-- 1 meteoval meteoval 49155 Apr 22 2010 vws740.jpg
-rw-r--r-- 1 meteoval meteoval 46831 Apr 22 2010 vws742.jpg
-rw-r--r-- 1 meteoval meteoval 50045 Apr 22 2010 vws754.jpg
-rw-r--r-- 1 meteoval meteoval 39573 Apr 22 2010 vws758.jpg
-rw-r--r-- 1 meteoval meteoval 46391 Apr 22 2010 vws856.jpg
-rw-r--r-- 1 meteoval meteoval 36043 Apr 22 2010 vws858.jpg
-rw-r--r-- 1 meteoval meteoval 9426 Jun 16 2010 vws907.jpg
-rw-r--r-- 1 meteoval meteoval 9379 Jun 10 2010 vws908.jpg
-rw-r--r-- 1 meteoval meteoval 3857 Apr 22 2010 vws910.jpg

Mirando los logs del servidor FTP, vemos que se están subiendo las imágenes correctamente:

Mar 29 15:00:49 cp16 pure-ftpd: (meteoval@) [NOTICE] /home/meteoval//public_html/images/stories/estacion/vws021.jpg uploaded (31558 bytes, 44.16KB/sec)
Mar 29 15:00:58 cp16 pure-ftpd: (meteoval@) [NOTICE] /home/meteoval//public_html/images/stories/estacion/vws1626.jpg uploaded (14730 bytes, 32.39KB/sec)
Mar 29 15:01:07 cp16 pure-ftpd: (meteoval@) [NOTICE] /home/meteoval//public_html/images/stories/estacion/vws1738.jpg uploaded (11137 bytes, 27.61KB/sec)
Mar 29 15:01:16 cp16 pure-ftpd: (meteoval@) [NOTICE] /home/meteoval//public_html/images/stories/estacion/vws1739.jpg uploaded (13030 bytes, 30.36KB/sec)
Mar 29 15:01:25 cp16 pure-ftpd: (meteoval@ [NOTICE] /home/meteoval//public_html/images/stories/estacion/vws1740.jpg uploaded (13059 bytes, 30.35KB/sec)
Mar 29 15:01:35 cp16 pure-ftpd: (meteoval@) [NOTICE] /home/meteoval//public_html/images/stories/estacion/vws1746.jpg uploaded (13998 bytes, 31.38KB/sec)

No vemos que la IP XXXXXXXX este siendo bloqueada por el firewall.

Por lo que el proceso de subida de las imágenes parece que se está realizando con normalidad, verifique la configuración de su Joomla y las extensiones que está empleando ya que podría ser que no estubieran bien configurados.

Saludos,
Departamento técnico
www.webempresa.com
Servicios Profesionales Joomla

Por lo anterior, entendí que buscara el origen del problema en joomla o extensiones, he procedido a escribir en este soporte, ahora bien, no entiendo el contexto en el cual usted me plantea su respuesta.

Por lo que le pregunto a usted ¿ puedo preguntar lo que quiera de joomla o mi web en este foro sin faltar el respeto? independiente de que haya consultado a través de ticket.

Finalmente decirle que como cliente de webempresa no me ha sentado muy bien la publicación de su respuesta, si bien le agradecería que las llamadas de atención, en mi caso, se efectuen o bien retirando mi tema, o bien, le rogaría lo haga por privado ya que dispone de los datos de contacto, ya que mi pregunta en este foro se debe únicamente por intentar solucionar un problema de mi web y en donde el soporte técnico me había indicado que podría ser de joomla y en definitiva como no tengo contratado el soporte joomla, me pareció el canal más adecuado en este momento.

Muchas Gracias y espero su respuesta pública sobre mi pregunta planteada en el antepenúltimo parrafo.

ResponderCitar
Respondido : 30/03/2011 3:54 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Alejandro,

No le quepa la menor duda de que estamos aquí para ayudarle en la medida de nuestras posibilidades y estoy plenamente convencido de que nuestro compañero tan solo le ha querido transmitir una información acerca del estado del problema que nos comenta.

Siempre que lo desee puede plantear sus dudas aquí en el Foro y si considera que son relaciones que deben ser gestionadas internamente o por soporte, sientase libre de hacer las correspondientes peticiones de soporte como ha hecho hasta ahora, estaremos encantado de atenderle.

Sobre la cuestión que plantea, seria interesante que aportase datos concreto de cual es la extensión que debe leer las imágenes que sube por FTP para que podamos conocerla mejor y aportar más luz al problema.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/03/2011 8:55 pm

Cursos Gratuitos WordPress

David Noguera
 David Noguera
Miembro Admin

Hola Alejandro!!

Por supuesto que puedes usar el foro para realizar cualquier tipo de pregunta!! creo que ha sido un malentendido, verás, seguramente mi compañero se refería a que esperaba que contestaras por ticket, pero como bien dices no dispones de tiempo de mantenimiento y el foro es un medio ideal para realizar tu consulta...

Solamente indicar que si el ticket no se responde se cierra automáticamente al cabo del tiempo, pero nada más..

Bueno, después de aclarar esto, te lanzo mis preguntas para ver si podemos resolver tu problema 🙂

Cargando la imagen que nos indicas en la captura y usando la extensión TamperData de Firefox, veo la siguiente información de la imagen:

Status=OK - 200
Date=Wed, 30 Mar 2011 20:32:28 GMT
Content-Type=image/jpeg
Content-Length=135236
Last-Modified=Wed, 30 Mar 2011 20:31:50 GMT
Connection=keep-alive
Expires=Thu, 31 Mar 2011 20:32:28 GMT
Cache-Control=max-age=86400
Accept-Ranges=bytes

Por lo que se ve, el max-age está a 86400 segundos, es decir, 24 horas.. por lo que el navegador intenta no cambiar la imagen hasta que hayan pasado 24 horas... esto es algo que hacen los navegadores y el servidor para mejorar la velocidad de navegación y es completamente normal

Para solucionar esto puedes tratar de hacer lo siguiente, añade esto al fichero .htaccess raíz de tu web:

ExpiresByType image/jpg A90
ExpiresByType image/jpeg A90

Cuando lo hayas puesto avísanos para que podamos verificar de nuevio las cabeceras de la imagen.

Saludos!!

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 30/03/2011 9:33 pm
Alejandro
 Alejandro
Usuario activo

Buenas noches,

En primer lugar agradecerle la respuesta a la duda planteada anteriormente.

Indicar que no soy informático sino un simple aficionado que ha publicado una web sobre mi hobby, le cuento al respecto del problema.

En la web, en la misma página principal que corresponde a la imagen que he colgado en el inicio de este Tema, son archivos JPG que son subidos por el FTP directamente al servidor cada 2 minutos, además en la propia web lestá puesto una recarga de datos a los 4 minutos.

No he instalado ninguna extensión en estos días, tampoco ninguna extensión se encarga de este aspecto, por eso más aún estoy ciego en este problema.

Desde que tengo la web con ustedes, ya hace algunos meses, no me había dado problema, este problema aparece hace solo desde hace unos días, y el problema acontece con todos los navegadores, al menos en los míos y en de algunos usuarios de mi web.

El problema acontece cuando usted entra en la web por primera vez, verá que le da los datos como aparece en la imagen actualizados, si usted espera cinco minutos y cierra su navegador y vuelve a abrir el mismo, verá que no se actualiza este JPG ( que antes si lo hacía), si embargo, si usted una vez entra en la web, le da a recargar verá que si que le modifica el jpg.

Esto lo he probado con usuarios con navegadores, mozilla, explorer y safari.

Por todo lo anterior, y como decía anteriormente no encuentro solución al problema.

Muchas gracias de antemano por su interés.

ResponderCitar
Respondido : 30/03/2011 9:39 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alejandro
 Alejandro
Usuario activo

Buenas de nuevo,

Tras la lectura de su información, he procedido a añadir el texto que usted me indicó en el htacces.

He probado con mis navegadores y persiste el problema.

Muchas gracias por su colaboración.

ResponderCitar
Respondido : 30/03/2011 9:47 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alejandro,

Parece un problema de cache, accede a la administración --> configuración global --> pestaña sistema --> Configuración de la caché --> indicar "no".

Realizado ese cambio, procede a limpiar la cache del navegador, también. Y luego realiza una navegación normal, y nos comentas...

Disculpa mi primera respuesta, no era una crítica, como puedes comprobar estamos para ayudarte. Sencillamente quise indicar que estábamos esperando una respuesta por tu parte en el ticket de soporte.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 31/03/2011 7:36 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

Hola Alejandro,

hemos configurado tu vhost en el servidor para que tenga un tiempo de expiración en las imágenes de 1 minuto.
Por favor comprueba ahora que no te pasa lo que ocurría antes. Recarga antes de hacer la prueba la página y después vuelve a hacer lo que hacías que provocaba el error, de esta forma ya te estará cojiendo las nuevas cabeceras en al imagen..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 31/03/2011 3:37 pm
Alejandro
 Alejandro
Usuario activo

Buenas tardes,
Perdonen el restraso.

Como pueden ver en la imagen persiste el problema después de hacer lo que me comentaron y lo que me han comentado ustedes tambien, a continuación les pongo una imagen de hace unos minutos en donde después de encender el ordenador esto que ven pasa con los tres navegadores siempre que entras por primera vez, y posteriormente si recargas pues actualiza las imágenes.

Lo que no entiendo es por qué cuando entras sirmpe coje la última imagen cache de la última vez que visitastes la web y sin embargo al recargar se actualiza bien, y encima en cualquier navegador.

gracias por vuestra ayuda

ResponderCitar
Respondido : 02/04/2011 2:08 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Alejandro,

¿Con que navegadores ha verificado que la imagen cambia o no cambia?

Hemos probado y en Firefox las imágenes van cambiando y el contador de la hora es real, marca la hora del momento en que nos encontramos y actualiza las imágenes.

Saludos

Nota: Es posible que la captura tarde un poquito en cargar, es una animación.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/04/2011 6:50 pm
Alejandro
 Alejandro
Usuario activo

Buenas,

No se trata de esa imagen, esa funciona correctamente, se tratan de las JPG que dan datos de la estación meteorológica.

Los navegadores utilizados son Explorer, Mozilla y Safari.

Y en todos pasa lo mismo.

ResponderCitar
Respondido : 02/04/2011 7:02 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Alejandro,

¿Podrías poner aquí el link concreto que muestra esas imágenes?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/04/2011 7:14 pm
Alejandro
 Alejandro
Usuario activo

www.meteovalverde.es en la misma pagina principal en el cuerpo del artículo veras estas imágenes que aparecen con los datos del tiempo actual en Valverde.

esos datos son actualizados cada dos minutos.

ResponderCitar
Respondido : 02/04/2011 7:16 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Alejandro,

En el siguiente artículo de nuestro Blog de Webempresa verś un artículo donde explicamos una posible solución al problema de refresco de tus imágenes.

- https://www.webempresa.com/blog/refrescar-imagenes-en-articulos-y-modulos-con-image-refresh-plugin.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/04/2011 9:54 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro