Quitar cuadro de bievenido a la portada de joomla [Tema resuelto]  

 
David
 David
Usuario experto

Hola,

estoy teniendo problemas con el cuadro de bienvenido de la portada (flecha negra, adjunto imagen1), me explico:
anteriormente lo quité de la siguiente manera, comentando las líneas de mi template (554-->564 aprox.) para que este desapareciese. La cuestión es , que cuando accedo a alguno de los items , ya sea de mi menú de categorías virtuemart, o del menú principal(donde estamos....etc...), me desaparece el cuadro de atrás también(flecha roja, adjunto imagen2), y no es como yo lo quiero, sino que me gustaría que el cuadro permaneciese. Quiero comentar también, que gracias a jmarreros creé una nueva posición 'superior' para que mi frontslide de la principal no tuviese recuadro por detrás. Este va en la parte superior(flecha verde, adjunto imagen1), os comento esto, por si tuviese algo que ver.

GRACIAS, un saludo

Citar
Respondido : 10/03/2011 8:04 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola guitarcentermd,

¿Recuerdas que en otro hilo pediste que te explicásemos como quitar el fondo "rectángulo redondeado" de la posición vm-fp? pues el resultado más probable es que el rectángulo redondeado inferior en determinados elementos de tu plantilla se cargue arriba al no encontrar el que cargaba vm-fp por estar comentado o eliminado.

Revisa como están los estilos para ese módulo en tu hoja de estilos, pero creo que el problema principal ahora esta producido por comentar lo relativo al rectángulo superior que te molestaba para mostrar el modulo de imágenes.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/03/2011 2:25 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Usuario experto

Hola gnumax,
sigo sin solucionar mi problema, he probado poniendo mi módulo de imágenes en la posición "ja-slider", me sale el recuadro redondeado por detrás. Pero al quitar el recuadro de "Bienvenido", que trae joomla por defecto (que no está en ninguna posición en concreto), me sigue desapareciendo el cuadro cuando accedo a alguno de los items , ya sea de mi menú de categorías virtuemart, o del menú principal(donde estamos....etc...).
Por tanto creo que si no utilizo en este momento la posición que yo cree "superior", ni tampoco "vm-fp", ¿puede ser que no sea solo fallo al haber creado mi posición? ó ¿puede ser que yo quite el recuadro de "Bienvenido" de forma erronea? Como ya dije en el post anterior, lo hago comentando las líneas (554-564 aprox.) de mi template.css ¿esto es correcto? o hay alguna otra forma de quitar ese recuadro o incluso reutilizarle para poner los productos destacados de mi web.

Gracias, un saludo.

ResponderCitar
Respondido : 14/03/2011 4:07 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola guitarcentermd

Tal como comentas a partir de las líneas 554 de template.css se encuentran las clases que definen los bordes, no deberías modificar estas ya que son genéricas y definen los bordes del content.

ja-contentwrapper, ja-contentwrap , etc.

por que tomaste la decisión de quitar esas clases?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2011 6:44 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David
 David
Usuario experto

Hola jmarreros,
la decisión como tu dices, puede ser la equivocada ya que fui probando con la ayuda del Firebug y esta es la única "solución" que encontre, aunque no es la adecuada (ya que como tu bien dices, esto afecta de forma genérica). ¿Que tendría que hacer para que al quitar el recuadro de "Bienvenido a la portada", esto no afecte al resto?

Gracias, un saludo.

ResponderCitar
Respondido : 14/03/2011 6:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola guitarcentermd

La frase de "Bienvenidos a la portada" se configura en el menú de inicio=>parametros del sistema=>mostrar titulo de la página , le pones que NO.

Pruébalo y nos comentas.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2011 7:56 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Usuario experto

Hola,
ya he probado eso, y si me quita el "Bienvenidos a la portada" (las letras), pero el recuadro con eso no me basta, y me sigue apareciendo, que en este caso es lo que pretendo. ¿Hay alguna otra solución posible?

Gracias.

ResponderCitar
Respondido : 14/03/2011 8:01 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola guitarcentermd

El template ja_zeolite en su configuración no tiene para elegir si mostrar o no el componente en el Inicio, por lo que tienes que modificar el archivo index.php del template, poniendo una condicional para que no cargue el component en el home

Revisa este tutorial
http://www.monitojoomla.com/tips/varios-joomla/2-tip-saber-si-estoy-en-la-pagina-home-dentro-de-un-template

En tu template tienes que poner la condicional a partir de la línea 184 aprox en donde empieza a mostrarse el content hasta la 195, ( template ja_zeolite en el archivo index.php ).

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2011 8:11 pm

Cursos Gratuitos WordPress

David
 David
Usuario experto

Hola jmarreros,

no entiendo muy bién lo que me quieres decir.
En mi index.php, a partir de la 185 es lo siguiente:

Es ahí donde pretendes que meta algo?, o es en el templete.css?
Si fuese en el index.php, me puedes hechar una mano ?, que agrego??
Un saludo

ResponderCitar
Respondido : 14/03/2011 8:49 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Esto se define arriba, al inicio entre etiquetas php, tal como se explica en el artículo

global $Itemid; //para determinar si estoy en la página principal

Luego esta condicional envuelve lo que se mostrará o no en el home, en este caso he cambiado la condicional para q se muestre en todos menos en el itemid=1 es decir en el home.




PD. La etiqueta PHP esta mal colocada en este post para q se pueda mostrar, debe ir sin espacio "< ?"

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/03/2011 9:21 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Usuario experto

Muchisimas gracias jmarreros,

esto es precisamente lo que quería, era un problema que tengo desde hace tiempo y no conseguía solucionarlo.

Un saludo.

ResponderCitar
Respondido : 14/03/2011 9:52 pm

Por favor Iniciar Sesión o Registro