Avisos
Vaciar todo

Redirecciones en joomfish  

 
david
 david
Reputable Member

Hola amigos de webempresa.

Este tema va relacionado con otro hilo que tengo abierto, pero he pensado que al tratarse de algo distinto, debia colocarlo en otro hilo.

El problema es el siguiente:

Tengo la wen hecha en catalan y utilizo joomfish en las traducciones.

Me pasa que al pasar de un idioma al otro, joomfish se esta haciendo el loco y me esta mostrando paginas que no estan relacionadas.

Por ejemplo, entro en esta url:
http://paucostafoundation.org/ca/qui-som.html,

y al pasarla a ingles, me aparece esta pagina:
http://paucostafoundation.org/en/who-we-are.html

Hasta aqui todo correcto.

El problema esta que al querer volver atras, joomfish solo cambia el apendice del lenguaje manteniendo la coletilla, y me manda a esta pagina:

http://paucostafoundation.org/ca/who-we-are.html

Esto de entrada es un desastre, puesto que deberia volver a http://paucostafoundation.org/ca/qui-som.html dejando de mantener la coletilla en ingles.

Eso hace que aparezca la ventana de error 404 y que la navegacion este incompleta y sea un desastre.

Como puedo solucionar esto?

Muchas gracias!

Citar
Respondido : 26/04/2011 12:08 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola david,

¿Que estas utilizando para mejorar el SEO, ademas de lo propio de Configuración Global?

Saludos

ResponderCitar
Respondido : 26/04/2011 12:28 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

david
 david
Reputable Member

Hola Gnumax.

Para el seo no estoy usando nada aparte de lo propio de joomla y el renombre de htacces.

NO hay nada mas instalado en el admin que de lugar a mejoras de seo.

Gracias

ResponderCitar
Respondido : 26/04/2011 12:33 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola david,

Al final ando medio perdido con tus post 😛 parecen todos iguales estos últimos.

¿Este quedó solucionado?, ¿persiste el problema?.

Saludos

ResponderCitar
Respondido : 26/04/2011 1:32 am

wpdoctor-revisa-la-salud-de-tu-wordpress

david
 david
Reputable Member

LO siento gnumax.

Si que es cierto que a veces hasta ni yo me aclaro, y como escribo para que no se me olvide, parece que hable solo a veces.

Lo siento.
blush:

Voy a expresarme mejor:

EL problema que especificaba antes en este hilo, aun persiste. No alcanzo a comprender porque se comporta el componente asi.

"Me pasa que al pasar de un idioma al otro, joomfish se esta haciendo el loco y me esta mostrando paginas que no estan relacionadas.

Por ejemplo, entro en esta url:
paucostafoundation.org/ca/qui-som.html,

y al pasarla a ingles, me aparece esta pagina:
paucostafoundation.org/en/who-we-are.html

Hasta aqui todo correcto.

El problema esta que al querer volver atras apretando de nuevo la bandera en catalan, joomfish solo cambia el apendice del lenguaje manteniendo la coletilla, y me manda a esta pagina:

paucostafoundation.org/ca/who-we-are.html

Esto de entrada es un desastre, puesto que deberia volver a paucostafoundation.org/ca/qui-som.html dejando de mantener la coletilla en ingles, ya que la pagina que muestra evidentemente no existe y por eso manda el mensaje de error.

Eso hace que aparezca la ventana de error 404 y que la navegacion este incompleta y sea un desastre."

Este todavia persiste.

Y de hecho, aun hay mas:

El catalan, que es el lenguaje origen, en el editor de menus funciona todo bien. Al clicar una pestaña principal, esta lleva a un contenido concreto.

Esto de hecho no pasa igual con la pestaña en ingles (o castellano) puesto que la pestaña en cuestion, en ingles, manda a un lugar totalmente distinto, pese a que en el editor de menus el menu esta configurado correctamente.

Puede ser una incompatibilidad de joomfish?

Seria recomendable desinstalar el componente, terminar de generar contenido, y una vez hecho, instalarlo de nuevo y empezar a traducir?

Me da a mi que se esta haciendo la picha un lio y por eso esta generando tantos errores.

A ver que se os ocurre...

Gracias!!!!!!!:woohoo: :woohoo: :woohoo: :woohoo:

ResponderCitar
Respondido : 26/04/2011 1:21 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola david,

Lo primero es que no podemos comprobar ya que el sitio web lo tienes en mantenimiento (fuera de linea). Y el sitio web no está en nuestros servidores.

Saludos,

ResponderCitar
Respondido : 26/04/2011 2:25 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

david
 david
Reputable Member

Hola jordi.

El cliente prefiere que sea asi hasta que decida abrirla. Ya me hubiera gustado dejarla abierta para poder comentarlo.

Por lo que hace referencia a los servidores, no lo esta. Esta alojada en otro servidor fuera de webempresa.

Hay algun requerimiento especial para el uso del foro para consultas de webs que no esten alojadas en webempresa?

Yo se que no se hace servicio tecnico de webs alojadas fuera, pero las consultas del foro tambien se rigen por ese principio?

Me gustaria saberlo, pues aun estoy a tiempo de pedir que me devuelvan el importe del hosting que tengo contratado en webempresa y que tanto me costo decidir a contratar, si no se puede hacer uso del foro.

Y siento decirlo en este tono, pero ya me parecio una cacicada dejar cerrado el foro a los no clientes si encima siendo cliente no se puede hacer uso de el.

Pero pensandolo bien quiza este no sea el mejor modo de discutir esto. Me parece excelente la tarea que haceis y no voy a caer en la trampa de escribir un comentario soez y desproporciando, mas aun cuando todo hasta ahora ha sido bueno, menos el comentario.

Simplemente respondeme a esa cuestion, porfavor.

ResponderCitar
Respondido : 26/04/2011 9:20 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola david

El comentario de que el sitio web no esta en nuestros servidores simplemente nos dificulta un poco las respuestas ya que por ejemplo no habría manera de saber las configuraciones en el servidor que son requeridas por algunas extensiones.

No hay problema en hacer consultas a través del foro de sitios web que no se encuentren alojados en webempresa, pero tal como te comenté anteriormente simplemente dificultan la respuesta.

Con respecto a tu consulta puedes probar quitando el sufijo .html, desde parámetos SEO => Agregar el sufijo a las URL

Saludos.

ResponderCitar
Respondido : 26/04/2011 9:47 pm

Cursos Gratuitos WordPress

david
 david
Reputable Member

Gracias Jhon.

Respecto al problema, he suprimido los sufijos y sigo teniendolo.

No entiendo porque aparece, y es mas, el componente me esta provocando varios errores, no solo este.

Las traducciones provocan errores en el 404 y ademas algunos menus se muestran distintos en catalan, castellano o ingles.

se puede acceder a ver el problema mediante usuario "test" y passw "test".

en la pestaña quien somos /qui som se ve ademas el segundo problema, que al clicar el menu lleva a un recurso distinto aun estando en el mismo menu. (en catalan se muestra un articulo y en ingles un listado, cuando deberia ser el articulo).

Adjunto captura de config de joomfish.

Muchisimas gracias!!!!

ResponderCitar
Respondido : 26/04/2011 10:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola david

No he podido conectarme con los datos enviados.
El usuario tiene que tener privilegios de administrador para ingresar.

Creo que seria mejor que quites la restricción de manera temporal

Por otro lado con respecto al problema puedes probar si tienes el mismo problema al quitar las url amigables

Saludos.

ResponderCitar
Respondido : 26/04/2011 11:13 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

david
 david
Reputable Member

Gracias jhon.

Con un poco de tiempo, mañana me centrare en intentar solucionar esto de las url.

Muchas gracias!

Esta semana la web debe quedar abierta, y por tanto, sera mas facil comprovar in situ el comportamiento erratico del componente.

Gracias de nuevo.

ResponderCitar
Respondido : 27/04/2011 11:30 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola david,

Con respecto a JoomFish, lo ideal es que la extensión esté instalada antes de comenzar a generar contenidos, aunque al final tampoco es demasiado problema.

Puedes probar a desinstalarla completamente, eso incluye el modulo y plugins y una vez concluyas los contenidos la instalas en "su última versión estable" habilitas los plugins y el módulo, vacías caché, etc., y pruebas nuevamente el proceso de verificar como cargan las páginas.

Trabajo hace bastante tiempo con sitios multidioma con JoomFish y hasta ahora no me ha pasado lo que comentas, ni con urls amigables, ni sin ellas, salvo que como te consulte anteriormente, estés utilizando otras herramientas SEO que dificulten el comportamiento.

Saludos 🙂

ResponderCitar
Respondido : 28/04/2011 12:46 am

wpdoctor-revisa-la-salud-de-tu-wordpress

david
 david
Reputable Member

Hola Gnumax i jhon.

Acabo de descubrir por erro porque pasaba lo anterior que os comentaba.

Inicialmente la web se empezo a generar en catalan, y el cliente decidio que el idioma base fuera el ingles (todavia no sabia lo del plugin de teccion de idioma).

Que paso? pues que del paso de las banderas esp a eng y viceversa, todo fantastico. Pero al intentar ir de la eng a la cat, como el idioma por defecto era el ingles (y supongo que toma la primera de las banderas como lenguaje predeterminado), añadia el apendice /ca/ y la coletilla en ingles, puesto que la pagina, el lenguaje por defecto era el ingles.

Ahora dejando el catalan de inicio, he hecho las pruebas èrinentes y celebro decir que el problema esta solucionado.

Referente al otro tema que comentaba, pues lo solucione borrando las traducciones y haciendolas de nuevo, puesto habia algunas de ellas creadas con anterioridad, se modificaron algunos modulos, y lamentablemente las traducciones (la estructura) no se actualizan.

Si inicialmente tienes una pestaña que te manda a un articulo y haces la traduccion, si le cambias el atributio a la pestaña, este no cambioa en la traduccion. Debes borrarla y hacerla de nuevo para que no quede "enganchado" el recurso y no te vyuelvas majareta al intentar cambiarlo.

Ha sido duro pero al final ha salido.

Muchas gracias a los dos!!!!
ç
:woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo:

ResponderCitar
Respondido : 28/04/2011 6:31 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola david,

Si sabia el tema de eliminar traducciones que hayan cambiado en el enlace de menú, sobre todo usando urls no amigables. El tema que no imagine es que plantear un idioma por defecto distinto del que se usa en JoomFish iba a suponer tanto problema con los sufijos .html y la página real que se cargaba. Una cosa más a tener en cuenta. 🙂

Me alegra saber que se solvento con éxito.

Saludos

ResponderCitar
Respondido : 28/04/2011 9:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress