Avisos
Vaciar todo

urls más amigables  

 
Alceste
 Alceste
Noble Member

Hola,
Creo que seguí todos los pasos para que las url se muestren amigables, pero quisiera saber si hay alguna forma de mejorar esto. Por ejemplo, si una url se muestra como sigue:

Contenido solo visible a usuarios registrados

Citar
Respondido : 01/10/2012 5:42 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Alceste

Lo que indicas es el comportamiento por defecto de Joomfish cuando tienes un sitio multiidioma y para el idioma por defecto.

Sin embargo si quieres más flexibilidad lo puedes conseguir utilizando una extensión para urls amigables como :

http://extensions.joomla.org/extensions/site-management/sef/10134
http://extensions.joomla.org/extensions/site-management/sef/10019
http://extensions.joomla.org/extensions/site-management/sef/1063

Saludos.

ResponderCitar
Respondido : 01/10/2012 9:31 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alceste
 Alceste
Noble Member

Hola John,
La extensión TAGMETA también me sirve, ¿verdad?

¿Usando estas extensiones es posible acortar una url como en el ejemplo que detallo a continuación"?

Acortar

http://www.miweb/es/tienda/category/53/ejemplo-uno.html

Por

http://www.miweb/es/tienda/ejemplo-uno.html

Gracias

ResponderCitar
Respondido : 30/10/2012 9:36 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Herramientas de urls amigables permiten acortar las urls como indicas o incluso personalizarlas a tu gusto.

Personalmente no soy nada partidario de usar este tipo de extensiones porque terminan funcionamiento como un paso intermedio entre la url y Joomla y, en ocasiones, puede provocar comportamientos inesperados.

Ten en cuenta que urls como la que quieres acortar no es propiamente una url mala ya que contiene toda la información necesaria para un buen posicionamiento.

ResponderCitar
Respondido : 30/10/2012 1:08 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alceste
 Alceste
Noble Member

HOla,

¿Si sólo las usara para añasir metatags también podría dar problemas o los comportamientos inesperados son sólo si cambian las url?

ResponderCitar
Respondido : 30/10/2012 2:27 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Alceste,

Si quieres mejorar de verdad tus urls amigables a niveles algo más granulados y concretos para elementos de tu sitio lo más propio es que migres de Joomla! 1.5 a Joomla! 2.5 o 3.0.1 para poder gestionar las urls amigables de forma más controlada y sin necesidad de extensiones de terceros, que como bien dice Pablo, acaban causando más problemas que ventajas, sobre todo con extensiones como VirtueMart y más si además trabajas con varios idiomas en la página.

Saludos

ResponderCitar
Respondido : 30/10/2012 2:43 pm

Cursos Gratuitos WordPress

Alceste
 Alceste
Noble Member

Gracias Luís,
El tema es el siguiente. Si usando Joomla 1.5 y VM 1.1.9 puedo conseguir un buen SEO, de modo que las ventajas que obtendría migrando no sean muchas, entonces me sale más a cuenta de momento estirar un poco más las versiones actuales.

Ahora bien, si con Joomla 1.5 y VM 1.1.9 el SEO no va a tener una calidad aceptable y migrando sí que obtendría un muy buen SEO, entonces me plantearé migrar, aunque esto conlleva para mi bastante follón: reservar más espacio para hacer una copia del sitio actual, asegurarme de que los plugins y componentes sean compatibles, ver si una aplicación que habíamos encargado a medida funciona igual (seguramente no) familiarizarme con las nuevas versiones... :unsure:

En resumen, para mí lo óptimo sería alargar las versiones actuales un año y migrar en octubre del 2013. Entonces las nuevas versiones estarían más rodadas y seguramente habrá más plugins y componentes. Por tanto la cuestión es si los inconvenientes que 1.5.26 y VM 1.1.9 tienen en SEO son suficientemente importantes como para avanzar la migración a este mismo año.

ResponderCitar
Respondido : 31/10/2012 7:28 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alceste,

En versiones superiores de Joomla! hay mejoras en relación al SEO, al igual que en Virtuemart. Pero claro todo es plantearse el tema, ya que como indicas es un tema laborioso.

Si deseas incorporar nuevas funcionalidades al sitio web, pues Joomla! 1.5.X deja de recibir soporte, y la versión recomendada actual es la 2.5.X

Si te ha realizado aplicaciones a medida para Joomla 1.5, no funcionará en 2.5. Todo es plantearse en una migración si tiene el conocimiento necesario para realizar, si se desea emplear tiempo, ya que no es un proceso de unos minutos.

Saludos

ResponderCitar
Respondido : 31/10/2012 8:51 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alceste
 Alceste
Noble Member

Gracias,
Lo ideal sería que pudiera alargarlo un poco con las versiones actuales. Lo estudiaremos...

ResponderCitar
Respondido : 31/10/2012 10:03 am