error: WeblinksTableWeblink: :almacenamiento fallido  

 
FCano
 FCano
Usuario eminente

Buenos dias a todos

tengo un error al crear un nuevo enlace web y tambien ayer me dio al crear una nueva categoria

error: WeblinksTableWeblink: :almacenamiento fallido

Se ha producido un fallo al guardar con el siguiente error: WeblinksTableWeblink: :almacenamiento fallido
Unknown column 'attribs' in 'field list' SQL=INSERT INTO `w47fa_weblinks` (`id`,`catid`,`title`,`alias`,`url`,`description`,`state`,`ordering`,`access`,`params`,`language`,`created`,`created_by`,`created_by_alias`,`publish_up`,`publish_down`,`attribs`) VALUES ('0','84','Cancio y Perez Abogados','cancio-y-perez-abogados','http://www.cancioyperezabogados.com ','','1','18','1','{"target":"","width":"","height":"","count_clicks":""}','*','2012-01-16 13:17:17','42','','','','{"myapiimage":0}')

no me deja por tanto crear nuevos enlaces web y nuevas categorias.

Si alguien me puede dar una orientacion y una solucion ya que se escapa de mis conocimientos actuales

muchas gracias

un saludo

Fcano

Citar
Respondido : 16/01/2012 1:30 pm
David Noguera
 David Noguera
Miembro Admin

Hola FCano, dinos que versión de Joomla 1.7 estás usando, es raro que el componente weblinks falle por que forma parte del core de Joomla..

Dinos también que valores pones al crear un weblink.. y si puede ser envía capturas de pantalla justo antes de pulsar en guardar..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/01/2012 3:22 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

FCano
 FCano
Usuario eminente

Hola David

el Joomla que uso es el 1.7.0 de Webempresa

te envio 2 capturas de pantalla de creacion de un nuevo enlace web

y 2 capturas de creacion de una nueva categoria, que me da el mismo error

no me las deja crear, ni almacenar

haber si con esto podemos arreglarlo

un saludo

Fcano

ResponderCitar
Respondido : 16/01/2012 4:25 pm
David Noguera
 David Noguera
Miembro Admin

Hola FCano,

el error SQL dice esto:

Unknown column 'attribs' in 'field list'

Suena a que se ha eliminado la columna attribs de la tabla weblinks, abre con phpMyAdmin la tabla weblinks y comprueba si tiene una columna attribs..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/01/2012 4:36 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

FCano
 FCano
Usuario eminente

Hola David

no tengo esa columna en weblinks

y tampoco tengo esa columna en categories

pero hasta ahora no me habia salido este error y podia crear link web y crear categorias

alguna sugerencia ?

un saludo

Fcano

ResponderCitar
Respondido : 16/01/2012 5:08 pm
FCano
 FCano
Usuario eminente

Hola David

he comprobado con otros paquetes joomla 1.7 webempresa como el que instale

que al instalarlo , las tablas weblink y categories, no tienen la columna atribute, que nos indica en el error

un saludo

Fcano

ResponderCitar
Respondido : 16/01/2012 5:18 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Fcano

Has realizado alguna actualización de Joomla después de haber trabajado tu sitio?
Envíanos la url de tu sitio web para ver detalles.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/01/2012 11:47 pm
David Noguera
 David Noguera
Miembro Admin

Hola FCano, prueba a crear el campo manualmente desde tu phpMyAdmin.. que sea de tipo Text..

Lo que yo también haría es bajarme el último paquete instalable de Joomla 1.7 de JoomlaSpanish y revisar el fichero de instalación SQL para comprobar si este campo realmente existe en la sentencia CREATE TABLE...

Avísanos si no sabes como hacerlo y te indicamos..

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/01/2012 10:05 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

FCano
 FCano
Usuario eminente

No sigo trabajando con la que instale directamente joomla 1.7.0 webempresa

he ido instalando extensiones

www.cmplus.es

un saludo

Fcano

ResponderCitar
Respondido : 17/01/2012 10:11 am
FCano
 FCano
Usuario eminente

Hola David

he comprobado que en el paquete Joomla 1.7 que se instalable que las tablas creadas de categorias y weblink no tienen la columna atributos.

PERO al Crear un Tabla , si que aparece la columna Atributos

un saludo

Fcano

ResponderCitar
Respondido : 17/01/2012 10:15 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David Noguera
 David Noguera
Miembro Admin

Hola FCano,

he estado revisando la estructura de la tabla #__weblinks en el fichero SQL de instalación y realmente no se crea el campo attribs:

#
# Table structure for table `#__weblinks`
#

CREATE TABLE `#__weblinks` (
`id` integer unsigned NOT NULL auto_increment,
`catid` integer NOT NULL default '0',
`sid` integer NOT NULL default '0',
`title` varchar(250) NOT NULL default '',
`alias` varchar(255) NOT NULL default '',
`url` varchar(250) NOT NULL default '',
`description` TEXT NOT NULL,
`date` datetime NOT NULL default '0000-00-00 00:00:00',
`hits` integer NOT NULL default '0',
`state` tinyint(1) NOT NULL default '0',
`checked_out` integer NOT NULL default '0',
`checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00',
`ordering` integer NOT NULL default '0',
`archived` tinyint(1) NOT NULL default '0',
`approved` tinyint(1) NOT NULL default '1',
`access` integer NOT NULL default '1',
`params` text NOT NULL,
`language` char(7) NOT NULL DEFAULT '',
`created` datetime NOT NULL default '0000-00-00 00:00:00',
`created_by` int(10) unsigned NOT NULL default '0',
`created_by_alias` varchar(255) NOT NULL default '',
`modified` datetime NOT NULL default '0000-00-00 00:00:00',
`modified_by` int(10) unsigned NOT NULL default '0',
`metakey` text NOT NULL,
`metadesc` text NOT NULL,
`metadata` text NOT NULL,
`featured` tinyint(3) unsigned NOT NULL default '0' COMMENT 'Establecer si el link aparece.',
`xreference` varchar(50) NOT NULL COMMENT 'Una referencia para activar vínculos a datos externos conjuntos.',
`publish_up` datetime NOT NULL default '0000-00-00 00:00:00',
`publish_down` datetime NOT NULL default '0000-00-00 00:00:00',

PRIMARY KEY (`id`),
KEY `idx_access` (`access`),
KEY `idx_checkout` (`checked_out`),
KEY `idx_state` (`state`),
KEY `idx_catid` (`catid`),
KEY `idx_createdby` (`created_by`),
KEY `idx_featured_catid` (`featured`,`catid`),
KEY `idx_language` (`language`),
KEY `idx_xreference` (`xreference`)
) DEFAULT CHARSET=utf8;

así que el error me parece muy extraño..

Si creas un nuevo paquete Joomla 1.7 bajado desde JoomlaSpanish y tratas de repetir el proceso obtienes el mismo error?? o solo te pasa en tu Paquete Autoinstalable de Webempresa?

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/01/2012 10:29 am
FCano
 FCano
Usuario eminente

Hola David

indicame por favor como crear un campo manualmente de texto en phpMyAdmin

voy a la tabla .... voy a insertar...... y aqui es donde no estoy seguro

un saludo

Fcano

ResponderCitar
Respondido : 17/01/2012 10:38 am

wpdoctor-revisa-la-salud-de-tu-wordpress

FCano
 FCano
Usuario eminente

Hola David

con los que tengo instalados en Local no me pasa, y tengo 2 proyectos.

De momento solo en el que tengo en remoto con vosotros y es el Paquete Webempresa.

www.cmplus.es

Hasta ahora funcionaba todo muy bien

un saludo

Fcano

ResponderCitar
Respondido : 17/01/2012 11:05 am
FCano
 FCano
Usuario eminente

Hola David

acabo de crear un campo de texto con el nombre de "attribs" en la tabla weblinks

y me desaparece el error

Es habitual este tipo de "apaños" en Joomla , es para ir aprediendo....

de todas formas no se si es un fallo general o es un tema puntual

un saludo

Fcano

ResponderCitar
Respondido : 17/01/2012 11:16 am

Cursos Gratuitos WordPress

David Noguera
 David Noguera
Miembro Admin

Hola FCano,

no es habitual para nada este tipo de errores en Joomla, en algunas extensiones si que puede darse el caso, sobre todo en las extensiones de peor calidad, pero en el core de Joomla no suelen haber etse tipo de problemas... paso nota a mis compañeros para que estén al tanto por si hay que hacer alguna modificación en los packs...

Saludos

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/01/2012 12:58 pm

Por favor Iniciar Sesión o Registro