Limpieza de plug-ins  

 
Inma
 Inma
Usuario activo

Hola,

Tengo problemas con algunos componentes de Joomla y además quiero migrar de 1.7 a 2.5 pero antes quiero hacer una limpieza de los plug-ins que no estoy usando.

Para comparar qué puede sobrar necesito saber con qué viene la instalación de Joomla por defecto y qué extensiones he instalado. ¿Alguien me podría pasar unos pantallazos o un listado de los plugins por defecto que vienen en una instalación recién instalada de joomla 1.7.2?

Muchas gracias,

Inma

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 16/04/2013 5:22 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Inma

Revisa la siguiente lista en la imagen adjunta.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/04/2013 5:41 pm

Cursos Gratuitos WordPress

Inma
 Inma
Usuario activo

Hola!

He desinstalado los componentes que no estaba usando pero creo que aun tengo algunos plugins que pueden estar haciendo fallar mi sistema a la hora de hacer comentarios a los artículos por parte de usuarios registrados, tal y como he ido preguntando en otro tema abierto.

En cuanto a la limpieza de plugins necesitaría algo de ayuda.

He capturado pantalla de los plugins que tengo instalados. He remarcado en rojo los que vienen por defecto en Joomla. Y en verde los que tienen un nombre relacionado con alguno de los componentes que uso y reconozco.

El resto no sé muy bien si sobran de algunas desinstalaciones que no hemos hecho bien y sospecho que alguno puede estar dando algún problema de redundancia/incompatibilidad.

¿Cómo puedo saber si los estoy usando realmente en mi web?

¿Alguno de los supuestamente sobrantes podría ser sospechoso de estar dando problemas?

¿Veis alguna incompatibilidad conocida entre varios plugins publicados a la vez?

Mi web tiene un joomla 1.7.2 con los siguientes componentes en uso: Akeeba, Fox contact, iJoomla Surveys y JCE Administration.

Luego tiene algunos módulos para mostrar artículos: TabsGK4, Featured Categories y ARI Image Slider.

El problema de mi web está expuesto en el tema https://www.webempresa.com/foro/20-Joomla%21-17/103770-Comentar-art%C3%ADculos-de-k2-solo-para-usuarios-registrados-en-una-comunidad-virtual.html

Para resumirlo y no tener que releer todo, el problema está en que queremos que los usuarios comenten los artículos de k2 ( http://www.feadulta.org/es/buscadoravanzado/item/3545-no-florezca-en-balde.html) siempre y cuando sean usuarios registrados (registrados/publicador). Al logearse aparece un enlace para dejar el primer comentario pero no carga la caja de los comentarios o más bien la carga pero la deja en blanco. Si activamos la opción para permitir a todos los usuarios hacer comentarios sí que funciona, pero en cuanto decimos que solo los registrados es cuando viene el problema y no carga el editor. Un usuario para hacer pruebas es "pepito" y la clave "publicador". Para logearse o deslogearse en el menú principal, dentro de "portada".

Muchas gracias,

Inma

ResponderCitar
Respondido : 18/04/2013 12:07 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Inma,

Los que tienes en "rojo" no los desinstales, son nativos y los verdes si puedes desinstalarlos si ya no necesitas esas extensiones.

El planteamiento para realizar una migración de Joomla! 1.7.x (preferiblemente de Joomla! 1.7.5) a 2.5 es el siguiente:

- Podrás migrar si tus actuales extensiones ya están disponibles en Joomla! 2.5, lo cual deberás verificar en el JED: http://extensions.joomla.org/search?q=joomla+2.5 y este punto es determinante para que puedas avanzar en la migración.
- NO podrás migrar si tus extensiones no están disponibles para Joomla! 2.5, y esta premisa es fundamental para seguir hablando de migraciones.
- Podrás migrar si ADEMÁS de tus extensiones, tu plantilla en uso esta disponible para Joomla! 2.5.
- Podrás migrar a Joomla! 2.5 si tus extensiones están disponibles para Joomla! 2.5 pero NO deberías migrar si tu plantilla no está disponible para esta rama, o por el contrario tendrás, tras la migración, pasar por un proceso de ADAPTACIÓN de la misma a una liberada para 2.5 y reajuste de módulos a nuevas posiciones.

Recomendación: no realizar una migración sin previamente hacer un respaldo del sitio web, preferiblemente con Akeeba Backup.
-

Es importante que tengas en cuenta que Joomla! 1.7 ya no tiene soporte desde febrero de 2012 y extensiones como Akeeba Backup ya no pueden ser instaladas en Joomla! 1.7.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/04/2013 1:51 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Inma
 Inma
Usuario activo

Hola Luis,

Para la migración tengo a favor que todas las extensiones están disponibles, pero la plantilla no, y además, esta plantilla nos la hicieron a medida y es propia. Supongo que me dará problemas de adaptación y por eso mismo estoy intentando resolver el problema antes de migrar... Por eso abrí este tema nuevo y hay varias preguntas que se han quedado en el tintero de mi anterior entrada.

He puesto en rojo los que sé que son de Joomla y que no debo desinstalar y en verde, los que he reconocido que los estoy usando y tampoco quiero desinstalar. La duda la tengo en el resto... Copio de mi mensaje:

El resto no sé muy bien si sobran de algunas desinstalaciones que no hemos hecho bien y sospecho que alguno puede estar dando algún problema de redundancia/incompatibilidad.

¿Cómo puedo saber si los estoy usando realmente en mi web?

¿Alguno de los supuestamente sobrantes podría ser sospechoso de estar dando problemas?

¿Veis alguna incompatibilidad conocida entre varios plugins publicados a la vez?

Mi web tiene un joomla 1.7.2 con los siguientes componentes en uso: Akeeba, Fox contact, iJoomla Surveys y JCE Administration.

Luego tiene algunos módulos para mostrar artículos: TabsGK4, Featured Categories y ARI Image Slider.

El problema de mi web está expuesto en el tema www.webempresa.com/foro/20-Joomla%21-17/103770-Comentar-art%C3%ADculos-de-k2-solo-para-usuarios-registrados-en-una-comunidad-virtual.html

Para resumirlo y no tener que releer todo, el problema está en que queremos que los usuarios comenten los artículos de k2 (www.feadulta.org/es/buscadoravanzado/item/3545-no-florezca-en-balde.html) siempre y cuando sean usuarios registrados (registrados/publicador). Al logearse aparece un enlace para dejar el primer comentario pero no carga la caja de los comentarios o más bien la carga pero la deja en blanco. Si activamos la opción para permitir a todos los usuarios hacer comentarios sí que funciona, pero en cuanto decimos que solo los registrados es cuando viene el problema y no carga el editor. Un usuario para hacer pruebas es "pepito" y la clave "publicador". Para logearse o deslogearse en el menú principal, dentro de "portada".

Muchas gracias,

Inma

ResponderCitar
Respondido : 18/04/2013 10:59 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Te respondo a las preguntas que planteas:

Cómo puedo saber si los estoy usando realmente en mi web?

Esto es complicado ya que el funcionamiento de los plugins es muy diversos. Algunos actuan de forma directa en la web, como cargar botones de redes sociales y otros solo funcionan en ciertas ocasiones. Tienes que tener en cuenta que desactivando un determinado plugin puedes hacer que no funcione un componente de la web.

¿Alguno de los supuestamente sobrantes podría ser sospechoso de estar dando problemas?

Revisando la lista no veo que haya ninguno que pudiese estar afectando al tema de los comentarios de K2, aunque no se puede estar seguro.

¿Veis alguna incompatibilidad conocida entre varios plugins publicados a la vez?

Respecto a lo que tienes instalado no me parece que pudiera haber incompatibilidades, aunque de nuevo esto no se puede afirmar con rotundidad.

Para el tema de la actualización de tu Joomla te recomiendo que hagas una copia de tu web que restaures en otro directorio y realices las pruebas de actualización en ella. De esta forma, en el caso de que aparezcan problemas no te afectará a la web real. En el caso de que todo vaya bien podrás aplicar los cambios a la web real, siempre realizando una copia de seguridad antes.

Es posible que la plantilla que estás usando en tu Joomla sea compatible con Joomla 2.5 (la mayor parte de las extensiones lo son), pero para ello es mejor que hagas las pruebas.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/04/2013 11:32 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Inma
 Inma
Usuario activo

Hola Pablo,

Y ¿realmente crees que después de migrar a Joomla 2.5 van a desaparecer mis problemas con los comentarios?

Puedo migrar sin problemas porque dispongo de dos webs en dos alojamientos diferentes, en .com está funcionando y en .org tengo una imagen que clono con Akeeba de vez en cuando.

Pero me resisto a montar todo el lío sin intentar resolver el problema antes, a no ser que haya algún indicio o tengas experiencia de que se resuelven algunas cosas cuando se migra. Pues esa es mi pregunta.

Muchas gracias,

Inma

ResponderCitar
Respondido : 18/04/2013 11:39 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por supuesto, no te puedo garantizar que el problema se arregle actualizando Joomla. De hecho lo más probable es que no sea así. Lo importante sería actualizar el componente K2.

En cualquier caso, como te había comentado, esto es algo recomendable debido a que la versión de Joomla que estás usando ya no recibe soporte oficial por lo que si, por ejemplo, se descubre un problema de seguridad este no será corregido con lo que tu web será más vulnerable.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/04/2013 12:07 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Por favor Iniciar Sesión o Registro