No me sale el gestor de extensiones  

 
Rosa
 Rosa
Reputable Member

Hola,
en mi administracion de joomla no me sale el gestor de extensiones, me sale este error:

Fatal error: Call to a member function getQuery() on a non-object in /administrator/components/com_installer/models/manage.php on line 246

He cambiado "new JDatabaseQuery" por "$db->getQuery(true)" pero no funciona.....
alguien sabe qué pasa??

gracias!!!!!!!!!!

Citar
Respondido : 07/11/2011 10:19 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Indícanos la versión de Joomla que estás utilizando, así como si has realizado algún cambio en el código de Joomla que pueda haber afectado a esto.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/11/2011 11:49 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Rosa
 Rosa
Reputable Member

Utilizo 1.7.1. no he tocado nada en joomla porque ni siquiera sabría dónde hay que tocar...! estoy pez.

ResponderCitar
Respondido : 08/11/2011 12:07 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Rosa,

No entiendo:

Utilizo 1.7.1. no he tocado nada en joomla porque ni siquiera sabría dónde hay que tocar...! estoy pez.

pero en cambio indicas

He cambiado "new JDatabaseQuery" por "$db->getQuery(true)" pero no funciona.....
alguien sabe qué pasa??

No es normal que el gestor de extensiones no aparezca, a menos que hayas realizado cambios en código. El error administrator/components/com_installer/models/manage.php on line 246 no vemos que esté documentado.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 08/11/2011 12:18 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rosa
 Rosa
Reputable Member

Jordi,
entiendo que no me entiendas, es que lo único que he cambiado en el código ha sido eso porque en otras ocasiones me he entontrado con problemas de new JDatabaseQuery y siempre se han solucionado sustituyendo por $db->getQuery(true), pero eso es lo unico que he cambiado porque otra cosa no se hacer.

Se te ocurre alguna solución? cambio el archivo administrator/components/com_installer/models/manage.php de mi web por el mismo de otra web que tengo donde no tengo ese problema?
A lo mejor deberia sustituir todos los archivos del gestor de extensiones con los de otra veb que me funciona??

(a todo esto, no se si ayudará pero estos problemas ha surgido a raiz de que pasé de J1.6.3 a 1.7.1..... tanto cambio de archivo pues la he liado....)

ResponderCitar
Respondido : 09/11/2011 9:48 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Rosa

Si has realizado cambios manuales te sugiero recuperar los archivos originales, si tienes un backup de tu sitio mejor.

Ten en cuenta que no siempre las modificaciones que haces en una versión de Joomla funcionan en otra.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/11/2011 4:07 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Rosa
 Rosa
Reputable Member

crees que puedo actulizar a J.1.7.2 y se acabaran estos problemas al ser actulizados los ficheros??

ResponderCitar
Respondido : 10/11/2011 9:05 am
Rosa
 Rosa
Reputable Member

hola a todos,
mi gestor de extensiones ha aparecido!!!! os cuento lo que he hecho:
he actualizado de j1.7.1 a 1.7.2 con el parche. Despues de la actulizacion me salia aun el error:

El error administrator/components/com_installer/models/manage.php on line 246

asi que procedi a remplazar manualmente el fichero manage.php: cogi el del paquete de J1.7.2 que me habia bajado y lo subi via cpanel a mi carpeta administrator/components/com_installer/models/, lo copié (y remplazó asi al fichero existente) y el ERROR HA DESAPARECIDO!!!! y mi gestor funciona.

gracias de todas formas por las pistas

ResponderCitar
Respondido : 10/11/2011 10:35 am

Cursos Gratuitos WordPress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Rosa,

Perfecto que se hayan solucionado los problemas con la actualización. En este caso se ha resuelto, pero no siempre una actualización resuelve problemas, ya que si hay errores en un sitio web, y se produce la actualización, se complica la resolución del problema, ya que entonces es más dificil averiguar que es lo que falla.

Gracias por tener este feedback con los usuarios del foro, explicando la resolución final de problema.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 11/11/2011 12:54 pm

Por favor Iniciar Sesión o Registro